aboutsummaryrefslogtreecommitdiff
path: root/www/gatling
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-02 17:37:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-02 17:37:00 +0000
commit805c1fc00c786fc2ccb3b5a8feff34009df90421 (patch)
tree74be83d9431ca7445f11029e964e2b51bd545cc9 /www/gatling
parentdf4d71f4d9261f3d6c3afc0e032c48afb4a06e84 (diff)
downloadports-805c1fc00c786fc2ccb3b5a8feff34009df90421.tar.gz
ports-805c1fc00c786fc2ccb3b5a8feff34009df90421.zip
- Update to 0.6
PR: ports/76980 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Notes
Notes: svn path=/head/; revision=127921
Diffstat (limited to 'www/gatling')
-rw-r--r--www/gatling/Makefile21
-rw-r--r--www/gatling/distinfo4
-rw-r--r--www/gatling/files/patch-Makefile24
-rw-r--r--www/gatling/files/patch-gatling.c19
4 files changed, 28 insertions, 40 deletions
diff --git a/www/gatling/Makefile b/www/gatling/Makefile
index 9bb02e54542a..ecce27243a31 100644
--- a/www/gatling/Makefile
+++ b/www/gatling/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gatling
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= www benchmarks ftp ipv6
MASTER_SITES= http://dl.fefe.de/
@@ -17,17 +16,21 @@ COMMENT= A high performance webserver with scalability benchmark tools
BUILD_DEPENDS= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/devel/libowfat
USE_BZIP2= yes
+USE_OPENSSL= yes
-MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lowfat" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+CFLAGS+= -I${LOCALBASE}/include/libowfat -I${OPENSSLINC}
+LDFLAGS+= -L${LOCALBASE}/lib -lowfat -L${OPENSSLLIB}
-bin= dl gatling
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+bin= dl
examples= run-gatling
examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
+sbin= gatling tlsgatling
MAN8= gatling.8
.if !defined(NOPORTDOCS)
-PORTDOCS= CHANGES README README.ftp README.http README.performance \
- README.prefetch README.proxy README.redirect
+PORTDOCS= CHANGES README README.ftp README.htaccess README.http \
+ README.performance README.prefetch README.proxy README.redirect
.endif
OPTIONS= BENCHMARKS "Install system benchmark programs" on
@@ -43,13 +46,15 @@ examples+= prep run-bench
.endif
PLIST_DIRS= ${examplesdir}
-PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,}
+PLIST_FILES= ${bin:S,^,bin/,} ${examples:S,^,${examplesdir}/,} \
+ ${sbin:S,^,sbin/,}
pre-install:
@cd ${WRKSRC} && ${CP} gatling.1 gatling.8
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_PROGRAM} ${sbin} ${PREFIX}/sbin
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${examples} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_MAN} ${MAN8} ${MAN8PREFIX}/man/man8
diff --git a/www/gatling/distinfo b/www/gatling/distinfo
index 57155a1b1540..09899c2a3ffc 100644
--- a/www/gatling/distinfo
+++ b/www/gatling/distinfo
@@ -1,2 +1,2 @@
-MD5 (gatling-0.5.tar.bz2) = ee15becac325864afc99cca6f3d08779
-SIZE (gatling-0.5.tar.bz2) = 42576
+MD5 (gatling-0.6.tar.bz2) = 2067d666c01834f2c8702b08644f95d8
+SIZE (gatling-0.6.tar.bz2) = 47267
diff --git a/www/gatling/files/patch-Makefile b/www/gatling/files/patch-Makefile
index 578efbf29c98..0d956eb7de8a 100644
--- a/www/gatling/files/patch-Makefile
+++ b/www/gatling/files/patch-Makefile
@@ -1,13 +1,6 @@
---- Makefile.orig Sat May 8 02:26:21 2004
-+++ Makefile Thu Aug 12 11:37:25 2004
-@@ -2,16 +2,13 @@
- BINDIR=${prefix}/bin
- MANDIR=${prefix}/man
- man1dir=$(MANDIR)/man1
-+CFLAGS+=-I${LOCALBASE}/include/libowfat
-
- TARGET=gatling httpbench dl bindbench mmapbench forkbench pthreadbench \
- mktestdata manymapbench ioerr forksbench
+--- Makefile.orig Tue Feb 1 17:50:50 2005
++++ Makefile Tue Feb 1 17:53:20 2005
+@@ -8,10 +8,6 @@
all: $(TARGET)
@@ -18,7 +11,7 @@
gatling: gatling.o libsocket libiconv
$(CC) -o $@ gatling.o $(LDFLAGS) `cat libsocket libiconv`
-@@ -34,7 +31,7 @@
+@@ -34,7 +30,7 @@
$(CC) -static -o $@ forkbench.o $(LDFLAGS)
pthreadbench: pthreadbench.o
@@ -27,3 +20,12 @@
mktestdata: mktestdata.o
$(CC) -o $@ mktestdata.o $(LDFLAGS)
+@@ -50,7 +50,7 @@
+ $(CC) -c $< -I. $(CFLAGS)
+
+ tlsgatling: gatling.c ssl.o
+- $(CC) -o $@ $(CFLAGS) $^ $(LDFLAGS) -lssl -lcrypto $(LDLIBS)
++ $(CC) -o $@ $(CFLAGS) $> -DSUPPORT_HTTPS $(LDFLAGS) -lssl -lcrypto $(LDLIBS)
+
+ libsocket: trysocket.c
+ if $(DIET) $(CC) $(CFLAGS) -o trysocket trysocket.c >/dev/null 2>&1; then echo ""; else \
diff --git a/www/gatling/files/patch-gatling.c b/www/gatling/files/patch-gatling.c
deleted file mode 100644
index 8952ed9e6495..000000000000
--- a/www/gatling/files/patch-gatling.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- gatling.c.orig Wed Jul 28 15:23:51 2004
-+++ gatling.c Mon Jan 31 18:42:03 2005
-@@ -1261,6 +1261,7 @@ e404:
- ++c;
- if ((i=scan_ulonglong(c,&range_last))) {
- if (!i) goto rangeerror;
-+ ++range_last;
- }
- }
- } else {
-@@ -1311,7 +1312,7 @@ rangeerror:
- c+=fmt_str(c,"\r\nContent-Range: bytes ");
- c+=fmt_ulonglong(c,range_first);
- c+=fmt_str(c,"-");
-- c+=fmt_ulonglong(c,range_last);
-+ c+=fmt_ulonglong(c,range_last-1);
- c+=fmt_str(c,"/");
- c+=fmt_ulonglong(c,ss.st_size);
- }