aboutsummaryrefslogtreecommitdiff
path: root/www/gitlab-ce
diff options
context:
space:
mode:
authorVVD <vvd@unislabs.com>2022-03-10 16:47:12 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-03-10 16:47:12 +0000
commitccc9d98b47ff35cda47a10094e7777d962c48108 (patch)
treee007df6ca6faf8d419b43f6b55e3d057ad839b2e /www/gitlab-ce
parent7e2c5f5e88e905b3ca8620a44f0fe820bc6efac8 (diff)
downloadports-ccc9d98b47ff35cda47a10094e7777d962c48108.tar.gz
ports-ccc9d98b47ff35cda47a10094e7777d962c48108.zip
www/gitlab-ce: add option to remove kerberos dep
I understand that this option can be helpful, but I do not suggest to use it. If it breaks due to new version and the patch does not apply anymore, please send a PR then I will update this feature accordingly. But I will not testbuild gitlab with many option combinations. PR: 262191
Diffstat (limited to 'www/gitlab-ce')
-rw-r--r--www/gitlab-ce/Makefile10
-rw-r--r--www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off11
2 files changed, 19 insertions, 2 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index c4700a883383..69a66f822686 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gitlab-ce
PORTVERSION= 14.8.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -53,7 +53,6 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-omniauth-github>=1.4.0<2.0:net/rubygem-omniauth-github \
rubygem-omniauth-gitlab>=1.0.2<1.1.0:security/rubygem-omniauth-gitlab \
rubygem-omniauth-google-oauth2>=0.6.0<0.7.0:net/rubygem-omniauth-google-oauth2 \
- rubygem-omniauth-kerberos>=0.3.0<0.4.0:net/rubygem-omniauth-kerberos \
rubygem-omniauth-oauth2-generic>=0.2.2<0.3.0:security/rubygem-omniauth-oauth2-generic \
rubygem-omniauth-saml>=1.10<2.0:security/rubygem-omniauth-saml \
rubygem-omniauth-shibboleth>=1.3.0<1.4.0:security/rubygem-omniauth-shibboleth \
@@ -284,6 +283,13 @@ NO_BUILD= yes
NO_ARCH= yes
+OPTIONS_DEFINE= KERBEROS
+OPTIONS_DEFAULT= KERBEROS
+
+KERBEROS_BUILD_DEPENDS= rubygem-omniauth-kerberos>=0.3.0<0.4.0:net/rubygem-omniauth-kerberos
+KERBEROS_RUN_DEPENDS= rubygem-omniauth-kerberos>=0.3.0<0.4.0:net/rubygem-omniauth-kerberos
+KERBEROS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Gemfile-kerberos-off
+
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config/gitlab.yml.example \
${WRKSRC}/config/puma.rb.example \
diff --git a/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off b/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off
new file mode 100644
index 000000000000..7e641a198558
--- /dev/null
+++ b/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off
@@ -0,0 +1,11 @@
+--- Gemfile.orig 2022-01-21 10:23:10 UTC
++++ Gemfile
+@@ -43,7 +43,7 @@
+ gem 'omniauth-github', '~> 1.4'
+ gem 'omniauth-gitlab', '~> 1.0.2'
+ gem 'omniauth-google-oauth2', '~> 0.6.0'
+-gem 'omniauth-kerberos', '~> 0.3.0', group: :kerberos
++#gem 'omniauth-kerberos', '~> 0.3.0', group: :kerberos
+ gem 'omniauth-oauth2-generic', '~> 0.2.2'
+ gem 'omniauth-saml', '~> 1.10'
+ gem 'omniauth-shibboleth', '~> 1.3.0'