aboutsummaryrefslogtreecommitdiff
path: root/www/gitlab-pages
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-05-19 02:50:12 +0000
committerSteve Wills <swills@FreeBSD.org>2018-05-19 02:50:12 +0000
commit5e26b76258b0f3c601d867dc24aaf6b638963d35 (patch)
treef35d3b8cb7bb5e2245de9a5927c1bbd3d57d15a7 /www/gitlab-pages
parent5ccb1b712abb41311c44d3793e603fcb26d1cd5f (diff)
downloadports-5e26b76258b0f3c601d867dc24aaf6b638963d35.tar.gz
ports-5e26b76258b0f3c601d867dc24aaf6b638963d35.zip
www/gitlab-pages: update to 0.9.1
Notes
Notes: svn path=/head/; revision=470353
Diffstat (limited to 'www/gitlab-pages')
-rw-r--r--www/gitlab-pages/Makefile5
-rw-r--r--www/gitlab-pages/distinfo6
-rw-r--r--www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__fileno.go12
-rw-r--r--www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__ino.go12
-rw-r--r--www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir.go46
-rw-r--r--www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir__unix.go17
-rw-r--r--www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_walk.go13
7 files changed, 105 insertions, 6 deletions
diff --git a/www/gitlab-pages/Makefile b/www/gitlab-pages/Makefile
index 8f6db43db9bf..90962ee106aa 100644
--- a/www/gitlab-pages/Makefile
+++ b/www/gitlab-pages/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gitlab-pages
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= www
MAINTAINER= swills@FreeBSD.org
@@ -16,7 +15,7 @@ BUILD_DEPENDS= go:lang/go
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find the here: https://gitlab.com/gitlab-org/gitlab-pages/tags
-GL_COMMIT= 4e11c8392935e1f4dbd96066f3cbb8d657afd874
+GL_COMMIT= 69b7e196fe0336c91a44da72110f44c2ec0869b0
PLIST_FILES= bin/gitlab-pages
diff --git a/www/gitlab-pages/distinfo b/www/gitlab-pages/distinfo
index acb4236175cd..13413e710fcf 100644
--- a/www/gitlab-pages/distinfo
+++ b/www/gitlab-pages/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1523370266
-SHA256 (gitlab-org-gitlab-pages-4e11c8392935e1f4dbd96066f3cbb8d657afd874_GL0.tar.gz) = fc0892141f241af9eb63e8fab65137948f5bb8fa5670b86ff87d9d82eb57fa12
-SIZE (gitlab-org-gitlab-pages-4e11c8392935e1f4dbd96066f3cbb8d657afd874_GL0.tar.gz) = 1076893
+TIMESTAMP = 1526695044
+SHA256 (gitlab-org-gitlab-pages-69b7e196fe0336c91a44da72110f44c2ec0869b0_GL0.tar.gz) = d993cb8c584d0366837e723f29bee9a3fb67ea0044448f185dc6cec255ff1f39
+SIZE (gitlab-org-gitlab-pages-69b7e196fe0336c91a44da72110f44c2ec0869b0_GL0.tar.gz) = 1692719
diff --git a/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__fileno.go b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__fileno.go
new file mode 100644
index 000000000000..8abd49be0fc3
--- /dev/null
+++ b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__fileno.go
@@ -0,0 +1,12 @@
+--- vendor/github.com/karrick/godirwalk/dirent_fileno.go.orig 2018-05-19 02:10:07 UTC
++++ vendor/github.com/karrick/godirwalk/dirent_fileno.go
+@@ -0,0 +1,9 @@
++// +build dragonfly freebsd openbsd netbsd
++
++package godirwalk
++
++import "syscall"
++
++func direntIno(de *syscall.Dirent) uint64 {
++ return uint64(de.Fileno)
++}
diff --git a/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__ino.go b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__ino.go
new file mode 100644
index 000000000000..bffd9e400f03
--- /dev/null
+++ b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_dirent__ino.go
@@ -0,0 +1,12 @@
+--- vendor/github.com/karrick/godirwalk/dirent_ino.go.orig 2018-05-19 02:10:07 UTC
++++ vendor/github.com/karrick/godirwalk/dirent_ino.go
+@@ -0,0 +1,9 @@
++// +build darwin linux
++
++package godirwalk
++
++import "syscall"
++
++func direntIno(de *syscall.Dirent) uint64 {
++ return de.Ino
++}
diff --git a/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir.go b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir.go
new file mode 100644
index 000000000000..a5f9c819de58
--- /dev/null
+++ b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir.go
@@ -0,0 +1,46 @@
+--- vendor/github.com/karrick/godirwalk/readdir.go.orig 2018-04-30 10:37:07 UTC
++++ vendor/github.com/karrick/godirwalk/readdir.go
+@@ -2,6 +2,9 @@ package godirwalk
+
+ import (
+ "os"
++ "path/filepath"
++
++ "github.com/pkg/errors"
+ )
+
+ // Dirent stores the name and file system mode type of discovered file system
+@@ -11,6 +14,22 @@ type Dirent struct {
+ modeType os.FileMode
+ }
+
++// NewDirent returns a newly initialized Dirent structure, or an error. This
++// function does not follow symbolic links.
++//
++// This function is rarely used, as Dirent structures are provided by other
++// functions in this library that read and walk directories.
++func NewDirent(osPathname string) (*Dirent, error) {
++ fi, err := os.Lstat(osPathname)
++ if err != nil {
++ return nil, errors.Wrap(err, "cannot lstat")
++ }
++ return &Dirent{
++ name: filepath.Base(osPathname),
++ modeType: fi.Mode() & os.ModeType,
++ }, nil
++}
++
+ // Name returns the basename of the file system entry.
+ func (de Dirent) Name() string { return de.name }
+
+@@ -28,6 +47,10 @@ func (de Dirent) ModeType() os.FileMode { return de.mo
+ // may be set for a node. For instance, on Windows, a symbolic link that points
+ // to a directory will have both the directory and the symbolic link bits set.
+ func (de Dirent) IsDir() bool { return de.modeType&os.ModeDir != 0 }
++
++// IsRegular returns true if and only if the Dirent represents a regular
++// file. That is, it ensures that no mode type bits are set.
++func (de Dirent) IsRegular() bool { return de.modeType&os.ModeType == 0 }
+
+ // IsSymlink returns true if and only if the Dirent represents a file system
+ // symbolic link. Note that on some operating systems, more than one file mode
diff --git a/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir__unix.go b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir__unix.go
new file mode 100644
index 000000000000..9767965a5032
--- /dev/null
+++ b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_readdir__unix.go
@@ -0,0 +1,17 @@
+--- vendor/github.com/karrick/godirwalk/readdir_unix.go.orig 2018-04-30 10:37:07 UTC
++++ vendor/github.com/karrick/godirwalk/readdir_unix.go
+@@ -1,4 +1,4 @@
+-// +build darwin dragonfly freebsd linux nacl netbsd openbsd solaris
++// +build darwin freebsd linux netbsd openbsd
+
+ package godirwalk
+
+@@ -49,7 +49,7 @@ func readdirents(osDirname string, scratchBuffer []byt
+ de = (*syscall.Dirent)(unsafe.Pointer(&buf[0])) // point entry to first syscall.Dirent in buffer
+ buf = buf[de.Reclen:] // advance buffer
+
+- if de.Ino == 0 {
++ if direntIno(de) == 0 {
+ continue // this item has been deleted, but not yet removed from directory
+ }
+
diff --git a/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_walk.go b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_walk.go
new file mode 100644
index 000000000000..931ba1cbe0b9
--- /dev/null
+++ b/www/gitlab-pages/files/patch-vendor_github.com_karrick_godirwalk_walk.go
@@ -0,0 +1,13 @@
+--- vendor/github.com/karrick/godirwalk/walk.go.orig 2018-04-30 10:37:07 UTC
++++ vendor/github.com/karrick/godirwalk/walk.go
+@@ -188,6 +188,10 @@ func Walk(pathname string, options *Options) error {
+ options.ErrorCallback = defaultErrorCallback
+ }
+
++ if options.ScratchBuffer == nil {
++ options.ScratchBuffer = make([]byte, 64*1024)
++ }
++
+ err = walk(pathname, dirent, options)
+ if err == filepath.SkipDir {
+ return nil // silence SkipDir for top level