aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-26 00:28:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-26 00:28:39 +0000
commit2bb5031fd7e8f3ba1824ea304eed15482b3e337f (patch)
treee91f13817ad900f1ec308d50c87045fecdd08b11 /www/gnome-user-share/Makefile
parent007634e3264aa027efbd3417255b1f3a8c7cda05 (diff)
downloadports-2bb5031fd7e8f3ba1824ea304eed15482b3e337f.tar.gz
ports-2bb5031fd7e8f3ba1824ea304eed15482b3e337f.zip
Support stage
Use USES=libtool Strip binaries
Notes
Notes: svn path=/head/; revision=352197
Diffstat (limited to 'www/gnome-user-share/Makefile')
-rw-r--r--www/gnome-user-share/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index a885a721f3be..2d13d390cd9f 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-user-share
PORTVERSION= 2.30.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -11,27 +11,26 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Personal file-sharing service for the GNOME Desktop
-LIB_DEPENDS= avahi-client:${PORTSDIR}/net/avahi-app \
- canberra.0:${PORTSDIR}/audio/libcanberra \
- notify.4:${PORTSDIR}/devel/libnotify \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app \
+ libcanberra.so:${PORTSDIR}/audio/libcanberra \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd \
console-kit-daemon:${PORTSDIR}/sysutils/consolekit
-USE_BZIP2= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake libtool pkgconfig tar:bzip2
USE_APACHE= 22
USE_XORG= sm
-USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 gnomedocutils nautilus2
+USE_GNOME= gnomeprefix intlhack gtk20 gconf2 gnomedocutils nautilus2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --with-modules-path=${LOCALBASE}/${APACHEMODDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
GCONF_SCHEMAS= desktop_gnome_file_sharing.schemas
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/etc/httpd/modules|${LOCALBASE}/${APACHEMODDIR}|g' \
${WRKSRC}/data/dav_user_*.conf