aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /www/gnome-user-share/Makefile
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
downloadports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.tar.gz
ports-ae52bc80895a23ddbe33b86e75a9cf331ae32ba9.zip
Presenting GNOME 2.26 for FreeBSD. See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach.
Notes
Notes: svn path=/head/; revision=231972
Diffstat (limited to 'www/gnome-user-share/Makefile')
-rw-r--r--www/gnome-user-share/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 0d820afb4956..9e0bc6e9af8e 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/gnome-user-share/Makefile,v 1.8 2008/02/24 20:36:08 marcus Exp $
+# $MCom: ports/www/gnome-user-share/Makefile,v 1.14 2009/03/17 13:35:33 kwm Exp $
#
PORTNAME= gnome-user-share
-PORTVERSION= 0.31
-PORTREVISION= 2
+PORTVERSION= 2.26.0
+PORTREVISION= 0
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,16 +16,18 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Personal file-sharing service for the GNOME Desktop
-LIB_DEPENDS= avahi-client:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= avahi-client:${PORTSDIR}/net/avahi-app \
+ notify.1:${PORTSDIR}/devel/libnotify
+RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_APACHE= 2.0+
-USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2
+USE_APACHE= 2.2+
+USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --disable-howl --with-modules-path=${LOCALBASE}/${APACHEMODDIR}
+CONFIGURE_ARGS= --with-modules-path=${LOCALBASE}/${APACHEMODDIR}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"