aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /www/gnome-user-share/Makefile
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Presenting GNOME 2.28.1 for FreeBSD. The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ . Officially, this is mostly a polishing release in preparation for GNOME 3.0 due in about a year. On the FreeBSD front, though, a lot went into this release. Major thanks goes to kwm and avl who did a lot of the porting work for this release. In particular, kwm brought in Evolution MAPI support for better Microsoft Exchange integration. Avl made sure that the new gobject introspection repository ports were nicely compartmentalized so that large dependencies aren't brought in wholesale. But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself) contributed to this release. Other major improvements include an updated HAL with better volume probing code, ufsid integration, and support for volume names containing spaces (big thanks to J.R. Oldroyd); a new WebKit; updated AbiWord; an updated Gimp; and a preview of the new GNOME Shell project (thanks to Pawel Worach). The FreeBSD GNOME Team would like to that the following additional contributors to this release whose patches and testing really helped make it a success: Andrius Morkunas Dominique Goncalves Eric L. Chen J.R. Oldroyd Joseph S. Atkinson Li Pawel Worach Romain Tartière Thomas Vogt Yasuda Keisuke Rui Paulo Martin Wilke (and an extra shout out to miwi and pav for pointyhat runs) We would like to send this release out to Alexander Loginov (avl) in hopes that he feels better soon. PR: 136676 136967 138872 (obsolete with new epiphany-webkit) 139160 134737 139941 140097 140838 140929
Notes
Notes: svn path=/head/; revision=244923
Diffstat (limited to 'www/gnome-user-share/Makefile')
-rw-r--r--www/gnome-user-share/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 3528bd5cb8e0..3f47df649814 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/gnome-user-share/Makefile,v 1.14 2009/03/17 13:35:33 kwm Exp $
+# $MCom: ports/www/gnome-user-share/Makefile,v 1.17 2009/10/27 11:20:53 kwm Exp $
#
PORTNAME= gnome-user-share
-PORTVERSION= 2.26.0
-PORTREVISION= 1
+PORTVERSION= 2.28.1
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,14 +16,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Personal file-sharing service for the GNOME Desktop
LIB_DEPENDS= avahi-client:${PORTSDIR}/net/avahi-app \
+ canberra.0:${PORTSDIR}/audio/libcanberra \
notify.1:${PORTSDIR}/devel/libnotify
-RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd
+RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd \
+ console-kit-daemon:${PORTSDIR}/sysutils/consolekit
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_APACHE= 2.2+
-USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2 gnomedocutils
+USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --with-modules-path=${LOCALBASE}/${APACHEMODDIR}