aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-web-photo/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-01-12 23:06:38 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-01-12 23:06:38 +0000
commit6b84df32e5a37bf5c082883c2f2f89a8938c80bb (patch)
tree35f5aace53e1f1ace8eb5cfeb5a50c4950e88c49 /www/gnome-web-photo/Makefile
parenta686996a9d8527c40a7e8a4a1ca6632529e083f6 (diff)
downloadports-6b84df32e5a37bf5c082883c2f2f89a8938c80bb.tar.gz
ports-6b84df32e5a37bf5c082883c2f2f89a8938c80bb.zip
- Add gnome-web-photo
GNOME Web Photographer is a tool to generate full-size image files and thumbnails from HTML files and web pages.
Notes
Notes: svn path=/head/; revision=153375
Diffstat (limited to 'www/gnome-web-photo/Makefile')
-rw-r--r--www/gnome-web-photo/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
new file mode 100644
index 000000000000..876503d108b7
--- /dev/null
+++ b/www/gnome-web-photo/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnome-web-photo
+# Date created: 2005-11-30
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/www/gnome-web-photo/Makefile,v 1.1 2005/12/01 06:25:42 ahze Exp $
+#
+
+PORTNAME= gnome-web-photo
+PORTVERSION= 0.1.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.1
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Tool to generate full-size image files and thumbnails
+
+USE_BZIP2= yes
+USE_GECKO= firefox seamonkey
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ARGS= --with-gecko=${GECKO}
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomevfs2 gnomehack
+GCONF_SCHEMAS= thumbnailer.schemas
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libpng|libpng12|' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>