aboutsummaryrefslogtreecommitdiff
path: root/www/gtkhtml3
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-22 10:44:29 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-22 10:44:29 +0000
commit3e4a806167fd4921ccc48623317dc31d7ab4f276 (patch)
tree2e1c942caa79a250b3baeb557ee3445960e10d70 /www/gtkhtml3
parentd9b2d0f0da5b6f85f90547429dadaa903033f59a (diff)
downloadports-3e4a806167fd4921ccc48623317dc31d7ab4f276.tar.gz
ports-3e4a806167fd4921ccc48623317dc31d7ab4f276.zip
Add 4 new sed commands to USES=libtool. The first two apply some of the
changes that Debian made to their libtool. The first command applies to libtool versions 1.4 and up. The second command is somewhat more elaborate but essentially it uses the sed hold space to move an "elif...fi" block down. It applies to 2.x. Together these reduce overlinking to unpatched .la files (from ports that don't have USES=libtool yet but also .la files in the work directory). The third and fourth command fix relinking. During staging libtool may relink libA when it links to another library in the work directory libB. The reason is that libA created during build phase has its runpath set to the location of libB in the work directory. This allows running an executable that links to libA from within the work directory. The relink removes this extra runpath. When libtool relinks libA it replaces "libB.la" on the linker command line with "-L${STAGEDIR}${PREFIX}/lib -lB" with the intention to link to libB in the stage directory but this -L flag isn't necessarily the first so another libB may be linked instead. The two sed commands make relink the same as a normal link. This means libtool will relink with libraries from the work directory using a path similar to "../srcB/.libs/libB.so" without -L flags. This applies to libtool 1.4 and up. Earlier versions don't seem to relink libraries. (This fixes ports like devel/apr1 so they link with freshly built libraries instead of installed libraries.) Fix all ports with missing libraries. Additionally: archivers/rpm4: USES=patchfix. databases/gdbm: INSTALL_TARGET=install-strip. devel/gnome-vfs: remove patch that doesn't change anything. devel/ois: INSTALL_TARGET=install-strip and use standard USE_AUTOTOOLS. devel/zziplib: INSTALL_TARGET=install-strip, MAKE_CMD. multimedia/mjpegtools: remove USE_AUTOTOOLS, use modern compiler on i386 instead of disabling optimisations. net/libnetdude: disable static plugins. PR: 190941 Exp-run: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=358784
Diffstat (limited to 'www/gtkhtml3')
-rw-r--r--www/gtkhtml3/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index 33b6e2956eb0..521c26390d45 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USES= gettext libtool:keepla pathfix pkgconfig gmake tar:bzip2
USE_XORG= xinerama xi xrandr xcursor xcomposite xdamage
-USE_GNOME= gnomeprefix intlhack gconf2
+USE_GNOME= gnomeprefix intlhack gconf2 gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -41,6 +41,8 @@ post-patch:
s|-DGDK_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gtkhtml-editor-test[$$]|gtkhtml3-editor-test$$|' \
+ -e '/^gtkhtml_editor_test_LDADD =/s/=/= @GTKHTML_LIBS@/' \
+ -e 's/$$(GTHREAD_LIBS)/-lgthread-2.0/' \
${WRKSRC}/components/editor/Makefile.in
@${REINPLACE_CMD} -e 's|G_CONST_RETURN||g' \
${WRKSRC}/a11y/*.[ch]