aboutsummaryrefslogtreecommitdiff
path: root/www/harvest
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-11-23 15:29:50 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-11-23 15:29:50 +0000
commitcd895d43859a50bd8450c7f276b04e298e03cbd9 (patch)
treedc2d1abcce5de4b16f4aa5cd9c8168d5110094ca /www/harvest
parente8c072775e28bde36a11a10d38d536694627d275 (diff)
downloadports-cd895d43859a50bd8450c7f276b04e298e03cbd9.tar.gz
ports-cd895d43859a50bd8450c7f276b04e298e03cbd9.zip
Update to 1.8.2.
PR: ports/45630 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=70864
Diffstat (limited to 'www/harvest')
-rw-r--r--www/harvest/Makefile2
-rw-r--r--www/harvest/distinfo2
-rw-r--r--www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c11
-rw-r--r--www/harvest/files/patch-components::gatherer::WordPerfect::wp3x-2.3::wp2x.c11
-rw-r--r--www/harvest/files/patch-src::gatherer::essence::file::print.c13
-rw-r--r--www/harvest/files/patch-wp2x.c10
-rw-r--r--www/harvest/pkg-plist20
7 files changed, 39 insertions, 30 deletions
diff --git a/www/harvest/Makefile b/www/harvest/Makefile
index 7c4c7e486921..caa4a43cb4dd 100644
--- a/www/harvest/Makefile
+++ b/www/harvest/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= harvest
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/harvest/distinfo b/www/harvest/distinfo
index 8881e1c932d5..883c68677aa7 100644
--- a/www/harvest/distinfo
+++ b/www/harvest/distinfo
@@ -1 +1 @@
-MD5 (harvest-1.8.1.tar.bz2) = 9425a081d215686f55bf13efecd02bd0
+MD5 (harvest-1.8.2.tar.bz2) = c7b2e646d16dc5760c4d60273c244678
diff --git a/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c b/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c
index 1622f8058eed..70f84a7d6007 100644
--- a/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c
+++ b/www/harvest/files/patch-components::broker::standard::WWW::DisplayObject.c
@@ -1,12 +1,15 @@
--- components/broker/standard/WWW/DisplayObject.c.orig Mon Feb 11 07:57:16 2002
-+++ components/broker/standard/WWW/DisplayObject.c Wed Nov 13 09:01:03 2002
-@@ -215,8 +215,8 @@
++++ components/broker/standard/WWW/DisplayObject.c Sat Nov 23 04:30:56 2002
+@@ -214,10 +214,12 @@
+ */
char *xstrerror(n)
int n;
++#if !defined(__FreeBSD__)
{
-- extern int sys_nerr;
+ extern int sys_nerr;
#ifdef NEED_SYS_ERRLIST
-+ extern int sys_nerr;
extern char *sys_errlist[];
++#endif
#endif
+ if (n < 0 || n >= sys_nerr)
diff --git a/www/harvest/files/patch-components::gatherer::WordPerfect::wp3x-2.3::wp2x.c b/www/harvest/files/patch-components::gatherer::WordPerfect::wp3x-2.3::wp2x.c
new file mode 100644
index 000000000000..340a3073c914
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::WordPerfect::wp3x-2.3::wp2x.c
@@ -0,0 +1,11 @@
+--- components/gatherer/WordPerfect/wp2x-2.3/wp2x.c.orig Sat Nov 16 08:09:53 2002
++++ components/gatherer/WordPerfect/wp2x-2.3/wp2x.c Sat Nov 23 04:42:43 2002
+@@ -151,7 +151,7 @@
+ #include "patchlevel.h"
+
+ /* Some platforms do not define these externals in stdlib.h */
+-#ifndef __CYGWIN__
++#if !defined(__CYGWIN__) && !defined(__FreeBSD__)
+ #if NEED_SYS_ERRLIST || __GLIBC__
+ extern char *Cdecl sys_errlist[];
+ #endif
diff --git a/www/harvest/files/patch-src::gatherer::essence::file::print.c b/www/harvest/files/patch-src::gatherer::essence::file::print.c
index bf01e67fa518..8c14537e95d0 100644
--- a/www/harvest/files/patch-src::gatherer::essence::file::print.c
+++ b/www/harvest/files/patch-src::gatherer::essence::file::print.c
@@ -1,12 +1,15 @@
---- src/gatherer/essence/file/print.c.orig Sat Dec 13 01:02:15 1997
-+++ src/gatherer/essence/file/print.c Wed Nov 13 08:56:34 2002
-@@ -78,8 +78,8 @@
+--- src/gatherer/essence/file/print.c.orig Sat Nov 16 08:09:53 2002
++++ src/gatherer/essence/file/print.c Sat Nov 23 04:28:48 2002
+@@ -78,10 +78,12 @@
warning(f, a)
char *f, *a;
{
-- extern int errno, sys_nerr;
++#if !defined(__FreeBSD__)
+ extern int errno, sys_nerr;
+ #ifndef __CYGWIN__
#ifdef NEED_SYS_ERRLIST
-+ extern int errno, sys_nerr;
extern char *sys_errlist[];
++#endif
+ #endif
#endif
int myerrno;
diff --git a/www/harvest/files/patch-wp2x.c b/www/harvest/files/patch-wp2x.c
deleted file mode 100644
index d3fd9005be79..000000000000
--- a/www/harvest/files/patch-wp2x.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- components/gatherer/WordPerfect/wp2x-2.3/wp2x.c.orig Thu Nov 21 11:33:54 2002
-+++ components/gatherer/WordPerfect/wp2x-2.3/wp2x.c Thu Nov 21 13:13:25 2002
-@@ -155,7 +155,6 @@
- extern char *Cdecl sys_errlist[];
- #endif
- extern int Cdecl errno;
--extern int Cdecl sys_nerr;
-
- /************************************************************************/
- /* Some common idioms */
diff --git a/www/harvest/pkg-plist b/www/harvest/pkg-plist
index c207dae8be21..13d4000ec91b 100644
--- a/www/harvest/pkg-plist
+++ b/www/harvest/pkg-plist
@@ -27,6 +27,7 @@ harvest/brokers/skeleton/admin/broker.conf.in
harvest/brokers/skeleton/query-glimpse-modern.html.de.in
harvest/brokers/skeleton/query-glimpse-modern.html.es.in
harvest/brokers/skeleton/query-glimpse-modern.html.in
+harvest/brokers/skeleton/query-glimpse-modern.html.ru.in
harvest/brokers/skeleton/query-glimpse.html.in
harvest/brokers/skeleton/query-swish-modern.html.in
harvest/brokers/skeleton/query-swish.html.in
@@ -39,6 +40,7 @@ harvest/cgi-bin/lib/Sample.cf
harvest/cgi-bin/lib/classic.cf
harvest/cgi-bin/lib/german.cf
harvest/cgi-bin/lib/modern.cf
+harvest/cgi-bin/lib/russian.cf
harvest/cgi-bin/lib/search.cf
harvest/cgi-bin/lib/spanish.cf
harvest/cgi-bin/nph-search.cgi
@@ -146,15 +148,15 @@ harvest/lib/gatherer/catdoc-lib/8859-8.txt
harvest/lib/gatherer/catdoc-lib/8859-9.txt
harvest/lib/gatherer/catdoc-lib/ascii.replchars
harvest/lib/gatherer/catdoc-lib/ascii.specchars
-harvest/lib/gatherer/catdoc-lib/cp2250.txt
-harvest/lib/gatherer/catdoc-lib/cp2251.txt
-harvest/lib/gatherer/catdoc-lib/cp2252.txt
-harvest/lib/gatherer/catdoc-lib/cp2253.txt
-harvest/lib/gatherer/catdoc-lib/cp2254.txt
-harvest/lib/gatherer/catdoc-lib/cp2255.txt
-harvest/lib/gatherer/catdoc-lib/cp2256.txt
-harvest/lib/gatherer/catdoc-lib/cp2257.txt
-harvest/lib/gatherer/catdoc-lib/cp2258.txt
+harvest/lib/gatherer/catdoc-lib/cp1250.txt
+harvest/lib/gatherer/catdoc-lib/cp1251.txt
+harvest/lib/gatherer/catdoc-lib/cp1252.txt
+harvest/lib/gatherer/catdoc-lib/cp1253.txt
+harvest/lib/gatherer/catdoc-lib/cp1254.txt
+harvest/lib/gatherer/catdoc-lib/cp1255.txt
+harvest/lib/gatherer/catdoc-lib/cp1256.txt
+harvest/lib/gatherer/catdoc-lib/cp1257.txt
+harvest/lib/gatherer/catdoc-lib/cp1258.txt
harvest/lib/gatherer/catdoc-lib/cp437.txt
harvest/lib/gatherer/catdoc-lib/cp850.txt
harvest/lib/gatherer/catdoc-lib/cp852.txt