aboutsummaryrefslogtreecommitdiff
path: root/www/horde4-base/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-12-12 15:16:56 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-12-12 15:16:56 +0000
commitcd4b5e26f1f107f63d1df5461afe8a66829dc3ec (patch)
tree3fb7d6080e4c46250a144599804046174e893258 /www/horde4-base/Makefile
parent17ceff765800de56a99184d5868cc6c54dd38812 (diff)
downloadports-cd4b5e26f1f107f63d1df5461afe8a66829dc3ec.tar.gz
ports-cd4b5e26f1f107f63d1df5461afe8a66829dc3ec.zip
Update horde4 packages and applications to horde5
Notes
Notes: svn path=/head/; revision=308772
Diffstat (limited to 'www/horde4-base/Makefile')
-rw-r--r--www/horde4-base/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index e28fd2f8606b..89e17da0fb36 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= horde
-PORTVERSION= 4.0.16
-PKGNAMEPREFIX=
+PORTVERSION= 5.0.2
CATEGORIES= www pear
+PKGNAMEPREFIX=
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Application Framework
@@ -17,10 +17,13 @@ CONFLICTS= horde-3*
RUN_DEPENDS= ${PEARDIR}/Net/DNS2.php:${PORTSDIR}/dns/pear-Net_DNS2
-OPTIONS= FACEBOOK "Support connections to Facebook" Off \
- ICONV "Depend on PHP iconv extension" On \
- TWITTER "Support connections to Twitter" Off \
- WEATHER "Support weather forecast display" Off
+OPTIONS_DEFAULT= ICONV
+OPTIONS_DEFINE= FACEBOOK ICONV TWITTER WEATHER
+
+FACEBOOK_DESC= Support connections to Facebook
+ICONV_DESC= Depend on PHP iconv extension
+TWITTER_DESC= Support connections to Twitter
+WEATHER_DESC= Support weather forecast display
USE_PHP= filter gettext hash
@@ -39,6 +42,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Http \
Horde_Image \
Horde_LoginTasks \
+ Horde_Mail \
Horde_Mime \
Horde_Nls \
Horde_Perms \
@@ -57,8 +61,7 @@ USE_HORDE_RUN= Horde_Role \
Horde_Vfs
# Optional in package but we want them in
-USE_HORDE_RUN+= Horde_DataTree \
- Horde_Feed
+USE_HORDE_RUN+= Horde_Feed
.include <bsd.port.options.mk>