aboutsummaryrefslogtreecommitdiff
path: root/www/htdigest
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-01-12 20:05:49 +0000
committerChris Rees <crees@FreeBSD.org>2014-01-12 20:05:49 +0000
commit6ae32afa165b4c8c32d7e52741fe79bc94a1914a (patch)
treef6bd2de69f0a0a19a96dfec0f56a68698e369743 /www/htdigest
parent9d64b5938cc168274f8a185d187ac90237fc6f2e (diff)
downloadports-6ae32afa165b4c8c32d7e52741fe79bc94a1914a.tar.gz
ports-6ae32afa165b4c8c32d7e52741fe79bc94a1914a.zip
The htdigest utility from Apache is useful for other web servers too--
lighttpd for example can make use of the digests thus created. This package contains just htdigest, renamed as apache-htdigest to avoid conflicts. It means that the htdigest utility is available without installing the entire Apache distribution. WWW: http://httpd.apache.org/
Notes
Notes: svn path=/head/; revision=339541
Diffstat (limited to 'www/htdigest')
-rw-r--r--www/htdigest/Makefile37
-rw-r--r--www/htdigest/distinfo2
-rw-r--r--www/htdigest/pkg-descr8
3 files changed, 47 insertions, 0 deletions
diff --git a/www/htdigest/Makefile b/www/htdigest/Makefile
new file mode 100644
index 000000000000..d5386b3f1303
--- /dev/null
+++ b/www/htdigest/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= htdigest
+PORTVERSION= 2.4.6
+CATEGORIES= www ipv6
+MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
+DISTNAME= httpd-${PORTVERSION}
+DIST_SUBDIR= apache24
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Utility from the Apache distribution for creating htdigest files
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libaprutil-1.so:${PORTSDIR}/devel/apr1 \
+ libexpat.so:${PORTSDIR}/textproc/expat2
+
+USES= iconv
+
+PLIST_FILES= bin/apache-${PORTNAME} man/man1/apache-${PORTNAME}.1.gz
+
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/support
+
+# Don't actually need pcre, so hack around
+post-patch:
+ ${REINPLACE_CMD} -e '/^[[:space:]]*as_fn_error[^"]*"[^"]*pcre/d' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/support/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/apache-htdigest
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/${PORTNAME}.1 \
+ ${STAGEDIR}${PREFIX}/man/man1/apache-htdigest.1
+
+.include <bsd.port.mk>
diff --git a/www/htdigest/distinfo b/www/htdigest/distinfo
new file mode 100644
index 000000000000..30c15d79eb35
--- /dev/null
+++ b/www/htdigest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (apache24/httpd-2.4.6.tar.gz) = b704d6ae3d17f7c56dd49d617f7fde0ade34fa913e78dd14ebaab0992efbc9cf
+SIZE (apache24/httpd-2.4.6.tar.gz) = 6700153
diff --git a/www/htdigest/pkg-descr b/www/htdigest/pkg-descr
new file mode 100644
index 000000000000..5524fd5946cd
--- /dev/null
+++ b/www/htdigest/pkg-descr
@@ -0,0 +1,8 @@
+The htdigest utility from Apache is useful for other web servers too--
+lighttpd for example can make use of the digests thus created.
+
+This package contains just htdigest, renamed as apache-htdigest to avoid
+conflicts. It means that the htdigest utility is available without installing
+the entire Apache distribution.
+
+WWW: http://httpd.apache.org/