aboutsummaryrefslogtreecommitdiff
path: root/www/htdump
diff options
context:
space:
mode:
authorDaniel Harris <dannyboy@FreeBSD.org>2001-03-08 22:01:06 +0000
committerDaniel Harris <dannyboy@FreeBSD.org>2001-03-08 22:01:06 +0000
commit0ea5aff8243f4ba705dfcb82e1bb6e4b9ff26419 (patch)
treef5b9f2e10b60d9140d03fb6a9112a85c85180466 /www/htdump
parent922183a07773ec99ed836de5a0e1ab0bbd57cff0 (diff)
downloadports-0ea5aff8243f4ba705dfcb82e1bb6e4b9ff26419.tar.gz
ports-0ea5aff8243f4ba705dfcb82e1bb6e4b9ff26419.zip
Add htdump 0.9x, a tool to retrieve WWW data.
PR: 25238 Submitted by: Maxime Henrion (mux@qualys.com)
Notes
Notes: svn path=/head/; revision=39289
Diffstat (limited to 'www/htdump')
-rw-r--r--www/htdump/Makefile30
-rw-r--r--www/htdump/distinfo1
-rw-r--r--www/htdump/files/patch-aa39
-rw-r--r--www/htdump/pkg-comment1
-rw-r--r--www/htdump/pkg-descr7
-rw-r--r--www/htdump/pkg-plist2
6 files changed, 80 insertions, 0 deletions
diff --git a/www/htdump/Makefile b/www/htdump/Makefile
new file mode 100644
index 000000000000..c4c528e4023c
--- /dev/null
+++ b/www/htdump/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: htdump
+# Date created: Tue Feb 20, 2001
+# Whom: Maxime Henrion (mux@qualys.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= htdump
+PORTVERSION= 0.9x
+CATEGORIES= www
+MASTER_SITES= http://arak.cs.hro.nl/~ren/linux/htdump/bin/
+
+MAINTAINER= mux@qualys.com
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+ALL_TARGET= ssl
+.endif
+
+pre-extract:
+.if !defined(WITH_SSL)
+ @${ECHO} "Define WITH_SSL if you want to build with SSL support"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/htdump ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/htdump/distinfo b/www/htdump/distinfo
new file mode 100644
index 000000000000..b71904c49707
--- /dev/null
+++ b/www/htdump/distinfo
@@ -0,0 +1 @@
+MD5 (htdump-0.9x.tar.gz) = a7a213b81af05399cc57f9bad5a082ea
diff --git a/www/htdump/files/patch-aa b/www/htdump/files/patch-aa
new file mode 100644
index 000000000000..f95abd76ce49
--- /dev/null
+++ b/www/htdump/files/patch-aa
@@ -0,0 +1,39 @@
+--- Makefile.orig Tue Dec 19 16:26:47 2000
++++ Makefile Wed Feb 21 00:33:15 2001
+@@ -5,10 +5,11 @@
+ #
+ #
+
+-CFLAGS = -O4 -m486 -Wall #-funsigned-char -Wshadow -Wmissing-prototypes -Wmissing-declarations -Winline
++CFLAGS = -O4 -Wall -I${PREFIX}/include #-funsigned-char -Wshadow -Wmissing-prototypes -Wmissing-declarations -Winline
+ PROGS = htdump
+ LFLAGS = -s #-static
+ CC = cc
++LDFLAGS += -L${PREFIX}/lib
+
+ # Nothing should have to change beneath this line
+
+@@ -22,19 +23,19 @@
+
+ htdump: $(OBJS) socket.o
+ rm -f htdump
+- $(CC) $(LFLAGS) -o htdump $(OBJS) socket.o
++ $(CC) $(LFLAGS) -o htdump $(OBJS) socket.o ${LDFLAGS} -lgnugetopt
+
+ ssl: $(OBJS) socket-ssl.o
+ rm -f htdump
+- $(CC) $(LFLAGS) -o htdump $(OBJS) socket-ssl.o -lssl -lcrypto -L/usr/local/ssl/lib
++ $(CC) $(LFLAGS) -o htdump $(OBJS) socket-ssl.o ${LDFLAGS} -lssl -lcrypto -lgnugetopt
+
+-$(OBJS): %.o: %.c $(HDRS)
++$(OBJS): $(HDRS)
+
+ socket.o: socket.c $(HDRS)
+ $(CC) $(CFLAGS) -c socket.c
+
+ socket-ssl.o: socket.c socket-ssl.c $(HDRS)
+- $(CC) $(CFLAGS) -c socket-ssl.c -I /usr/local/ssl/include
++ $(CC) $(CFLAGS) -c socket-ssl.c
+
+ install: $(PROGS)
+ cp htdump /usr/local/bin
diff --git a/www/htdump/pkg-comment b/www/htdump/pkg-comment
new file mode 100644
index 000000000000..e97f08069e1d
--- /dev/null
+++ b/www/htdump/pkg-comment
@@ -0,0 +1 @@
+A tool to retrieve WWW data
diff --git a/www/htdump/pkg-descr b/www/htdump/pkg-descr
new file mode 100644
index 000000000000..ee633a733adb
--- /dev/null
+++ b/www/htdump/pkg-descr
@@ -0,0 +1,7 @@
+HTdump is an automation utility to retrieve URLs and write them to a file, or
+process them through a pipeline. It is also a very usefull tool for web
+developer who work low level, for example with CGI binaries. This makes a
+perfect debugging tool, since it allows usual but also rfc-illegal operations.
+Packet level debugging is included in this tool.
+
+WWW: http://arak.cs.hro.nl/~ren/linux/
diff --git a/www/htdump/pkg-plist b/www/htdump/pkg-plist
new file mode 100644
index 000000000000..ebd837673bf2
--- /dev/null
+++ b/www/htdump/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+bin/htdump