aboutsummaryrefslogtreecommitdiff
path: root/www/htdump
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-11-01 21:52:15 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-11-01 21:52:15 +0000
commit1b1f2436ad961017fe98296bafefd049196ec53b (patch)
tree63b2bd1f5faabfe042b34f85a25521d560123bc6 /www/htdump
parent058eff382bdaf03a022b233af12bed778b292b21 (diff)
downloadports-1b1f2436ad961017fe98296bafefd049196ec53b.tar.gz
ports-1b1f2436ad961017fe98296bafefd049196ec53b.zip
- Update to version 0.9y
- Remove leading article from COMMENT - Add LICENSE - Support staging - Reformat pkg-descr PR: ports/181061 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=332413
Diffstat (limited to 'www/htdump')
-rw-r--r--www/htdump/Makefile22
-rw-r--r--www/htdump/distinfo4
-rw-r--r--www/htdump/files/patch-aa21
-rw-r--r--www/htdump/files/patch-usage.c42
-rw-r--r--www/htdump/pkg-descr10
5 files changed, 48 insertions, 51 deletions
diff --git a/www/htdump/Makefile b/www/htdump/Makefile
index 65bdfc630ac0..b59396cb613c 100644
--- a/www/htdump/Makefile
+++ b/www/htdump/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= htdump
-PORTVERSION= 0.9x
-PORTREVISION= 1
+PORTVERSION= 0.9y
CATEGORIES= www
MASTER_SITES= http://ivo.palli.nl/prog/linux/htdump/bin/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A tool to retrieve WWW data
+COMMENT= Tool to retrieve WWW data
+
+LICENSE= AL2
OPTIONS_DEFINE= SSL
OPTIONS_DEFAULT=SSL
-CFLAGS+= ${CPPFLAGS}
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LFLAGS="-s ${LDFLAGS}"
+PLIST_FILES= bin/htdump
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
@@ -24,9 +23,16 @@ USE_OPENSSL= yes
ALL_TARGET= ssl
.endif
-PLIST_FILES= bin/htdump
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS|#CFLAGS| ; \
+ s|^CC|#CC| ; \
+ s|$$(LFLAGS)|$$(LDFLAGS)| ; \
+ s|-L/usr/local/ssl/lib|| ; \
+ s|%.o: %.c|| ; \
+ s|-I /usr/local/ssl/include|$$(CPPFLAGS)|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/htdump ${PREFIX}/bin
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} htdump ${STAGEDIR}${PREFIX}/bin)
.include <bsd.port.mk>
diff --git a/www/htdump/distinfo b/www/htdump/distinfo
index 1808919a73b2..45aba86c6d62 100644
--- a/www/htdump/distinfo
+++ b/www/htdump/distinfo
@@ -1,2 +1,2 @@
-SHA256 (htdump-0.9x.tar.gz) = 07a9b7d4f6d451b66662478d3aa0500157006cf1a9566c747d931e2138a2b313
-SIZE (htdump-0.9x.tar.gz) = 215769
+SHA256 (htdump-0.9y.tar.gz) = 8f0a83a4eee5c35f2274914c63cff879df1de9a6f0d2e1295c4cff2a291c6f1b
+SIZE (htdump-0.9y.tar.gz) = 218635
diff --git a/www/htdump/files/patch-aa b/www/htdump/files/patch-aa
deleted file mode 100644
index 1c3cbc937922..000000000000
--- a/www/htdump/files/patch-aa
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.orig Wed Dec 20 00:26:47 2000
-+++ Makefile Sun Jul 6 20:19:19 2003
-@@ -26,15 +24,15 @@
-
- ssl: $(OBJS) socket-ssl.o
- rm -f htdump
-- $(CC) $(LFLAGS) -o htdump $(OBJS) socket-ssl.o -lssl -lcrypto -L/usr/local/ssl/lib
-+ $(CC) $(LFLAGS) -o htdump $(OBJS) socket-ssl.o -lssl -lcrypto
-
--$(OBJS): %.o: %.c $(HDRS)
-+$(OBJS): $(HDRS)
-
- socket.o: socket.c $(HDRS)
- $(CC) $(CFLAGS) -c socket.c
-
- socket-ssl.o: socket.c socket-ssl.c $(HDRS)
-- $(CC) $(CFLAGS) -c socket-ssl.c -I /usr/local/ssl/include
-+ $(CC) $(CFLAGS) -c socket-ssl.c
-
- install: $(PROGS)
- cp htdump /usr/local/bin
diff --git a/www/htdump/files/patch-usage.c b/www/htdump/files/patch-usage.c
index edf718f1de95..bc0e5c155ea2 100644
--- a/www/htdump/files/patch-usage.c
+++ b/www/htdump/files/patch-usage.c
@@ -1,23 +1,29 @@
--- usage.c.orig Wed Dec 20 00:26:47 2000
+++ usage.c Mon Jul 7 04:43:54 2003
-@@ -29,24 +29,24 @@
+@@ -29,31 +29,31 @@
" OPTIONS\n"
" ===================================\n"
" Main mode of operation:\n"
- " -command=<command> Define request command. Default is 'GET'.\n"
- " -post=<form data> POST form data. When used, command is\n"
-- " overriden to 'POST'\n"
+ " --command=<command> Define request command. Default is 'GET'.\n"
+ " --post=<form data> POST form data. When used, command is\n"
-+ " overriden to 'POST'\n"
+ " overriden to 'POST'\n"
"\n"
" Miscellaneous:\n"
-- " -debug=<level> Debug mode, specify level\n"
-- " -file=<file> Dump data to file. (Auto-resumes)\n"
-- " When omitted, output goes to stdout.\n"
-+ " --debug=<level> Debug mode, specify level\n"
-+ " --file=<file> Dump data to file. (Auto-resumes)\n"
-+ " When omitted, output goes to stdout.\n"
+- " -debug[=<level>] Debug mode, specify level\n"
+- " -file[=<file>] Dump data to file. (default: overwrite)\n"
++ " --debug[=<level>] Debug mode, specify level\n"
++ " --file[=<file>] Dump data to file. (default: overwrite)\n"
+ " When omitted, output goes to stdout.\n"
+ " When no filename given, the filename is\n"
+ " extracted from the URL given.\n"
+- " -resume When writing to file, resume instead of\n"
++ " --resume When writing to file, resume instead of\n"
+ " overwrite.\n"
+- " -jar=file Give a cookie jar file and htdump will\n"
++ " --jar=file Give a cookie jar file and htdump will\n"
+ " manage all cookies on it's own.\n"
"\n"
" Header adjustment:\n"
- " -accept=<Accept> Add 'Accept:' header\n"
@@ -28,6 +34,7 @@
- " -range=<Range string> Add 'Range:' header (*)\n"
- " -agent=<Agent string> Add 'User-Agent:' header\n"
- " -version=<0|1|r> Select HTTP version. Default is HTTP/1.1\n"
+- " -extra=<extra header> Add your own custom headers\n"
+ " --accept=<Accept> Add 'Accept:' header\n"
+ " --cookie=<Cookie> Add 'Cookie:' header\n"
+ " --from=<From> Add 'From:' header\n"
@@ -36,10 +43,11 @@
+ " --range=<Range string> Add 'Range:' header (*)\n"
+ " --agent=<Agent string> Add 'User-Agent:' header\n"
+ " --version=<0|1|r> Select HTTP version. Default is HTTP/1.1\n"
++ " --extra=<extra header> Add your own custom headers\n"
"\n"
" (*) = HTTP/1.1 only\n"
- " You need version 1.1 to use password authentication\n"
-@@ -56,13 +56,13 @@
+ "\n"
+@@ -62,15 +62,15 @@
" ===================================\n"
" htdump www.netscape.com\n"
" htdump https://flemming:secret@www.jamesbond.com/members/secret.html\n"
@@ -47,16 +55,20 @@
- " htdump -referer=\"www.fbi.gov\" http://www.arpa.mil/secret.zip\n"
- " htdump -version=r -agent=\"Crazy www browser 1.6\" http://bouncy.com/\n"
- " htdump -command=\"OPTIONS\" http://arak.cs.hro.nl/ -debug\n"
-- " htdump -file=this.zip download.com/this.zip &\n"
+- " htdump -file -resume download.com/this.zip &\n"
- " htdump http://download.com/big.zip -range=\"644221-\" >> big.zip &\n"
- " htdump -post=\"name=Ren&op1=yes\" here.com/cgi-bin/prog\n"
+- " htdump -cookie=\"chocolate\" -cookie=\"brownie\" cookies.com\n"
+- " htdump -extra=\"ProxyVersion: SeaCreature/5.0\" www.mutated-seabass.com\n"
+ " htdump --host=\"www.vhost1.com\" http://127.0.0.1/\n"
+ " htdump --referer=\"www.fbi.gov\" http://www.arpa.mil/secret.zip\n"
-+ " htdump --version=r --agent=\"Crazy www browser 1.6\" http://bouncy.com/\n"
-+ " htdump --command=\"OPTIONS\" http://arak.cs.hro.nl/ --debug\n"
-+ " htdump --file=this.zip download.com/this.zip &\n"
++ " htdump --version=r -agent=\"Crazy www browser 1.6\" http://bouncy.com/\n"
++ " htdump --command=\"OPTIONS\" http://arak.cs.hro.nl/ -debug\n"
++ " htdump --file -resume download.com/this.zip &\n"
+ " htdump http://download.com/big.zip --range=\"644221-\" >> big.zip &\n"
+ " htdump --post=\"name=Ren&op1=yes\" here.com/cgi-bin/prog\n"
++ " htdump --cookie=\"chocolate\" -cookie=\"brownie\" cookies.com\n"
++ " htdump --extra=\"ProxyVersion: SeaCreature/5.0\" www.mutated-seabass.com\n"
"\n"
"\n"
" htdump "VERSION"\n"
diff --git a/www/htdump/pkg-descr b/www/htdump/pkg-descr
index 6e6487081c65..1a65f3579593 100644
--- a/www/htdump/pkg-descr
+++ b/www/htdump/pkg-descr
@@ -1,7 +1,7 @@
-HTdump is an automation utility to retrieve URLs and write them to a file, or
-process them through a pipeline. It is also a very usefull tool for web
-developer who work low level, for example with CGI binaries. This makes a
-perfect debugging tool, since it allows usual but also rfc-illegal operations.
-Packet level debugging is included in this tool.
+HTdump is an automation utility to retrieve URLs and write them to a
+file, or process them through a pipeline. It is also a very usefull tool
+for web developer who work low level, for example with CGI binaries.
+This makes a perfect debugging tool, since it allows usual but also
+rfc-illegal operations. Packet level debugging is included in this tool.
WWW: http://ivo.palli.nl/prog/linux/htdump/overview.html