aboutsummaryrefslogtreecommitdiff
path: root/www/httest/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-10 08:33:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-10 08:33:27 +0000
commitcefd296e0fa3f2f3991f00beeb589884a6318b20 (patch)
tree77b7f0c2bd607ca24dd68036d4f3161a81be38d4 /www/httest/Makefile
parentba5882cefaee4c0f0309e9021dddf5a21c4c4e5f (diff)
downloadports-cefd296e0fa3f2f3991f00beeb589884a6318b20.tar.gz
ports-cefd296e0fa3f2f3991f00beeb589884a6318b20.zip
Port to lua 5.2 + cosmetic changes
Notes
Notes: svn path=/head/; revision=339326
Diffstat (limited to 'www/httest/Makefile')
-rw-r--r--www/httest/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index 44ee49365328..b24a05c37375 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -24,24 +24,18 @@ CONFIGURE_ARGS= --enable-lua-module \
--with-ssl="${OPENSSLLIB}"
CPPFLAGS+= -I${LUA_INCDIR}
GNU_CONFIGURE= yes
-USES= iconv
-USE_LUA= yes
+USES= iconv lua
USE_OPENSSL= yes
USE_LDCONFIG= yes
-MAN1= htntlm.1 htproxy.1 htremote.1 httest.1
PORTEXAMPLES= *
post-patch:
- @${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||; s|-llua|-llua-${LUA_VER}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>