aboutsummaryrefslogtreecommitdiff
path: root/www/httest
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-08 06:35:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-08 06:35:31 +0000
commitbc3af828cd14239d5c6759622c2f9d02a5d663f0 (patch)
tree2addf8ce3f8d2f86d221b85d1e07dfc410a93961 /www/httest
parentba50418207a6eb11df1b2be08bbd5ce0fd2935f6 (diff)
downloadports-bc3af828cd14239d5c6759622c2f9d02a5d663f0.tar.gz
ports-bc3af828cd14239d5c6759622c2f9d02a5d663f0.zip
- Support CFLAGS properly
- Add MAKE_JOBS_SAFE - Support PORTEXAMPLES/PLIST_FILES PR: 166053 Submitted by: Ports Fury Feature safe: yes
Notes
Notes: svn path=/head/; revision=294360
Diffstat (limited to 'www/httest')
-rw-r--r--www/httest/Makefile37
-rw-r--r--www/httest/pkg-plist6
2 files changed, 27 insertions, 16 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index 55bc73845a8b..2dec8b73171a 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -7,30 +7,47 @@
PORTNAME= httest
PORTVERSION= 2.1.18
+PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= htt/htt2.1/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/htt/htt${PORTVERSION:R}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= HTTP Test Tool
LICENSE= AL2
-LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1 \
+LIB_DEPENDS= apr-1.4:${PORTSDIR}/devel/apr1 \
pcre.1:${PORTSDIR}/devel/pcre
-GNU_CONFIGURE= yes
-USE_OPENSSL= yes
USE_LUA= yes
-
-LDFLAGS+= -L${LUA_LIBDIR} -lm
-
-CONFIGURE_ARGS+=--with-apr="${LOCALBASE}/bin" \
+USE_OPENSSL= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-apr="${LOCALBASE}/bin" \
--with-apr-util="${LOCALBASE}/bin" \
--with-pcre="${LOCALBASE}/bin" \
- --with-lua="${LUA_INCDIR}" \
+ --with-ssl="${OPENSSLLIB}" \
+ --with-lua="${LUA_LIBDIR}" \
--enable-lua-module
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LUA_INCDIR}
MAN1= httest.1 htproxy.1 htntlm.1 htremote.1
+PORTEXAMPLES= *
+PLIST_FILES= bin/htntlm bin/htproxy bin/htremote bin/httest bin/hturlext \
+ bin/htx2b
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|`$$APR_CONFIG --cflags`||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/www/httest/pkg-plist b/www/httest/pkg-plist
deleted file mode 100644
index 073cb5522dad..000000000000
--- a/www/httest/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/htntlm
-bin/htproxy
-bin/htremote
-bin/httest
-bin/hturlext
-bin/htx2b