aboutsummaryrefslogtreecommitdiff
path: root/www/http_post/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-09-09 15:01:34 +0000
committerSteve Wills <swills@FreeBSD.org>2012-09-09 15:01:34 +0000
commitc850dea23e2d4a9d850e2cbd0141aa3f8fc1485f (patch)
treeb4848497f4175bda7ef349780d1071adb94a3331 /www/http_post/Makefile
parent4e7e939867e723d73efc4a61a3f0283834008190 (diff)
downloadports-c850dea23e2d4a9d850e2cbd0141aa3f8fc1485f.tar.gz
ports-c850dea23e2d4a9d850e2cbd0141aa3f8fc1485f.zip
Http_post does a POST operation and dumps the results to stdout. This supports
ipv6 and https (SSL). WWW: http://www.acme.com/software/http_post/ PR: ports/171492 Submitted by: masaki@club.kyutech.ac.jp
Notes
Notes: svn path=/head/; revision=303970
Diffstat (limited to 'www/http_post/Makefile')
-rw-r--r--www/http_post/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/http_post/Makefile b/www/http_post/Makefile
new file mode 100644
index 000000000000..ea9ef55ecaac
--- /dev/null
+++ b/www/http_post/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: http_post
+# Date created: 9 Sep 2012
+# Whom: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http_post
+PORTVERSION= 1.0.20110118
+CATEGORIES= www ipv6
+MASTER_SITES= http://www.acme.com/software/http_post/
+DISTNAME= ${PORTNAME}_18jan2011
+
+MAINTAINER= masaki@club.kyutech.ac.jp
+COMMENT= Do a POST operaion and Dump http-contents to stdout
+
+WRKSRC= ${WRKDIR}/http_post
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+MAN1= http_post.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/http_post
+
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
+
+.include <bsd.port.mk>