aboutsummaryrefslogtreecommitdiff
path: root/www/httptunnel
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2001-05-21 10:00:49 +0000
committerBrian Somers <brian@FreeBSD.org>2001-05-21 10:00:49 +0000
commit725829d7b015e56ccaff6ab9f9e4221279227075 (patch)
treeded9525d80e30cb0b089d4a18962cb5f1e4ebe48 /www/httptunnel
parent3382222fd5edf4f3485e1fd9167716577eaf6fa9 (diff)
downloadports-725829d7b015e56ccaff6ab9f9e4221279227075.tar.gz
ports-725829d7b015e56ccaff6ab9f9e4221279227075.zip
Upgrade to version 3.3
Notes
Notes: svn path=/head/; revision=42848
Diffstat (limited to 'www/httptunnel')
-rw-r--r--www/httptunnel/Makefile2
-rw-r--r--www/httptunnel/distinfo2
-rw-r--r--www/httptunnel/files/patch-aa11
-rw-r--r--www/httptunnel/files/patch-ab32
-rw-r--r--www/httptunnel/files/patch-ac17
5 files changed, 2 insertions, 62 deletions
diff --git a/www/httptunnel/Makefile b/www/httptunnel/Makefile
index 6c23abc43d7d..a07c74c0b67d 100644
--- a/www/httptunnel/Makefile
+++ b/www/httptunnel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httptunnel
-PORTVERSION= 3.2
+PORTVERSION= 3.3
CATEGORIES= www
MASTER_SITES= http://www.Awfulhak.org/httptunnel/ \
ftp://ftp.nocrew.org/pub/nocrew/unix/ \
diff --git a/www/httptunnel/distinfo b/www/httptunnel/distinfo
index 294bd95141b0..980fdd384762 100644
--- a/www/httptunnel/distinfo
+++ b/www/httptunnel/distinfo
@@ -1 +1 @@
-MD5 (httptunnel-3.2.tar.gz) = 6cc45913ed81f3f45108b0773ef1e8af
+MD5 (httptunnel-3.3.tar.gz) = 493cc0f5f21e9955db27ee9cd9a976d5
diff --git a/www/httptunnel/files/patch-aa b/www/httptunnel/files/patch-aa
deleted file mode 100644
index 51bb72713c30..000000000000
--- a/www/httptunnel/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- htc.c.orig Thu Aug 31 22:10:13 2000
-+++ htc.c Thu Aug 31 22:10:29 2000
-@@ -539,7 +539,7 @@
- arg.host_name, arg.host_port,
- arg.proxy_name, arg.proxy_port);
- else
-- log_notice ("connected to %s%d", arg.host_name, arg.host_port);
-+ log_notice ("connected to %s:%d", arg.host_name, arg.host_port);
-
- closed = FALSE;
- time (&last_tunnel_write);
diff --git a/www/httptunnel/files/patch-ab b/www/httptunnel/files/patch-ab
deleted file mode 100644
index 4951e768a37c..000000000000
--- a/www/httptunnel/files/patch-ab
+++ /dev/null
@@ -1,32 +0,0 @@
---- tunnel.c.orig Thu Aug 31 22:22:58 2000
-+++ tunnel.c Thu Aug 31 22:24:27 2000
-@@ -358,10 +358,10 @@
- if (tunnel->out_fd == -1)
- {
- log_error ("tunnel_out_connect: do_connect (%d.%d.%d.%d:%u) error: %s",
-- tunnel->address.sin_addr.s_addr >> 24,
-- (tunnel->address.sin_addr.s_addr >> 16) & 0xff,
-- (tunnel->address.sin_addr.s_addr >> 8) & 0xff,
-- tunnel->address.sin_addr.s_addr & 0xff,
-+ ntohl(tunnel->address.sin_addr.s_addr) >> 24,
-+ (ntohl(tunnel->address.sin_addr.s_addr) >> 16) & 0xff,
-+ (ntohl(tunnel->address.sin_addr.s_addr) >> 8) & 0xff,
-+ ntohl(tunnel->address.sin_addr.s_addr) & 0xff,
- ntohs (tunnel->address.sin_port),
- strerror (errno));
- return -1;
-@@ -1120,10 +1120,10 @@
- }
-
- log_notice ("connection from %d.%d.%d.%d:%u",
-- addr.sin_addr.s_addr >> 24,
-- (addr.sin_addr.s_addr >> 16) & 0xff,
-- (addr.sin_addr.s_addr >> 8) & 0xff,
-- addr.sin_addr.s_addr & 0xff,
-+ ntohl(addr.sin_addr.s_addr) >> 24,
-+ (ntohl(addr.sin_addr.s_addr) >> 16) & 0xff,
-+ (ntohl(addr.sin_addr.s_addr) >> 8) & 0xff,
-+ ntohl(addr.sin_addr.s_addr) & 0xff,
- ntohs (addr.sin_port));
-
- m = http_parse_request (s, &request);
diff --git a/www/httptunnel/files/patch-ac b/www/httptunnel/files/patch-ac
deleted file mode 100644
index fdcde075a537..000000000000
--- a/www/httptunnel/files/patch-ac
+++ /dev/null
@@ -1,17 +0,0 @@
---- common.c.orig Thu Aug 31 22:24:49 2000
-+++ common.c Thu Aug 31 22:26:01 2000
-@@ -179,10 +179,10 @@
- memcpy(&address->sin_addr.s_addr, ent->h_addr, (unsigned)ent->h_length);
- ip = ntohl (address->sin_addr.s_addr);
- log_annoying ("set_address: host = %d.%d.%d.%d",
-- ip >> 24,
-- (ip >> 16) & 0xff,
-- (ip >> 8) & 0xff,
-- ip & 0xff);
-+ ntohl(ip) >> 24,
-+ (ntohl(ip) >> 16) & 0xff,
-+ (ntohl(ip) >> 8) & 0xff,
-+ ntohl(ip) & 0xff);
- }
-
- return 0;