aboutsummaryrefslogtreecommitdiff
path: root/www/httptunnel
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2000-08-31 20:30:55 +0000
committerBrian Somers <brian@FreeBSD.org>2000-08-31 20:30:55 +0000
commite697ee667e5e02fc1ab5a45eebce16356b407cf6 (patch)
tree71afa753659629694da067386dc336f4f8e7c239 /www/httptunnel
parent3802f14ef2d91a9d9a190026ab5fb8ebe20302c9 (diff)
downloadports-e697ee667e5e02fc1ab5a45eebce16356b407cf6.tar.gz
ports-e697ee667e5e02fc1ab5a45eebce16356b407cf6.zip
Upgrade to 3.2 (no functional changes)
Set $HTS and $HTC in etc/rc.d/httptunnel.sh Allow HTCPROXYAUTH to specify a file name
Notes
Notes: svn path=/head/; revision=32159
Diffstat (limited to 'www/httptunnel')
-rw-r--r--www/httptunnel/Makefile7
-rw-r--r--www/httptunnel/distinfo2
-rw-r--r--www/httptunnel/files/httptunnel.sh20
3 files changed, 21 insertions, 8 deletions
diff --git a/www/httptunnel/Makefile b/www/httptunnel/Makefile
index b1138e45529a..08c20859b01d 100644
--- a/www/httptunnel/Makefile
+++ b/www/httptunnel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httptunnel
-PORTVERSION= 3.1
+PORTVERSION= 3.2
CATEGORIES= www
MASTER_SITES= http://www.Awfulhak.org/httptunnel/ \
ftp://ftp.nocrew.org/pub/nocrew/unix/ \
@@ -22,7 +22,8 @@ CONFIGURE_ARGS+=--enable-debug
MAN1= hts.1 htc.1
post-install:
- [ -f ${PREFIX}/etc/rc.d/httptunnel.sh ] || \
- ${INSTALL_SCRIPT} ${FILESDIR}/httptunnel.sh ${PREFIX}/etc/rc.d/.
+ ${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/httptunnel.sh \
+ >${PREFIX}/etc/rc.d/httptunnel.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/httptunnel.sh
.include <bsd.port.mk>
diff --git a/www/httptunnel/distinfo b/www/httptunnel/distinfo
index 6682ed6d1684..294bd95141b0 100644
--- a/www/httptunnel/distinfo
+++ b/www/httptunnel/distinfo
@@ -1 +1 @@
-MD5 (httptunnel-3.1.tar.gz) = 3fd732aece11a59fee3d74ecb77f8910
+MD5 (httptunnel-3.2.tar.gz) = 6cc45913ed81f3f45108b0773ef1e8af
diff --git a/www/httptunnel/files/httptunnel.sh b/www/httptunnel/files/httptunnel.sh
index c919064ea036..e4d58e2d4dc7 100644
--- a/www/httptunnel/files/httptunnel.sh
+++ b/www/httptunnel/files/httptunnel.sh
@@ -2,10 +2,12 @@
#
# $FreeBSD$
+HTS=%%PREFIX%%/bin/hts # The installed hts program
HTSPORT= # [host:]port to listen for htc connection
HTSFORWARD= # Talk to this socket
HTSDEVICE= # *or* talk to this device
+HTC=%%PREFIX%%/bin/htc # The installed htc program
HTCPORT= # host:port where hts is running
HTCFORWARD= # Talk to this socket
HTCDEVICE= # *or* talk to this device
@@ -21,7 +23,7 @@ start)
if [ -n "$HTSPORT" -a -x $HTS ]; then
[ -n "$HTSFORWARD" ] && args="-F $HTSFORWARD"
[ -n "$HTSDEVICE" ] && args="-d $HTSDEVICE"
- /usr/local/bin/hts $args $HTSPORT && echo -n ' hts'
+ $HTS $args $HTSPORT && echo -n ' hts'
fi
if [ -n "$HTCPORT" -a -x $HTC ]; then
@@ -30,11 +32,21 @@ start)
[ -n "$HTCDEVICE" ] && set -- -d $HTCDEVICE
[ -n "$HTCBROWSER" ] && set -- -U "$HTCBROWSER" "$@"
if [ -n "$HTCPROXY" ]; then
- [ -n "$HTCPROXYBUFFER" ] && set -- -B $HTCPROXYBUFFER "$@"
- [ -n "$HTCPROXYAUTH" ] && set -- -A $HTCPROXYAUTH "$@"
+ [ -n "$HTCPROXYBUFFER" ] &&
+ set -- -B $HTCPROXYBUFFER "$@"
+ if [ -n "$HTCPROXYAUTH" ]
+ then
+ if [ -f "$HTCPROXYAUTH" ]
+ then
+ set -- --proxy-authorization-file \
+ $HTCPROXYAUTH "$@"
+ else
+ set -- -A $HTCPROXYAUTH "$@"
+ fi
+ fi
set -- -P $HTCPROXY "$@"
fi
- /usr/local/bin/htc "$@" $HTCARGS $HTCPORT && echo -n ' htc'
+ $HTC "$@" $HTCARGS $HTCPORT && echo -n ' htc'
fi
;;
stop)