aboutsummaryrefslogtreecommitdiff
path: root/www/igal2
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-14 11:25:38 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-14 11:25:38 +0000
commit5d42951f9468d74110210672de019cc5d7d9a7a5 (patch)
tree64cd6c2920e9663a56f252ab26e727d942679736 /www/igal2
parentcbb2a662e38e8c71667f1a21638ba41b34e64fc6 (diff)
downloadports-5d42951f9468d74110210672de019cc5d7d9a7a5.tar.gz
ports-5d42951f9468d74110210672de019cc5d7d9a7a5.zip
- STAGE-clean
- Remove article from COMMENT line
Notes
Notes: svn path=/head/; revision=344192
Diffstat (limited to 'www/igal2')
-rw-r--r--www/igal2/Makefile14
-rw-r--r--www/igal2/files/patch-Makefile26
-rw-r--r--www/igal2/files/patch-igal211
-rw-r--r--www/igal2/pkg-plist1
4 files changed, 46 insertions, 6 deletions
diff --git a/www/igal2/Makefile b/www/igal2/Makefile
index ebe2dc9329a1..0f4e5b33cd0f 100644
--- a/www/igal2/Makefile
+++ b/www/igal2/Makefile
@@ -7,7 +7,9 @@ CATEGORIES= www graphics
MASTER_SITES= http://igal.trexler.at/
MAINTAINER= gahr@FreeBSD.org
-COMMENT= A simple CLI image gallery generator
+COMMENT= Simple CLI image gallery generator
+
+LICENSE= GPLv2
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
@@ -17,11 +19,8 @@ EXIF_DESC= Support EXIF data (-e option)
CONFLICTS= igal-1.*
USES= perl5
NO_BUILD= yes
+MAKE_ENV+= DESTDIR=${STAGEDIR}
-MAN1= igal2.1
-MANCOMPRESSED= no
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEXIF}
@@ -29,6 +28,9 @@ RUN_DEPENDS+= p5-Image-ExifTool>=7.0:${PORTSDIR}/graphics/p5-Image-ExifTool
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile ${WRKSRC}/igal2
+ ${REINPLACE_CMD} -e 's|%%LIBDIR%%|${PREFIX}/lib/igal2|' ${WRKSRC}/igal2
+
+post-install:
+ ${LN} -sf igal2 ${STAGEDIR}${PREFIX}/bin/igal
.include <bsd.port.mk>
diff --git a/www/igal2/files/patch-Makefile b/www/igal2/files/patch-Makefile
new file mode 100644
index 000000000000..b1c2966857ed
--- /dev/null
+++ b/www/igal2/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig 2014-02-14 12:27:23.000000000 +0100
++++ Makefile 2014-02-14 12:27:48.000000000 +0100
+@@ -1,11 +1,11 @@
+ ############################################################################
+ # if you change this, please also modify the value at the top of igal code
+-DESTDIR=/usr/local
++DESTDIR?=/usr/local
+ ############################################################################
+
+-BINDIR=$(DESTDIR)/bin
+-MANDIR=$(DESTDIR)/man/man1
+-LIBDIR=$(DESTDIR)/lib/igal2
++BINDIR=$(DESTDIR)$(PREFIX)/bin
++MANDIR=$(DESTDIR)$(PREFIX)/man/man1
++LIBDIR=$(DESTDIR)$(PREFIX)/lib/igal2
+
+ OLDLIBDIR=$(DESTDIR)/lib/igal
+
+@@ -24,7 +24,6 @@
+ install:: igal2
+ install -d $(BINDIR)
+ install -m 0755 igal2 $(BINDIR)
+- ln -si $(BINDIR)/igal2 $(BINDIR)/igal
+ install -m 0755 utilities/igal2.sh $(BINDIR)
+ install -d $(MANDIR)
+ install -m 0644 igal2.1 $(MANDIR)
diff --git a/www/igal2/files/patch-igal2 b/www/igal2/files/patch-igal2
new file mode 100644
index 000000000000..a95d0c6076d2
--- /dev/null
+++ b/www/igal2/files/patch-igal2
@@ -0,0 +1,11 @@
+--- igal2.orig 2014-02-14 12:28:33.000000000 +0100
++++ igal2 2014-02-14 12:28:40.000000000 +0100
+@@ -5,7 +5,7 @@
+ ############################################################################
+ # Please change this accordingly if you change the DESTDIR in the tarball
+ # distribution Makefile or the --prefix of the RPM installation
+-$LIBDIR = "/usr/local/lib/igal2";
++$LIBDIR = "%%LIBDIR%%";
+ # for example if you make DESTDIR=/usr then $LIBDIR="/usr/lib/igal2"
+ ############################################################################
+ #
diff --git a/www/igal2/pkg-plist b/www/igal2/pkg-plist
index dae7ef4d33c7..8b7fceb76c8f 100644
--- a/www/igal2/pkg-plist
+++ b/www/igal2/pkg-plist
@@ -9,4 +9,5 @@ lib/igal2/igal2.css
lib/igal2/indextemplate2.html
lib/igal2/slidetemplate2.html
lib/igal2/tile.png
+man/man1/igal2.1.gz
@dirrm lib/igal2