aboutsummaryrefslogtreecommitdiff
path: root/www/ilias6
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2020-05-30 01:51:29 +0000
committerWen Heping <wen@FreeBSD.org>2020-05-30 01:51:29 +0000
commit8ed87f7d45a67eb2b52ba45c852d3e2f8293376a (patch)
treea82d538271558b8081b401bdc2296e7f5ac14fef /www/ilias6
parentf8ec3139d9c201ecc7d243b5a2a05fd9a5c43b9e (diff)
downloadports-8ed87f7d45a67eb2b52ba45c852d3e2f8293376a.tar.gz
ports-8ed87f7d45a67eb2b52ba45c852d3e2f8293376a.zip
- Repocopy www/ilias --> www/ilias6 and update to 6.0
- Add CONFLICTS - Update pkg-message
Notes
Notes: svn path=/head/; revision=537031
Diffstat (limited to 'www/ilias6')
-rw-r--r--www/ilias6/Makefile88
-rw-r--r--www/ilias6/distinfo3
-rw-r--r--www/ilias6/files/pkg-message.in41
-rw-r--r--www/ilias6/pkg-descr6
4 files changed, 138 insertions, 0 deletions
diff --git a/www/ilias6/Makefile b/www/ilias6/Makefile
new file mode 100644
index 000000000000..4227ffe64135
--- /dev/null
+++ b/www/ilias6/Makefile
@@ -0,0 +1,88 @@
+# Created by: Bartlomiej Rutkowski <r@robakdesign.com>
+# $FreeBSD$
+
+PORTNAME= ilias
+PORTVERSION= 6.0
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+PKGNAMESUFFIX= 6${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Powerful, dynamic, PHP and MySQL based e-learning platform
+
+LICENSE= GPLv2
+
+CONFLICTS= ilias-5.4.[0-9]*
+
+RUN_DEPENDS= composer:devel/php-composer \
+ convert:graphics/ImageMagick6 \
+ zip:archivers/zip \
+ ${UNZIP_CMD}:archivers/unzip \
+ ${LOCALBASE}/share/pear/PEAR.php:devel/pear@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/Auth/Auth.php:security/pear-Auth@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/HTML/Template/IT.php:devel/pear-HTML_Template_IT@${PHP_FLAVOR}
+LIB_DEPENDS= libpng.so:graphics/png
+
+USE_GITHUB= yes
+GH_ACCOUNT= ILIAS-eLearning
+GH_PROJECT= ILIAS
+
+USES= cpe jpeg php
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+USE_PHP= curl ldap pdo_mysql gd pdf dom pcre session simplexml \
+ soap xmlrpc xmlwriter xsl zlib
+ILIASDIR= www/ilias
+ILIASDATADIR= www/iliasdata
+PLIST_SUB= ILIASDATADIR=${ILIASDATADIR}
+SUB_FILES= pkg-message
+SUB_LIST= ILIASDATADIR=${ILIASDATADIR}
+
+OPTIONS_DEFINE= SCORM2004 CHECKER MAIL
+SCORM2004_USE= php=json
+CHECKER_RUN_DEPENDS= ${LOCALBASE}/share/pear/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
+MAIL_RUN_DEPENDS= ${LOCALBASE}/share/pear/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
+
+EXTRA_FILES= %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/_mocha \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/esparse \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/esvalidate \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/flat \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/he \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/js-yaml \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/mime \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/mkdirp \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/mocha \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/semver \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/uuid \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/which \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/js-yaml/node_modules/.bin/esparse \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/js-yaml/node_modules/.bin/esvalidate \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/mocha/node_modules/.bin/he \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/mocha/node_modules/.bin/js-yaml \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/mocha/node_modules/.bin/mkdirp \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/mocha/node_modules/.bin/which \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/node-environment-flags/node_modules/.bin/semver \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/send/node_modules/.bin/mime \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/superagent/node_modules/.bin/mime \
+ %%WWWDIR%%/Modules/Chatroom/chat/node_modules/yargs-unparser/node_modules/.bin/flat
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${ILIASDIR}?g" >> ${PLIST}
+.for i in ${EXTRA_FILES}
+ @${ECHO_CMD} ${i} >> ${PLIST}
+.endfor
+ @${ECHO} @dir ${ILIASDIR} >> ${PLIST}
+ @${ECHO} @dir ${ILIASDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${ILIASDATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/ilias6/distinfo b/www/ilias6/distinfo
new file mode 100644
index 000000000000..487807e53bf7
--- /dev/null
+++ b/www/ilias6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1590766801
+SHA256 (ILIAS-eLearning-ILIAS-v6.0_GH0.tar.gz) = bfc1ce773b2b2e9d27b69ce304d8e760107f81104044eb22274327773a172d80
+SIZE (ILIAS-eLearning-ILIAS-v6.0_GH0.tar.gz) = 158528303
diff --git a/www/ilias6/files/pkg-message.in b/www/ilias6/files/pkg-message.in
new file mode 100644
index 000000000000..6ae9c41a872c
--- /dev/null
+++ b/www/ilias6/files/pkg-message.in
@@ -0,0 +1,41 @@
+[
+{ type: install
+ message: <<EOM
+1 Please keep in mind that
+heavily used ILIAS installation can cause huge growth
+of your log file, so remember to disable notices logging
+in your PHP installation.
+
+2 Also, this installation process has installed everything
+that is needed for ILIAS to run properly with basic
+functionality, but to broaden it you will have to install
+third party software like Sun Java, HTMLdoc, LaTeX or
+some virus scanner by yourself.
+
+3 Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ Alias /ilias %%WWWDIR%%/
+ AcceptPathInfo On
+ <Directory %%WWWDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+4 If you use MySQL, Strict SQL Mode MUST be disabled.
+
+5 After installation, you should use 'composer install'
+in the directory %%WWWDIR%%/libs/composer.
+
+6 Then feel free to proceed to ILIAS web setup proccess.
+ When input Ilias data directory, please use
+ %%PREFIX%%/%%ILIASDATADIR%% and uncheck the create option.
+
+7 If all is OK, you can login into the system with
+username/root and password/homer as the administrator.
+
+For more information, see the INSTALL DOCUMENTATION:
+http://www.ilias.de/docu/goto.php?target=lm_367&client_id=docu
+EOM
+}
+]
diff --git a/www/ilias6/pkg-descr b/www/ilias6/pkg-descr
new file mode 100644
index 000000000000..8e957b1d334f
--- /dev/null
+++ b/www/ilias6/pkg-descr
@@ -0,0 +1,6 @@
+ILIAS is a powerful web-based learning management
+system that allows users to create, edit and publish
+learning and teaching material in an integrated
+system with their normal web browsers.
+
+WWW: http://www.ilias.de