aboutsummaryrefslogtreecommitdiff
path: root/www/ilias
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-18 23:01:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-18 23:01:34 +0000
commita65271d4c4fb666f8b2d6edab58e7ce09e59d293 (patch)
tree0c22b2478c535a9c54388a29bf68955b4c70a949 /www/ilias
parent5b5d978c24a35eee0fda39d399763dae38fff498 (diff)
downloadports-a65271d4c4fb666f8b2d6edab58e7ce09e59d293.tar.gz
ports-a65271d4c4fb666f8b2d6edab58e7ce09e59d293.zip
ILIAS is a powerful web-based learning management
system that allows users to create, edit and publish learning and teaching material in an integrated system with their normal web browsers. WWW: http://www.ilias.de/ios/index-e.html PR: ports/105089 Submitted by: Bartlomiej Rutkowski <r at robakdesign.com>
Notes
Notes: svn path=/head/; revision=177536
Diffstat (limited to 'www/ilias')
-rw-r--r--www/ilias/Makefile65
-rw-r--r--www/ilias/distinfo3
-rw-r--r--www/ilias/files/pkg-message.in15
-rw-r--r--www/ilias/pkg-descr6
4 files changed, 89 insertions, 0 deletions
diff --git a/www/ilias/Makefile b/www/ilias/Makefile
new file mode 100644
index 000000000000..6aeca2c4eb36
--- /dev/null
+++ b/www/ilias/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: www/ilias
+# Date created: Oct 24, 2006
+# Whom: Bartlomiej Rutkowski <r@robakdesign.com>
+#
+# $FreeBSD$
+
+PORTNAME= ilias
+PORTVERSION= 3.7.3
+CATEGORIES= www
+MASTER_SITES= http://www.ilias.de/download/src/
+
+MAINTAINER= r@robakdesign.com
+COMMENT= A poweful, dynamic, PHP and MySQL based e-learning platform
+
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ zip:${PORTSDIR}/archivers/zip \
+ ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/share/pear/PEAR.php:${PORTSDIR}/devel/pear \
+ ${LOCALBASE}/share/pear/Auth/Auth.php:${PORTSDIR}/security/pear-Auth \
+ ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+ ${LOCALBASE}/share/pear/HTML/Template/IT.php:${PORTSDIR}/devel/pear-HTML_Template_IT
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
+
+NO_BUILD= yes
+SUB_FILES= pkg-message
+USE_MYSQL= yes
+DEFAULT_MYSQL_VER= 50
+USE_PHP= mysql session zlib gd pdf xml pcre
+DEFAULT_PHP_VER= 5
+WANT_PHP_MOD= yes
+WRKSRC= ${WRKDIR}/ilias3
+PLIST= ${WRKDIR}/pkg-plist
+
+INSTALL_DIR?= www/${PORTNAME}
+
+OPTIONS= PHP4 "Use PHP4 instead of PHP5" off \
+ MYSQL4 "Use MySQL 4.x instead of MySQL 5.x" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PHP4)
+DEFAULT_PHP_VER= 4
+LIB_DEPENDS+= sablot.70:${PORTSDIR}/textproc/sablotron
+.endif
+
+.if defined(WITH_MYSQL4)
+DEFAULT_MYSQL_VER= 41
+.endif
+
+PLIST_SUB= INSTALL_DIR=${INSTALL_DIR}
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${INSTALL_DIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${INSTALL_DIR}?g" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @cd ${WRKSRC} && ${FIND} . | ${PAX} -rw ${PREFIX}/${INSTALL_DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${INSTALL_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/ilias/distinfo b/www/ilias/distinfo
new file mode 100644
index 000000000000..ecf244a075ff
--- /dev/null
+++ b/www/ilias/distinfo
@@ -0,0 +1,3 @@
+MD5 (ilias-3.7.3.tar.gz) = 2ccb76fec6805a4f35fb50bc688105a0
+SHA256 (ilias-3.7.3.tar.gz) = 440693d8a1d84416489be9753726aa7447b01a0ea2f18ebc2e4af8da5bc8ca30
+SIZE (ilias-3.7.3.tar.gz) = 37878345
diff --git a/www/ilias/files/pkg-message.in b/www/ilias/files/pkg-message.in
new file mode 100644
index 000000000000..bbfd8a1f683b
--- /dev/null
+++ b/www/ilias/files/pkg-message.in
@@ -0,0 +1,15 @@
+=============================================
+Congratulations! You have successfully installed
+ILIAS e-learning platform. Please keep in mind that
+heavily used ILIAS installation can cause huge growth
+of your log file, so remember to disable notices logging
+in your PHP installation.
+
+Also, this installation process have installed everything
+that is needed for ILIAS to run properly with basic
+functionality, but to broaden it you will have to install
+third party software like Sun Java, HTMLdoc, LaTeX or
+some virus scanner by yourself.
+
+Now feel free to proceed to ILIAS web setup proccess.
+=============================================
diff --git a/www/ilias/pkg-descr b/www/ilias/pkg-descr
new file mode 100644
index 000000000000..cf4e811dac7b
--- /dev/null
+++ b/www/ilias/pkg-descr
@@ -0,0 +1,6 @@
+ILIAS is a powerful web-based learning management
+system that allows users to create, edit and publish
+learning and teaching material in an integrated
+system with their normal web browsers.
+
+WWW: http://www.ilias.de/ios/index-e.html