aboutsummaryrefslogtreecommitdiff
path: root/www/jmeter/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 23:11:33 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 23:11:33 +0000
commita36cc6f76069b486e45004dd475af0181e2d50a3 (patch)
tree980687f44e6ea0b8061f73b70997b5ed094b78d7 /www/jmeter/Makefile
parentf093667af6bed85e379cf39682c94edcbfba0c61 (diff)
downloadports-a36cc6f76069b486e45004dd475af0181e2d50a3.tar.gz
ports-a36cc6f76069b486e45004dd475af0181e2d50a3.zip
Remove NOPORTDOCS and NOPORTEXAMPLES.
Notes
Notes: svn path=/head/; revision=360680
Diffstat (limited to 'www/jmeter/Makefile')
-rw-r--r--www/jmeter/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/www/jmeter/Makefile b/www/jmeter/Makefile
index 31a5117649b7..93deccaa6b1a 100644
--- a/www/jmeter/Makefile
+++ b/www/jmeter/Makefile
@@ -54,9 +54,9 @@ EXTRACT_AFTER_ARGS= --exclude '*.bat' --exclude '*.cmd' \
${RUN_DEPENDS:M*.jar*:C|.*/(.+).jar:.*|--exclude '\1-*.jar'|} \
--exclude 'oro-*.jar'
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= docs printable_docs README LICENSE
-.endif
.include <bsd.port.pre.mk>
@@ -72,12 +72,10 @@ do-install:
&& ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${STAGEDIR}/${DATADIR}/{} \;
cd ${WRKSRC} \
&& ${FIND} ${DATAFILES} -type f -not -name '*.orig' -exec ${INSTALL_DATA} {} ${STAGEDIR}${DATADIR}/{} \;
-.if !defined(NOPORTDOCS)
cd ${WRKSRC} \
&& ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \;
cd ${WRKSRC} \
&& ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
-.endif
${INSTALL_SCRIPT} ${WRKDIR}/jmeter.sh ${STAGEDIR}${PREFIX}/bin/jmeter
# For some reason, it is not enough for these three to simply be listed in