aboutsummaryrefslogtreecommitdiff
path: root/www/khtml2png
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-27 22:12:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-27 22:12:09 +0000
commit18dd6954f3060c12b7882f4cb2a1f68dbfc0f102 (patch)
tree51edb00936e1a3da263df313cad16c1fa2858d19 /www/khtml2png
parenteb37a12fc9841da5f3a397814fbb99436d82a988 (diff)
downloadports-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.tar.gz
ports-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.zip
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=213789
Diffstat (limited to 'www/khtml2png')
-rw-r--r--www/khtml2png/Makefile15
1 files changed, 1 insertions, 14 deletions
diff --git a/www/khtml2png/Makefile b/www/khtml2png/Makefile
index bb24611e2655..d53e049d3a83 100644
--- a/www/khtml2png/Makefile
+++ b/www/khtml2png/Makefile
@@ -14,17 +14,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= rafan@FreeBSD.org
COMMENT= Command line program to create screenshots of webpages
-BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
-
USE_KDELIBS_VER= 3
-
-CMAKE?= ${LOCALBASE}/bin/cmake
-
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
- -DCMAKE_C_COMPILER:STRING='${CC}' \
- -DCMAKE_CXX_COMPILER:STRING=${CXX} \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
- -DCMAKE_INSTALL_PREFIX=${PREFIX}
+USE_CMAKE= yes
PLIST_FILES= bin/khtml2png2
@@ -34,8 +25,4 @@ post-patch:
@${REINPLACE_CMD} -e 's,QT_QT_LIBRARY,QT_LIBRARIES,g' \
${WRKSRC}/CMakeLists.txt
-do-configure:
- @cd ${WRKSRC} && ${CMAKE} ${CMAKE_ARGS} -G KDevelop3 ${WRKSRC} && \
- ${CMAKE} ${CMAKE_ARGS} ${WRKSRC}
-
.include <bsd.port.post.mk>