aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-16 02:33:03 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-16 02:33:03 +0000
commit5e2a39ae9c7dedfe3eb2731fe5d23937a0811c2c (patch)
treee228e37a8a5d42dcc3481df4a123ac1ccd1d6d65 /www/libapreq2
parentcc77b2d3dffa4aba29d834d5ca409f51f6bb76a1 (diff)
downloadports-5e2a39ae9c7dedfe3eb2731fe5d23937a0811c2c.tar.gz
ports-5e2a39ae9c7dedfe3eb2731fe5d23937a0811c2c.zip
- Update to 2.12
- We busted something upstream and we need GMAKE now - Bump PORTREVISIONS for p5-libapreq2 ports b/c of shared lib bumps PR: ports/133694 Approved by: maintainer timeout (skv; 1 month 2 days)
Notes
Notes: svn path=/head/; revision=233971
Diffstat (limited to 'www/libapreq2')
-rw-r--r--www/libapreq2/Makefile8
-rw-r--r--www/libapreq2/distinfo6
-rw-r--r--www/libapreq2/files/patch-glue-Makefile.in8
-rw-r--r--www/libapreq2/files/patch-glue-perl-Makefile.PL98
-rw-r--r--www/libapreq2/files/patch-library-Makefile.in14
-rw-r--r--www/libapreq2/files/patch-module-Makefile.in12
6 files changed, 24 insertions, 122 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index 46984bb0b797..539f62f35d14 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libapreq2
-PORTVERSION= 2.08
-PORTREVISION= 3
+PORTVERSION= 2.12
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
@@ -16,6 +15,7 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Generic Apache2 Request Library
USE_APACHE= 2.0+
+USE_GMAKE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf:262 libtool:15
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
@@ -59,9 +59,9 @@ PLIST_SUB+= WITH_MODPERL2="@comment "
.include <bsd.port.pre.mk>
.if ${APACHE_VERSION} == 20
-SHLIB_MAJOR= 8
-.else
SHLIB_MAJOR= 9
+.else
+SHLIB_MAJOR= 10
.endif
.include <bsd.port.post.mk>
diff --git a/www/libapreq2/distinfo b/www/libapreq2/distinfo
index 2b755e4bf1e8..2bd456dd93dd 100644
--- a/www/libapreq2/distinfo
+++ b/www/libapreq2/distinfo
@@ -1,3 +1,3 @@
-MD5 (libapreq2-2.08.tar.gz) = 9fb3deec448f74c455d4ffc13846ea9f
-SHA256 (libapreq2-2.08.tar.gz) = 8f8d71852ea3addab7690fa96fc50ea5f221f719156d50995f7f3e0a5a59e932
-SIZE (libapreq2-2.08.tar.gz) = 847527
+MD5 (libapreq2-2.12.tar.gz) = 76e2acde0d82246dea6f2565f3746eec
+SHA256 (libapreq2-2.12.tar.gz) = 4bf0f37eb92c8a78f3402b2f830ef4928d399bee9ced7a7c0ec218956490b1b8
+SIZE (libapreq2-2.12.tar.gz) = 859412
diff --git a/www/libapreq2/files/patch-glue-Makefile.in b/www/libapreq2/files/patch-glue-Makefile.in
index c70dab377129..9a6685990cd7 100644
--- a/www/libapreq2/files/patch-glue-Makefile.in
+++ b/www/libapreq2/files/patch-glue-Makefile.in
@@ -1,9 +1,9 @@
---- glue/Makefile.in.orig Mon May 29 19:31:01 2006
-+++ glue/Makefile.in Mon May 29 19:31:12 2006
-@@ -262,7 +262,7 @@
- cd perl; $(MAKE) test
+--- ./glue/Makefile.in.orig 2009-04-13 06:32:19.000000000 +0000
++++ ./glue/Makefile.in 2009-04-13 06:32:29.000000000 +0000
+@@ -266,7 +266,7 @@
perl_install:
+ cd perl; INSTALL=1 @PERL@ @PERL_OPTS@ Makefile.PL -apxs @APACHE2_APXS@ @MM_OPTS@
- cd perl; $(MAKE) install
+ cd perl; $(MAKE) pure_install
diff --git a/www/libapreq2/files/patch-glue-perl-Makefile.PL b/www/libapreq2/files/patch-glue-perl-Makefile.PL
index 5c5b336fd18f..26d6f73c2aba 100644
--- a/www/libapreq2/files/patch-glue-perl-Makefile.PL
+++ b/www/libapreq2/files/patch-glue-perl-Makefile.PL
@@ -1,103 +1,5 @@
--- glue/perl/Makefile.PL.orig 2006-08-09 04:26:45.000000000 +0000
+++ glue/perl/Makefile.PL 2008-08-25 18:07:08.000000000 +0000
-@@ -37,6 +37,50 @@
- read $file, $_[0], -s $file;
- }
-
-+sub cmp_tuples {
-+ my ($num_a, $num_b) = @_;
-+
-+ while (@$num_a && @$num_b) {
-+ my $cmp = shift @$num_a <=> shift @$num_b;
-+ return $cmp if $cmp;
-+ }
-+
-+ return @$num_a <=> @$num_b;
-+}
-+
-+sub autoconf_foo {
-+ my ($config, $re_start, $re_end, $re_match) = @_;
-+
-+ $$config =~ /^${re_start}APACHE2_INCLUDES${re_end}($re_match)/m or
-+ die "Can't find apache include directory";
-+ my $apache_includes = $1;
-+ $$config =~ /^${re_start}APR_INCLUDES${re_end}($re_match)/m or
-+ die "Can't find apache include directory";
-+ $apache_includes .= " $1";
-+
-+ my $apr_libs ="";
-+
-+ $$config =~ m/^${re_start}APREQ_LIBNAME${re_end}($re_match)/m or
-+ die "Can't find apreq libname";
-+
-+ my $apreq_libname = $1;
-+
-+ $$config =~ m/^${re_start}PACKAGE_VERSION${re_end}($re_match)/m or
-+ die "Can't find package version";
-+ my $version = $1;
-+
-+ ## Code around an autoconf 2.60 bug
-+ ## http://lists.gnu.org/archive/html/bug-autoconf/2006-06/msg00127.html
-+ ## $ grep @PACKAGE_VERSION config.status-2.59 config.status-2.60
-+ ## config.status-2.59:s,@PACKAGE_VERSION@,2.09,;t t
-+ ## config.status-2.60:s,@PACKAGE_VERSION@,|#_!!_#|2.09,g
-+ foreach ($apache_includes, $apreq_libname, $version) {
-+ s/\|#_!!_#\|//g;
-+ }
-+
-+ return ($apache_includes, $apr_libs, $apreq_libname, $version);
-+}
-+
- my ($apache_includes, $apache_dir, $apr_libs, $apreq_libname, $perl_lib);
-
- if (WIN32) {
-@@ -63,31 +107,22 @@
- }
- else {
- slurp my $config => "$base_dir/config.status";
-- $config =~ /^s,\@APACHE2_INCLUDES\@,([^,]+)/m or
-- die "Can't find apache include directory";
-- $apache_includes = $1;
-- $config =~ /^s,\@APR_INCLUDES\@,([^,]+)/m or
-- die "Can't find apache include directory";
-- $apache_includes .= " $1";
--
--# $config =~ m/^s,\@APR_LDFLAGS\@,([^,]+)/m or
--# die "Can't find apr ldflags";
--# $apr_libs = $1;
--
--# $config =~ m/^s,\@APR_LIBS\@,([^,]+)/m or
--# die "Can't find apr libraries";
--# $apr_libs .= " $1";
--
-- $apr_libs ="";
--
-- $config =~ m/^s,\@APREQ_LIBNAME\@,([^,]+)/m or
-- die "Can't find apreq libname";
-- $apreq_libname = $1;
--
-- $config =~ m/^s,\@PACKAGE_VERSION\@,([^,]+)/m or
-- die "Can't find package version";
-- $version = $1;
-
-+ $config =~ /GNU Autoconf (\d+\.\d+)/;
-+ my $autoconf_ver = $1;
-+
-+ ### XXX: Lord have mercy on us.....
-+ if (cmp_tuples([split /\./, $autoconf_ver], [qw(2 61)]) > 0) {
-+ ### Autoconf >=2.62 changed the format of the file
-+ ### I.E.: S["APACHE2_INCLUDES"]="-I/usr/local/include/apache2"
-+ ($apache_includes, $apr_libs, $apreq_libname, $version) =
-+ autoconf_foo(\$config, qr/S\[\"/, qr/\"\]=\"/, qr/[^\"]+/);
-+ }
-+ else {
-+ ### I.E.: s,@APACHE2_INCLUDES@,-I/usr/local/include/apache22,;t t
-+ ($apache_includes, $apr_libs, $apreq_libname, $version) =
-+ autoconf_foo(\$config, qr/s,\@/, qr/\@,/, qr/[^,]+/);
-+ }
- }
-
- my $apreq_libs = WIN32 ?
@@ -415,8 +450,8 @@
'NAME' => '$class',
'VERSION' => '$version',
diff --git a/www/libapreq2/files/patch-library-Makefile.in b/www/libapreq2/files/patch-library-Makefile.in
index 7192c924b08c..cc5e82cfeea7 100644
--- a/www/libapreq2/files/patch-library-Makefile.in
+++ b/www/libapreq2/files/patch-library-Makefile.in
@@ -1,11 +1,11 @@
---- library/Makefile.in.orig Thu Aug 10 01:43:51 2006
-+++ library/Makefile.in Thu Aug 10 01:43:58 2006
+--- ./library/Makefile.in.orig 2009-04-13 06:34:05.000000000 +0000
++++ ./library/Makefile.in 2009-04-13 06:35:03.000000000 +0000
@@ -144,7 +144,7 @@
- INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/include
+ CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
- LIBOBJS = @LIBOBJS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -L$(prefix)
- LIBTOOL = @LIBTOOL@
- LN_S = @LN_S@
- LTLIBOBJS = @LTLIBOBJS@
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+ @AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/cookie.Plo ./$(DEPDIR)/error.Plo \
diff --git a/www/libapreq2/files/patch-module-Makefile.in b/www/libapreq2/files/patch-module-Makefile.in
index a2d45c437b72..6dc704f27dab 100644
--- a/www/libapreq2/files/patch-module-Makefile.in
+++ b/www/libapreq2/files/patch-module-Makefile.in
@@ -1,11 +1,11 @@
---- module/Makefile.in.orig Tue Aug 8 21:29:05 2006
-+++ module/Makefile.in Thu Aug 10 01:45:23 2006
-@@ -47,7 +47,7 @@
- mkinstalldirs = $(install_sh) -d
+--- ./module/Makefile.in.orig 2009-04-13 06:36:59.000000000 +0000
++++ ./module/Makefile.in 2009-04-13 06:35:59.000000000 +0000
+@@ -128,7 +128,7 @@
CONFIG_HEADER = $(top_builddir)/include/apreq_config.h
CONFIG_CLEAN_FILES =
+ noinst_PROGRAMS = test_cgi$(EXEEXT)
-PROGRAMS = $(noinst_PROGRAMS)
-+PROGRAMS =
++PROGRAMS =
+
test_cgi_SOURCES = test_cgi.c
test_cgi_OBJECTS = test_cgi.$(OBJEXT)
- test_cgi_LDADD = $(LDADD)