aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-28 09:16:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-28 09:16:25 +0000
commit11d33d1b4a55f26c6c437dbcbc425b3850122da9 (patch)
treed0212421e4360c42b340781a50728868f4bfa414 /www/libxul
parent6c8d9b79b0d82421429d52afd05a94c015d17c67 (diff)
downloadports-11d33d1b4a55f26c6c437dbcbc425b3850122da9.tar.gz
ports-11d33d1b4a55f26c6c437dbcbc425b3850122da9.zip
gecko: fix Hunspell ABI mismatch
PR: 214849 MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=427291
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/libxul/files/patch-bug132062139
2 files changed, 40 insertions, 1 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 20564a7f1fc1..78bf9d98e8be 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/www/libxul/files/patch-bug1320621 b/www/libxul/files/patch-bug1320621
new file mode 100644
index 000000000000..7cfebadcfec4
--- /dev/null
+++ b/www/libxul/files/patch-bug1320621
@@ -0,0 +1,39 @@
+Make sure --enable-system-hunspell picks up system headers
+
+--- extensions/spellcheck/hunspell/glue/moz.build
++++ extensions/spellcheck/hunspell/glue/moz.build
+@@ -11,12 +11,14 @@ UNIFIED_SOURCES += [
+ 'RemoteSpellCheckEngineParent.cpp',
+ ]
+
+-CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
+-
+ FINAL_LIBRARY = 'xul'
+
++if CONFIG['MOZ_NATIVE_HUNSPELL']:
++ CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
++else:
++ LOCAL_INCLUDES += ['../src']
++
+ LOCAL_INCLUDES += [
+- '../src',
+ '/dom/base',
+ '/extensions/spellcheck/src',
+ ]
+--- extensions/spellcheck/src/moz.build
++++ extensions/spellcheck/src/moz.build
+@@ -17,9 +17,13 @@ UNIFIED_SOURCES += [
+
+ FINAL_LIBRARY = 'xul'
+
++if CONFIG['MOZ_NATIVE_HUNSPELL']:
++ CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
++else:
++ LOCAL_INCLUDES += ['../hunspell/src']
++
+ LOCAL_INCLUDES += [
+ '../hunspell/glue',
+- '../hunspell/src',
+ '/dom/base',
+ ]
+ EXPORTS.mozilla += [