aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-05-12 18:06:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-05-12 18:06:36 +0000
commit83847c65aa00a6fb44066d0264612f01a874fae5 (patch)
treeb4cc42220c1fd95a72b60309c084d6711c693754 /www/libxul
parent7b79640face9a69c1581543f6d5897d2d548f1fe (diff)
downloadports-83847c65aa00a6fb44066d0264612f01a874fae5.tar.gz
ports-83847c65aa00a6fb44066d0264612f01a874fae5.zip
- Update NSS and ca_root_nss to 3.19
Notes
Notes: svn path=/head/; revision=386162
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile5
-rw-r--r--www/libxul/distinfo4
-rw-r--r--www/libxul/files/patch-bug10211712
3 files changed, 5 insertions, 6 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 3c7388707e7f..31bd5566da5d 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 31.6.0
-PORTREVISION= 1
+DISTVERSION= 31.7.0
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
DISTNAME= firefox-${DISTVERSION}esr.source
@@ -12,7 +11,7 @@ MAINTAINER?= gecko@FreeBSD.org
COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
- nss>=3.16.2:${PORTSDIR}/security/nss \
+ nss>=3.16.2.3:${PORTSDIR}/security/nss \
libevent2>=2.0.21_2:${PORTSDIR}/devel/libevent2 \
cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo \
soundtouch>=1.8.0:${PORTSDIR}/audio/soundtouch \
diff --git a/www/libxul/distinfo b/www/libxul/distinfo
index 95da5e087f1b..cdd6c531f1e3 100644
--- a/www/libxul/distinfo
+++ b/www/libxul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-31.6.0esr.source.tar.bz2) = 88ad45202a7aee9c43378879863b023270aa29463d312f396a78a6e9cdcbf5c3
-SIZE (firefox-31.6.0esr.source.tar.bz2) = 147767808
+SHA256 (firefox-31.7.0esr.source.tar.bz2) = 8523c10ecb318f278a251d90e2161c07c7431796d4387fe9091dfa4e633474b6
+SIZE (firefox-31.7.0esr.source.tar.bz2) = 147772244
diff --git a/www/libxul/files/patch-bug1021171 b/www/libxul/files/patch-bug1021171
index a2c283c644a8..9e663a6779e0 100644
--- a/www/libxul/files/patch-bug1021171
+++ b/www/libxul/files/patch-bug1021171
@@ -162,7 +162,7 @@ index 5aacc23..aed45ca 100644
if (!sourceObject)
- return nullptr;
+ return false;
- ScriptSource *ss = sourceObject->source();
+ ScriptSource* ss = sourceObject->source();
SourceCompressionTask sct(cx);
diff --git js/xpconnect/wrappers/XrayWrapper.cpp js/xpconnect/wrappers/XrayWrapper.cpp