aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-08 12:35:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-08 12:35:43 +0000
commitd377f1f5dfff80fa197972eb7111869558bafc83 (patch)
tree7795d7d60670a5e8ed8367d68f14ca0216b2eb0d /www/libxul
parent404d355ba531a13e8a8261c351279803fe94d0b5 (diff)
downloadports-d377f1f5dfff80fa197972eb7111869558bafc83.tar.gz
ports-d377f1f5dfff80fa197972eb7111869558bafc83.zip
gecko: backport fix for crash on 9.x (lang/gcc5 + -O3)
Notes
Notes: svn path=/head/; revision=425733
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile1
-rw-r--r--www/libxul/files/patch-bug75736658
2 files changed, 59 insertions, 0 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index c28eec15c630..8808ee9ea477 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.5.0
+PORTREVISION= 1
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/www/libxul/files/patch-bug757366 b/www/libxul/files/patch-bug757366
new file mode 100644
index 000000000000..20be9013276d
--- /dev/null
+++ b/www/libxul/files/patch-bug757366
@@ -0,0 +1,58 @@
+commit 2a3be4b384b9
+Author: Jonathan Kew <jkew@mozilla.com>
+Date: Mon Sep 26 18:05:14 2016 +0100
+
+ Bug 757366 - Don't cast pointers to 'name'-table data to uint16_t*, as they may not be 16-bit-aligned. r=jrmuizel
+---
+ gfx/thebes/gfxFontUtils.cpp | 26 ++++++++++++++------------
+ 1 file changed, 14 insertions(+), 12 deletions(-)
+
+diff --git gfx/thebes/gfxFontUtils.cpp gfx/thebes/gfxFontUtils.cpp
+index 526e17d..cb505e8 100644
+--- gfx/thebes/gfxFontUtils.cpp
++++ gfx/thebes/gfxFontUtils.cpp
+@@ -918,16 +918,18 @@ IsValidSFNTVersion(uint32_t version)
+ version == TRUETYPE_TAG('t','r','u','e');
+ }
+
+-// copy and swap UTF-16 values, assume no surrogate pairs, can be in place
++// Copy and swap UTF-16 values, assume no surrogate pairs, can be in place.
++// aInBuf and aOutBuf are NOT necessarily 16-bit-aligned, so we should avoid
++// accessing them directly as uint16_t* values.
++// aLen is count of UTF-16 values, so the byte buffers are twice that.
+ static void
+-CopySwapUTF16(const uint16_t *aInBuf, uint16_t *aOutBuf, uint32_t aLen)
++CopySwapUTF16(const char* aInBuf, char* aOutBuf, uint32_t aLen)
+ {
+- const uint16_t *end = aInBuf + aLen;
++ const char* end = aInBuf + aLen * 2;
+ while (aInBuf < end) {
+- uint16_t value = *aInBuf;
+- *aOutBuf = (value >> 8) | (value & 0xff) << 8;
+- aOutBuf++;
+- aInBuf++;
++ uint8_t b0 = *aInBuf++;
++ *aOutBuf++ = *aInBuf++;
++ *aOutBuf++ = b0;
+ }
+ }
+
+@@ -1446,13 +1448,13 @@ gfxFontUtils::DecodeFontName(const char *aNameData, int32_t aByteLen,
+ if (csName[0] == 0) {
+ // empty charset name: data is utf16be, no need to instantiate a converter
+ uint32_t strLen = aByteLen / 2;
+-#ifdef IS_LITTLE_ENDIAN
+ aName.SetLength(strLen);
+- CopySwapUTF16(reinterpret_cast<const uint16_t*>(aNameData),
+- reinterpret_cast<uint16_t*>(aName.BeginWriting()), strLen);
++#ifdef IS_LITTLE_ENDIAN
++ CopySwapUTF16(aNameData, reinterpret_cast<char*>(aName.BeginWriting()),
++ strLen);
+ #else
+- aName.Assign(reinterpret_cast<const char16_t*>(aNameData), strLen);
+-#endif
++ memcpy(aName.BeginWriting(), aNameData, strLen * 2);
++#endif
+ return true;
+ }
+