aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-09 06:16:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-09 06:16:35 +0000
commitf4aef6b62c614ecd1d50069031eae67318ac5ff9 (patch)
tree781de0366f06f8728245988a38a42d4e172d024d /www/libxul
parentebc9843f2f48e534a414da8a8ee31543e08cfdf6 (diff)
downloadports-f4aef6b62c614ecd1d50069031eae67318ac5ff9.tar.gz
ports-f4aef6b62c614ecd1d50069031eae67318ac5ff9.zip
Mozilla upgrades:
- Update nspr to 4.10.7 - Update ca_root_nss to 3.17 (mark as NO_ARCH while here) - Update firefox to 32.0 - Update thunderbird to 31.1.0 - Add net-im/linux-instantbird - Update firefox-est to 31.1.0 - Update libxul to 24.8.0 - Update seamonkey to 2.29 Submitted by: Jan Beich for gecko@
Notes
Notes: svn path=/head/; revision=367712
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile6
-rw-r--r--www/libxul/distinfo4
-rw-r--r--www/libxul/files/patch-bug104622426
-rw-r--r--www/libxul/files/pkg-deinstall.in28
-rw-r--r--www/libxul/files/pkg-install.in37
5 files changed, 96 insertions, 5 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 9cf474b39e60..61847fe016a9 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 24.7.0
+DISTVERSION= 24.8.0
CATEGORIES?= www devel
-MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
+MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
+ https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/${DISTVERSION}esr-candidates/build1/source/
DISTNAME= firefox-${DISTVERSION}esr.source
MAINTAINER?= gecko@FreeBSD.org
@@ -29,7 +30,6 @@ WRKSRC= ${WRKDIR}/mozilla-esr24
CONFLICTS= libxul-1.9.*
USE_AUTOTOOLS= autoconf213:env
-USE_PYTHON_BUILD=2
WANT_GNOME= yes
USE_QT4= # empty
QT_NONSTANDARD= yes
diff --git a/www/libxul/distinfo b/www/libxul/distinfo
index ff44c811e43b..a4762361cfbb 100644
--- a/www/libxul/distinfo
+++ b/www/libxul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-24.7.0esr.source.tar.bz2) = 079b6021f153ba11658cefe41d467e25357cd78e84d3d66c6abcfecb5a00121f
-SIZE (firefox-24.7.0esr.source.tar.bz2) = 119967111
+SHA256 (firefox-24.8.0esr.source.tar.bz2) = d1247f58f898f2dcc0f21572ac0df6d27a3ed6b0a4c92f6d10ad377ac021c006
+SIZE (firefox-24.8.0esr.source.tar.bz2) = 119635865
diff --git a/www/libxul/files/patch-bug1046224 b/www/libxul/files/patch-bug1046224
new file mode 100644
index 000000000000..50d268f8fabe
--- /dev/null
+++ b/www/libxul/files/patch-bug1046224
@@ -0,0 +1,26 @@
+diff --git configure.in configure.in
+index 1853029..559bd45 100644
+--- configure.in
++++ configure.in
+@@ -2651,7 +2651,7 @@ if test "$ac_cv_sockaddr_sa_len" = true ; then
+ AC_DEFINE(HAVE_SA_LEN)
+ fi
+
+-AC_ARG_ENABLE(dtrace,
++MOZ_ARG_ENABLE_BOOL(dtrace,
+ [ --enable-dtrace build with dtrace support if available (default=no)],
+ [enable_dtrace="yes"],)
+ if test "x$enable_dtrace" = "xyes"; then
+diff --git js/src/configure.in js/src/configure.in
+index 134dfd3..682c1fb 100644
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -2153,7 +2153,7 @@ dnl Quota support
+ MOZ_CHECK_HEADERS(sys/quota.h)
+ MOZ_CHECK_HEADERS(linux/quota.h)
+
+-AC_ARG_ENABLE(dtrace,
++MOZ_ARG_ENABLE_BOOL(dtrace,
+ [ --enable-dtrace build with dtrace support if available (default=no)],
+ [enable_dtrace="yes"],)
+ if test "x$enable_dtrace" = "xyes"; then
diff --git a/www/libxul/files/pkg-deinstall.in b/www/libxul/files/pkg-deinstall.in
new file mode 100644
index 000000000000..2544ee4ed3a2
--- /dev/null
+++ b/www/libxul/files/pkg-deinstall.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.25 2008/07/26 19:07:07 ahze Exp $
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+# Fix the chrome registry.
+
+umask 022
+PATH=/bin:/usr/bin
+
+[ "x$1" = "x" ] && exit 1
+[ "x$2" != "xDEINSTALL" ] && exit 0
+
+MOZDIR=%%MOZDIR%%
+
+rm -rf ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/chrome/*.rdf
+rm -f ${MOZDIR}/component.reg
+rm -f ${MOZDIR}/components/*.dat
+rm -f ${MOZDIR}/components.ini
+rm -f ${MOZDIR}/defaults.ini
+rm -f ${MOZDIR}/chrome/app-chrome.manifest
+rm -rf ${MOZDIR}/updates
+find %%MOZDIR%%/plugins/ -depth 1 -type l -delete > /dev/null 2>&1
+find %%MOZDIR%%/extensions/ -depth 1 -type l -delete > /dev/null 2>&1
+
+exit 0
diff --git a/www/libxul/files/pkg-install.in b/www/libxul/files/pkg-install.in
new file mode 100644
index 000000000000..9feab2225a78
--- /dev/null
+++ b/www/libxul/files/pkg-install.in
@@ -0,0 +1,37 @@
+#!/bin/sh
+#
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.26 2008/08/04 16:58:03 mezz Exp $
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+# Fix the chrome registry.
+
+umask 022
+PATH=/bin:/usr/bin
+
+[ "x$1" = "x" ] && exit 1
+[ "x$2" != "xPOST-INSTALL" ] && exit 0
+
+MOZDIR=%%MOZDIR%%
+MOZBIN=${MOZDIR}/%%MOZILLA_BIN%%
+REGXPCOM=${MOZDIR}/regxpcom
+REGCHROME=${MOZDIR}/regchrome
+
+rm -rf ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/chrome/*.rdf
+mkdir -p ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/component.reg
+
+cd ${MOZDIR} || exit 1
+if [ -f ${REGXPCOM} ]; then
+ ./run-mozilla.sh ${REGXPCOM} || true
+fi
+if [ -f ${REGCHROME} ]; then
+ ./run-mozilla.sh ${REGCHROME} || true
+fi
+if [ -f ${MOZBIN} -a "${1%-*}" = "nvu" ]; then
+ ./run-mozilla.sh ${MOZBIN} -register > /dev/null 2>&1
+fi
+cp -R %%LOCALBASE%%/lib/xpi/symlinks/%%MOZILLA%%/ %%MOZDIR%%/extensions/ > /dev/null 2>&1
+
+exit 0