aboutsummaryrefslogtreecommitdiff
path: root/www/links
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2002-06-28 11:35:38 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2002-06-28 11:35:38 +0000
commit8be5d6ef7c7c5a4ea8e70c47a007ee0dd1259853 (patch)
treebf2e316d0e39f2d911fc8740188a72cfe84919c7 /www/links
parent807943fa6d05c98793c9ab99886da0f869a5895e (diff)
downloadports-8be5d6ef7c7c5a4ea8e70c47a007ee0dd1259853.tar.gz
ports-8be5d6ef7c7c5a4ea8e70c47a007ee0dd1259853.zip
Update to version 2.0.
Now with graphics mode support. PR: 39903 Submitted by: matthias.andree@web.de (with numerious modifications).
Notes
Notes: svn path=/head/; revision=62149
Diffstat (limited to 'www/links')
-rw-r--r--www/links/Makefile27
-rw-r--r--www/links/distinfo2
-rw-r--r--www/links/files/patch-width30
-rw-r--r--www/links/pkg-descr22
-rw-r--r--www/links/pkg-plist11
5 files changed, 51 insertions, 41 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index d6a95872a179..dcc49fea6db4 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -6,21 +6,36 @@
#
PORTNAME= links
-PORTVERSION= 0.97
-PORTREVISION= 1
+PORTVERSION= 2.0
PORTEPOCH= 1
CATEGORIES= www
-MASTER_SITES= http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/download/ \
- http://ice.dammit.lt/links/download/ \
- http://links.sourceforge.net/download/ \
- ftp://ftp.fu-berlin.de/unix/network/www/links/
+MASTER_SITES= http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/download/
MAINTAINER= demon@FreeBSD.org
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-javascript --with-ssl --without-svgalib
USE_OPENSSL= yes
+USE_BZIP2= yes
+
+.if !defined(WITHOUT_X11)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+USE_XLIB= yes
+CONFIGURE_ARGS+= --enable-graphics --with-x
+.endif
MAN1= links.1
+pre-everything::
+ @${ECHO_MSG} "Define WITHOUT_X11 to disable graphics support."
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/links_cal/* ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/www/links/distinfo b/www/links/distinfo
index 38fa1daa4f21..3d2b1143eb27 100644
--- a/www/links/distinfo
+++ b/www/links/distinfo
@@ -1 +1 @@
-MD5 (links-0.97.tar.gz) = 57d4ade86c49038b3d4bab66ad24c066
+MD5 (links-2.0.tar.bz2) = c41b3dea2c4a93ed77636db3c67807e2
diff --git a/www/links/files/patch-width b/www/links/files/patch-width
index ebaf38fffe06..88c9b8f0a52b 100644
--- a/www/links/files/patch-width
+++ b/www/links/files/patch-width
@@ -1,8 +1,8 @@
---- default.c Tue Mar 5 11:31:44 2002
-+++ default.c Tue Mar 5 11:26:50 2002
-@@ -773,6 +773,9 @@
- Write a plain-text version of the given HTML document to\n\
- stdout.\n\
+--- default.c.orig Fri Jun 28 14:53:11 2002
++++ default.c Fri Jun 28 14:56:17 2002
+@@ -908,6 +908,9 @@
+ is allowed, but user can't add or modify entries in\n\
+ association table.\n\
\n\
+ -width <size>\n\
+ Size of screen in characters, used in combination with -dump\n\
@@ -10,22 +10,22 @@
-no-connect\n\
Runs links as a separate instance - instead of connecting to\n\
existing instance.\n\
-@@ -831,6 +834,7 @@
+@@ -982,6 +985,7 @@
int download_utime = 0;
int max_connections = 10;
- int max_connections_to_host = 2;
+ int max_connections_to_host = 8;
+int screen_width = 80;
int max_tries = 3;
int receive_timeout = 120;
int unrestartable_receive_timeout = 600;
-@@ -884,6 +888,7 @@
- 1, gen_cmd, num_rd, num_wr, 1, 16, &max_connections, "max_connections", "max-connections",
- 1, gen_cmd, num_rd, num_wr, 1, 8, &max_connections_to_host, "max_connections_to_host", "max-connections-to-host",
- 1, gen_cmd, num_rd, num_wr, 1, 16, &max_tries, "retries", "retries",
-+ 1, gen_cmd, num_rd, num_wr, 40, 512, &screen_width, "screen_width", "width",
- 1, gen_cmd, num_rd, num_wr, 1, 1800, &receive_timeout, "receive_timeout", "receive-timeout",
- 1, gen_cmd, num_rd, num_wr, 1, 1800, &unrestartable_receive_timeout, "unrestartable_receive_timeout", "unrestartable-receive-timeout",
- 1, gen_cmd, num_rd, num_wr, 0, 256, &max_format_cache_entries, "format_cache_size", "format-cache-size",
+@@ -1060,6 +1064,7 @@
+ {1, gen_cmd, num_rd, num_wr, 1, 16, &max_connections, "max_connections", "max-connections"},
+ {1, gen_cmd, num_rd, num_wr, 1, 8, &max_connections_to_host, "max_connections_to_host", "max-connections-to-host"},
+ {1, gen_cmd, num_rd, num_wr, 1, 16, &max_tries, "retries", "retries"},
++ {1, gen_cmd, num_rd, num_wr, 40, 512, &screen_width, "screen_width", "width"},
+ {1, gen_cmd, num_rd, num_wr, 1, 1800, &receive_timeout, "receive_timeout", "receive-timeout"},
+ {1, gen_cmd, num_rd, num_wr, 1, 1800, &unrestartable_receive_timeout, "unrestartable_receive_timeout", "unrestartable-receive-timeout"},
+ {1, gen_cmd, num_rd, num_wr, 0, 256, &max_format_cache_entries, "format_cache_size", "format-cache-size"},
--- links.1 Mon Jan 1 09:26:52 2001
+++ links.1 Tue Mar 5 11:34:37 2002
@@ -94,6 +94,11 @@
diff --git a/www/links/pkg-descr b/www/links/pkg-descr
index 0a03e6e67397..b86d28f63d79 100644
--- a/www/links/pkg-descr
+++ b/www/links/pkg-descr
@@ -1,23 +1,7 @@
-Lynx-like text WWW browser with many features like displaying tables,
-menus, etc.
+Lynx-like WWW browser with text and graphics modes with many features
+like displaying tables, menus, etc.
-Keys: ESC display menu
- ^C quit
- ^P, ^N scroll up, down
- [, ] scroll left, right
- up, down select link
- -> follow link
- <- go back
- g go to url
- / search
- ? search back
- n find next
- N find previous
- = document info
- \ document source
- d download
-
-WWW: http://artax.karlin.mff.cuni.cz/~mikulas/vyplody/links/
+WWW: http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/
- Michael Vasilenko
acid@stu.cn.ua
diff --git a/www/links/pkg-plist b/www/links/pkg-plist
index 191550099363..328baa89325b 100644
--- a/www/links/pkg-plist
+++ b/www/links/pkg-plist
@@ -1 +1,12 @@
bin/links
+%%PORTDOCS%%share/doc/links/adjusted.png
+%%PORTDOCS%%share/doc/links/black-control-rocking.png
+%%PORTDOCS%%share/doc/links/black-icon.png
+%%PORTDOCS%%share/doc/links/calibration.html
+%%PORTDOCS%%share/doc/links/elbow.png
+%%PORTDOCS%%share/doc/links/kalibrace.html
+%%PORTDOCS%%share/doc/links/picture-crank-0.png
+%%PORTDOCS%%share/doc/links/picture-crank-up.png
+%%PORTDOCS%%share/doc/links/picture-icon.png
+%%PORTDOCS%%share/doc/links/test_pattern.png
+@dirrm share/doc/links