aboutsummaryrefslogtreecommitdiff
path: root/www/linux-mplayer-plugin
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-03 13:50:16 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-03 13:50:16 +0000
commit03052a85f94e35a35998cec4f10116e2f81f588e (patch)
tree568a3306f0746bb2947ac29055d1f90f3e08d3c1 /www/linux-mplayer-plugin
parentec1db8498854a3d57fca768b933a78d6e7e7e63b (diff)
downloadports-03052a85f94e35a35998cec4f10116e2f81f588e.tar.gz
ports-03052a85f94e35a35998cec4f10116e2f81f588e.zip
- Extend the list of supported apps in a preemptive way
- Do not farm links in linux-opera private plugins dir [1] Submitted by: mezz [1]
Notes
Notes: svn path=/head/; revision=169561
Diffstat (limited to 'www/linux-mplayer-plugin')
-rw-r--r--www/linux-mplayer-plugin/Makefile.npapi16
1 files changed, 9 insertions, 7 deletions
diff --git a/www/linux-mplayer-plugin/Makefile.npapi b/www/linux-mplayer-plugin/Makefile.npapi
index e1db9dcc5b00..2b9889cfdad8 100644
--- a/www/linux-mplayer-plugin/Makefile.npapi
+++ b/www/linux-mplayer-plugin/Makefile.npapi
@@ -62,11 +62,13 @@ PKGDEINSTALL?= ${NPAPI_PKGDEINSTALL}
NPAPI_APPS_ALL_WC= *mozilla* *firefox* *flock* *seamonkey* *opera*
NPAPI_APPS_ALL_WC_LINUX= ${NPAPI_APPS_ALL_WC:S/^*/linux-/}
NPAPI_APPS_ALL_WC_NATIVE= ${NPAPI_APPS_ALL_WC:S/^*//}
-NPAPI_APPS_ALL= mozilla mozilla-devel linux-mozilla \
- firefox firefox-devel linux-firefox linux-firefox-devel \
- flock linux-flock \
- seamonkey linux-seamonkey linux-seamonkey-devel \
- opera linux-opera
+NPAPI_APPS_ALL= firefox firefox-devel linux-firefox linux-firefox-devel \
+ flock flock-devel linux-flock linux-flock-devel \
+ mozilla mozilla-devel linux-mozilla \
+ nvu linux-nvu \
+ opera opera-devel linux-opera linux-opera-devel \
+ seamonkey seamonkey-devel linux-seamonkey linux-seamonkey-devel \
+ sunbird sunbird-devel linux-sunbird linux-sunbird-devel
# === Let's process WITH_NPAPI into WITH_NPAPI_APPS
WITH_NPAPI_TUPLES= ${WITH_NPAPI:M*?\:?*}
@@ -124,8 +126,8 @@ USE_NPAPI_EXP+= ${_TEMP_APP__}
NPAPI_APPS?= ${USE_NPAPI_EXP:S.^.${LOCALBASE}/lib/.:S.$./plugins.:N*opera*} \
${USE_NPAPI_EXP:S.^.${X11BASE}/lib/.:S.$./plugins.:N*opera*} \
- ${USE_NPAPI_EXP:S.^.${LOCALBASE}/share/.:S.$./plugins.:M*opera*} \
- ${USE_NPAPI_EXP:S.^.${X11BASE}/share/.:S.$./plugins.:M*opera*}
+ ${USE_NPAPI_EXP:S.^.${LOCALBASE}/share/.:S.$./plugins.:M*/opera*} \
+ ${USE_NPAPI_EXP:S.^.${X11BASE}/share/.:S.$./plugins.:M*/opera*}
NPAPI_SLDIRS_ALL= ${NPAPI_APPS_ALL:S.^.${NPAPI_SLDIR}/.}
NPAPI_SLDIRS= ${USE_NPAPI_EXP:S.^.${NPAPI_SLDIR}/.}
NPAPI_LINKFARMS= ${NPAPI_APPS} ${NPAPI_SLDIRS}