aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-02-05 00:02:27 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-02-05 00:02:27 +0000
commited1faaa68082b16ec29223d8170fd32a30be0996 (patch)
tree995a0dc058c389f22166f59ffefaa519e0688f4e /www/linux-opera/Makefile
parent924f7558f2981d345c83e2531421a976dd9f55f2 (diff)
downloadports-ed1faaa68082b16ec29223d8170fd32a30be0996.tar.gz
ports-ed1faaa68082b16ec29223d8170fd32a30be0996.zip
-Update to 7.54u2 (7.54.20050131), this is mostly security fixes release.
Security: - Solved data URL issue described in Secunia Advisory SA13818, http://secunia.com/advisories/13818/ - Additional fixes for frame injection issue reported in Secunia Advisory SA13253, http://secunia.com/advisories/13253/ Miscellaneous: - Improvements to handling of the must-revalidate directive. - Solved stability issue in Japanese version. UNIX specific: - Added extra warning dialog when opening .sh, .desktop or executables directly from Web or from transfer manager with kfmclient exec. Addresses issue reported in Secunia Advisory SA13447, http://secunia.com/advisories/13447/ - Fixed crash when importing e-mail. http://www.opera.com/linux/changelogs/754u2/ - Few other small cleans up. - Let's see if Realplayer plugins will work for anyone. It's not tested, but added support. I am not going to be surpised if the support is limited as common in the Linux world.
Notes
Notes: svn path=/head/; revision=128053
Diffstat (limited to 'www/linux-opera/Makefile')
-rw-r--r--www/linux-opera/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index c4c983e9f4e3..b6133e0e892e 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -7,18 +7,17 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
-PORTREVISION= 1
CATEGORIES= www linux
-MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ftp://ftp.sunet.se/pub/www/clients/Opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ftp://sunsite.cnlab-switch.ch/mirror/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ftp://ftp.tiscali.nl/pub/mirrors/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ftp://ftp.ntua.gr/pub/www/Opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- http://mirrors.pmmf.hu/mirror/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ftp://ftp.task.gda.pl/pub/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ftp://ftp.planetmirror.com/pub/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- http://gd.tuwien.ac.at/infosys/browsers/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/ \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/linux/${OPERA_VER:S/.//}u1/final/en/i386/static/&,}
+MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ftp://ftp.sunet.se/pub/www/clients/Opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ftp://ftp.tiscali.nl/pub/mirrors/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ftp://ftp.ntua.gr/pub/www/Opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ http://mirrors.pmmf.hu/mirror/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ftp://ftp.task.gda.pl/pub/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ftp://ftp.planetmirror.com/pub/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ http://gd.tuwien.ac.at/infosys/browsers/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/linux/${OPERA_VER:S/.//}u2/final/en/i386/static/&,}
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}-${OPERA_VER}-${OPERA_DATE}.1-static-qt.i386-en
@@ -31,18 +30,18 @@ RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XF
RESTRICTED= "not redistributable; commercial software"
+PREFIX?= ${X11BASE}
USE_BZIP2= yes
WANT_GNOME= yes
-PREFIX?= ${X11BASE}
-USE_REINPLACE= yes
WITH_LINUX= yes
+USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
NO_FILTER_SHLIBS=yes
OPERA_VER= 7.54
-OPERA_DATE= 20041210
+OPERA_DATE= 20050131
DATADIR= ${PREFIX}/share/${UNIQUENAME}
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}