aboutsummaryrefslogtreecommitdiff
path: root/www/llgal
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-01-25 20:20:34 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-01-25 20:20:34 +0000
commita3f4d5bb69bfdf3e91d080c1bdd674c4758edfdb (patch)
tree30bd7d81e896ea3a1d2d549d1e01af3659346f0b /www/llgal
parente3719f011f74c1f505f0365fe2b487917cbd8a8f (diff)
downloadports-a3f4d5bb69bfdf3e91d080c1bdd674c4758edfdb.tar.gz
ports-a3f4d5bb69bfdf3e91d080c1bdd674c4758edfdb.zip
Add llgal, a commandline image gallery generator
Notes
Notes: svn path=/head/; revision=183287
Diffstat (limited to 'www/llgal')
-rw-r--r--www/llgal/Makefile29
-rw-r--r--www/llgal/distinfo3
-rw-r--r--www/llgal/pkg-descr6
-rw-r--r--www/llgal/pkg-plist17
4 files changed, 55 insertions, 0 deletions
diff --git a/www/llgal/Makefile b/www/llgal/Makefile
new file mode 100644
index 000000000000..e8efa11de608
--- /dev/null
+++ b/www/llgal/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: llgal
+# Date created: 2007-01-25
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= llgal
+PORTVERSION= 0.13.9
+CATEGORIES= www
+MASTER_SITES= http://download.gna.org/llgal/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Command-line online gallery generator
+
+BUILD_DEPENDS= ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool
+RUN_DEPENDS= ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool
+
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>
diff --git a/www/llgal/distinfo b/www/llgal/distinfo
new file mode 100644
index 000000000000..b7b3c4dbe214
--- /dev/null
+++ b/www/llgal/distinfo
@@ -0,0 +1,3 @@
+MD5 (llgal-0.13.9.tar.bz2) = a76fbb238b132249870d4f5f0b08283a
+SHA256 (llgal-0.13.9.tar.bz2) = 9234e2d984bc28dfa5b12cbf8f5f6a7a554a0f4457f19a9d2bd57b1a988d4875
+SIZE (llgal-0.13.9.tar.bz2) = 76207
diff --git a/www/llgal/pkg-descr b/www/llgal/pkg-descr
new file mode 100644
index 000000000000..919deb68b4d0
--- /dev/null
+++ b/www/llgal/pkg-descr
@@ -0,0 +1,6 @@
+llgal is an easy and fast on-line gallery generator based on iGal.
+Its primary goal is to NOT require any boring useless expensive feature in
+your webserver, such as PHP, JavaScript, SQL, ...
+Thus, llgal generates static web-pages.
+
+WWW: http://home.gna.org/llgal/
diff --git a/www/llgal/pkg-plist b/www/llgal/pkg-plist
new file mode 100644
index 000000000000..6acd7fb12118
--- /dev/null
+++ b/www/llgal/pkg-plist
@@ -0,0 +1,17 @@
+bin/llgal
+etc/llgal/llgalrc
+%%SITE_PERL%%/Llgal/Config.pm
+%%SITE_PERL%%/Llgal/Utils.pm
+%%SITE_PERL%%/Llgal/Templates.pm
+%%SITE_PERL%%/Llgal/Messages.pm
+share/llgal/captions.header
+share/llgal/index.png
+share/llgal/indextemplate.html
+share/llgal/llgal.css
+share/llgal/next.png
+share/llgal/prev.png
+share/llgal/slidetemplate.html
+share/llgal/tile.png
+share/locale/fr/LC_MESSAGES/llgal.mo
+@dirrm %%SITE_PERL%%/Llgal
+@dirrm etc/llgal