aboutsummaryrefslogtreecommitdiff
path: root/www/llhttp
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 15:37:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 15:55:51 +0000
commitb6b97284627fc03401f1f3c83b6a025e4b02f2ed (patch)
tree4ba0345caacd2b7628bf19845dea5c43147084c8 /www/llhttp
parent0e1e73c545bc9142e30ff1c39b56506978bf8930 (diff)
downloadports-b6b97284627fc03401f1f3c83b6a025e4b02f2ed.tar.gz
ports-b6b97284627fc03401f1f3c83b6a025e4b02f2ed.zip
www/llhttp: Update to 6.0.5
Diffstat (limited to 'www/llhttp')
-rw-r--r--www/llhttp/Makefile7
-rw-r--r--www/llhttp/distinfo6
-rw-r--r--www/llhttp/files/CMakeLists.txt64
-rw-r--r--www/llhttp/files/patch-CMakeLists.txt46
4 files changed, 50 insertions, 73 deletions
diff --git a/www/llhttp/Makefile b/www/llhttp/Makefile
index 8e6de18aa8ff..db89c6965f5b 100644
--- a/www/llhttp/Makefile
+++ b/www/llhttp/Makefile
@@ -1,9 +1,8 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= llhttp
-PORTVERSION= 6.0.4
+PORTVERSION= 6.0.5
DISTVERSIONPREFIX= release/v
-PORTREVISION= 1
CATEGORIES= www
MAINTAINER= sunpoet@FreeBSD.org
@@ -19,8 +18,4 @@ CMAKE_ON= BUILD_SHARED_LIBS
GH_ACCOUNT= nodejs
USE_GITHUB= yes
-post-patch:
-# https://github.com/nodejs/llhttp/blob/master/CMakeLists.txt
- @${CP} ${FILESDIR}/CMakeLists.txt ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/www/llhttp/distinfo b/www/llhttp/distinfo
index f53b9c676117..c18cf6b28087 100644
--- a/www/llhttp/distinfo
+++ b/www/llhttp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1629364640
-SHA256 (nodejs-llhttp-release-v6.0.4_GH0.tar.gz) = a2dc90e41060f89a7682c4c325e226599139a78e65bb5b79f28d6a52bac267c4
-SIZE (nodejs-llhttp-release-v6.0.4_GH0.tar.gz) = 37328
+TIMESTAMP = 1632664302
+SHA256 (nodejs-llhttp-release-v6.0.5_GH0.tar.gz) = 28d5bc494d379228cd7a9af32dfc518fc9e6c5ad56838cafb63e8062bee06bda
+SIZE (nodejs-llhttp-release-v6.0.5_GH0.tar.gz) = 38102
diff --git a/www/llhttp/files/CMakeLists.txt b/www/llhttp/files/CMakeLists.txt
deleted file mode 100644
index 2a3bb13a0028..000000000000
--- a/www/llhttp/files/CMakeLists.txt
+++ /dev/null
@@ -1,64 +0,0 @@
-cmake_minimum_required(VERSION 3.5.1)
-cmake_policy(SET CMP0069 NEW)
-
-project(llhttp C)
-
-set(CMAKE_C_STANDARD 99)
-
-#
-# Options
-#
-# Generic option
-#option(BUILD_SHARED_LIBS "Build shared libraries (.dll/.so) instead of static ones (.lib/.a)" OFF)
-
-# Source code
-set(LLHTTP_SOURCES
- src/llhttp.c
- src/http.c
- src/api.c
-)
-
-set(LLHTTP_HEADERS
- include/llhttp.h
-)
-
-add_library(llhttp)
-add_library(llhttp_static STATIC)
-add_library(llhttp::llhttp ALIAS llhttp)
-
-target_sources(llhttp PRIVATE ${LLHTTP_SOURCES} ${LLHTTP_HEADERS})
-target_sources(llhttp_static PRIVATE ${LLHTTP_SOURCES} ${LLHTTP_HEADERS})
-
-# On windows with Visual Studio, add a debug postfix so that release
-# and debug libraries can coexist.
-if(MSVC)
- set(CMAKE_DEBUG_POSTFIX "d")
-endif()
-
-target_include_directories(llhttp PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
- $<INSTALL_INTERFACE:include>
-)
-target_include_directories(llhttp_static PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
- $<INSTALL_INTERFACE:include>
-)
-
-
-set_target_properties(llhttp PROPERTIES PUBLIC_HEADER ${LLHTTP_HEADERS})
-set_target_properties(llhttp_static PROPERTIES OUTPUT_NAME llhttp)
-
-install(TARGETS llhttp
- EXPORT llhttp
- ARCHIVE DESTINATION lib
- PUBLIC_HEADER DESTINATION include/
-)
-install(TARGETS llhttp_static
- ARCHIVE DESTINATION lib
-)
-
-# This is required to work with FetchContent
-install(EXPORT llhttp
- FILE llhttp-config.cmake
- NAMESPACE llhttp::
- DESTINATION lib/cmake/llhttp)
diff --git a/www/llhttp/files/patch-CMakeLists.txt b/www/llhttp/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a4fdd7981dee
--- /dev/null
+++ b/www/llhttp/files/patch-CMakeLists.txt
@@ -0,0 +1,46 @@
+--- CMakeLists.txt.orig 2021-08-25 00:31:04 UTC
++++ CMakeLists.txt
+@@ -9,7 +9,7 @@ set(CMAKE_C_STANDARD 99)
+ # Options
+ #
+ # Generic option
+-option(BUILD_SHARED_LIBS "Build shared libraries (.dll/.so) instead of static ones (.lib/.a)" OFF)
++#option(BUILD_SHARED_LIBS "Build shared libraries (.dll/.so) instead of static ones (.lib/.a)" OFF)
+
+ # Source code
+ set(LLHTTP_SOURCES
+@@ -23,9 +23,11 @@ set(LLHTTP_HEADERS
+ )
+
+ add_library(llhttp)
++add_library(llhttp_static STATIC)
+ add_library(llhttp::llhttp ALIAS llhttp)
+
+ target_sources(llhttp PRIVATE ${LLHTTP_SOURCES} ${LLHTTP_HEADERS})
++target_sources(llhttp_static PRIVATE ${LLHTTP_SOURCES} ${LLHTTP_HEADERS})
+
+ # On windows with Visual Studio, add a debug postfix so that release
+ # and debug libraries can coexist.
+@@ -37,13 +39,22 @@ target_include_directories(llhttp PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+ $<INSTALL_INTERFACE:include>
+ )
++target_include_directories(llhttp_static PUBLIC
++ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
++ $<INSTALL_INTERFACE:include>
++)
+
++
+ set_target_properties(llhttp PROPERTIES PUBLIC_HEADER ${LLHTTP_HEADERS})
++set_target_properties(llhttp_static PROPERTIES OUTPUT_NAME llhttp)
+
+ install(TARGETS llhttp
+ EXPORT llhttp
+ ARCHIVE DESTINATION lib
+ PUBLIC_HEADER DESTINATION include/
++)
++install(TARGETS llhttp_static
++ ARCHIVE DESTINATION lib
+ )
+
+ # This is required to work with FetchContent