aboutsummaryrefslogtreecommitdiff
path: root/www/lynx-current/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-06-09 19:55:14 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-06-09 19:55:14 +0000
commit1d8b7ee2b92226bc88d127aed0c343f8792449aa (patch)
tree5a394d89de6043f41ba5097536aa3ccd613f4733 /www/lynx-current/Makefile
parent0983ec3e090668b39664ef0695c8fc9327a7434e (diff)
downloadports-1d8b7ee2b92226bc88d127aed0c343f8792449aa.tar.gz
ports-1d8b7ee2b92226bc88d127aed0c343f8792449aa.zip
Upgrade to pre.1
Enable ssl and some features
Notes
Notes: svn path=/head/; revision=43722
Diffstat (limited to 'www/lynx-current/Makefile')
-rw-r--r--www/lynx-current/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 02b29d3ddffe..4c14c18a7454 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= lynx
-PORTVERSION= 2.8.4d20
+PORTVERSION= 2.8.4p1
CATEGORIES= www ipv6
MASTER_SITES= http://lynx.isc.org/current/
-DISTNAME= ${PORTNAME}2.8.4dev.20
+DISTNAME= ${PORTNAME}2.8.4pre.1
MAINTAINER= ache@FreeBSD.org
@@ -20,11 +20,20 @@ USE_BZIP2= yes
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-screen=ncurses --with-zlib --libdir="${L_LIB}" \
- --enable-nsl-fork --enable-persistent-cookies \
- --enable-nls
+ --enable-nsl-fork --enable-nls --enable-prettysrc \
+ --enable-file-upload --enable-nested-tables \
+ --enable-source-cache
+
+.ifndef NO_OPENSSL
+USE_OPENSSL= yes
+.endif
.include <bsd.port.pre.mk>
+.ifdef USE_OPENSSL
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+.endif
+
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else