aboutsummaryrefslogtreecommitdiff
path: root/www/lynx-ssl
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-08-06 16:19:45 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-08-06 16:19:45 +0000
commit5baeababef0ce1d5fcfdae2c91b2c2dab3eac143 (patch)
tree2a921bb40ceae309e00ea243736756e314fa73ec /www/lynx-ssl
parentc442a88353fc16b3acda9dc7666e2cfd6613db35 (diff)
downloadports-5baeababef0ce1d5fcfdae2c91b2c2dab3eac143.tar.gz
ports-5baeababef0ce1d5fcfdae2c91b2c2dab3eac143.zip
Upgrade to 2.8.3.1, and unmark FORBIDDEN. (non-ssl lynx was unmarked
broken when crossing 2.8.3.pre5) PR: ports/20399 Submitted by: Stefan `Sec` Zehl <sec@ice.42.org> (MAINTAINER)
Notes
Notes: svn path=/head/; revision=31348
Diffstat (limited to 'www/lynx-ssl')
-rw-r--r--www/lynx-ssl/Makefile20
-rw-r--r--www/lynx-ssl/distinfo4
-rw-r--r--www/lynx-ssl/files/patch-aa22
-rw-r--r--www/lynx-ssl/pkg-plist86
4 files changed, 85 insertions, 47 deletions
diff --git a/www/lynx-ssl/Makefile b/www/lynx-ssl/Makefile
index 85e5c82c1e8f..81a3386a0d56 100644
--- a/www/lynx-ssl/Makefile
+++ b/www/lynx-ssl/Makefile
@@ -6,22 +6,17 @@
#
PORTNAME= lynx-ssl
-PORTVERSION= 2.8.2.1
+PORTVERSION= 2.8.3.1
CATEGORIES= www
-MASTER_SITES= http://sol.slcc.edu/lynx/current/
-DISTNAME= lynx2.8.2rel.1
+MASTER_SITES= ftp://lynx.isc.org/current/
+DISTNAME= lynx2.8.3rel.1
USE_OPENSSL= RSA
-FORBIDDEN= "Riddled with buffer overflows exploitable by a malicious server to execute code as the local user"
.include <bsd.port.pre.mk>
-.if defined(OPENSSL_RSAREF)
PATCH_SITES= http://www.moxienet.com/lynx/
-.else
-PATCH_SITES= ftp://ftp.musin.de/unix/
-.endif
-PATCHFILES= lynx-282-ssl.patch.gz
+PATCHFILES= lynx-283-ssl.patch.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sec@42.org
@@ -31,13 +26,14 @@ CFLAGS+= -I${OPENSSLINC}/openssl
CONFIGURE_ARGS= --with-screen=ncurses --with-zlib --libdir="${PREFIX}/etc" \
--enable-nsl-fork
MAKEFILE= makefile
-INSTALL_TARGET= install install-help
+INSTALL_TARGET= install-full
MAN1= lynx.1
-WRKSRC= ${WRKDIR}/lynx2-8-2
+WRKSRC= ${WRKDIR}/lynx2-8-3
post-install:
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/lynx_help
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/lynx_help
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/lynx
${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PREFIX}/etc/lynx.cfg
.include <bsd.port.post.mk>
diff --git a/www/lynx-ssl/distinfo b/www/lynx-ssl/distinfo
index 664b4434cfc7..0b0421ad7377 100644
--- a/www/lynx-ssl/distinfo
+++ b/www/lynx-ssl/distinfo
@@ -1,2 +1,2 @@
-MD5 (lynx2.8.2rel.1.tar.gz) = 178a71b91b59bc91ccafd1bb55d4406d
-MD5 (lynx-282-ssl.patch.gz) = 058e0ca7c74b357a8186bdf1f6fd8776
+MD5 (lynx2.8.3rel.1.tar.gz) = b0e35d5cd132a60bbed64edc79850717
+MD5 (lynx-283-ssl.patch.gz) = c48607b33f493284ba60c8a431a13b03
diff --git a/www/lynx-ssl/files/patch-aa b/www/lynx-ssl/files/patch-aa
index c7cfa0b60d08..36e2b17d93f7 100644
--- a/www/lynx-ssl/files/patch-aa
+++ b/www/lynx-ssl/files/patch-aa
@@ -1,15 +1,25 @@
---- makefile.in.orig Sat Jan 29 23:43:49 2000
-+++ makefile.in Sun Jan 30 00:04:17 2000
-@@ -54,7 +54,7 @@
+--- makefile.in.orig Thu Aug 3 18:35:17 2000
++++ makefile.in Fri Aug 4 03:45:59 2000
+@@ -48,15 +48,15 @@
+ MANDIR= $(DESTDIR)$(mandir)
+
+ ## Where you want the lynx.cfg file installed
+-libdir= @libdir@
++libdir= @libdir@
+ LIBDIR= $(DESTDIR)$(libdir)
+
+ ## Where you want the doc-files installed
+-docdir= @libdir@/lynx_doc
++docdir= @libdir@/../share/doc/lynx
DOCDIR= $(DESTDIR)$(docdir)
## Where you want the help-files installed
-helpdir= @libdir@/lynx_help
-+helpdir= $(prefix)/lib/lynx_help
++helpdir= @libdir@/../share/lynx_help
HELPDIR= $(DESTDIR)$(helpdir)
##set the relative location of the WWW library Implementation directory,
-@@ -83,8 +83,8 @@
+@@ -84,8 +84,8 @@
# about the SSL patch for Lynx, please see http://www.moxienet.com/lynx/.
# This page also contains links which enable you to test your copy of Lynx'
# ability to make SSL connections.
@@ -17,6 +27,6 @@
-SSL_LIBS= -L$(SSL_DIR)/lib -lssl -lcrypto
+SSL_DIR= $(OPENSSLBASE)
+SSL_LIBS= -L$(SSL_DIR)/lib -lssl -lcrypto ${EXTRA_SSL_LIBS}
- SSL_DEFINES= -I$(SSL_DIR)/include -DUSE_SSL
+ SSL_DEFINES= -DUSE_SSL -I$(SSL_DIR)/include/openssl -I$(SSL_DIR)/include
# !!!!!!!!!!! SUN resolv LIBRARY !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
diff --git a/www/lynx-ssl/pkg-plist b/www/lynx-ssl/pkg-plist
index 266c0ffebb4d..8d7469c41572 100644
--- a/www/lynx-ssl/pkg-plist
+++ b/www/lynx-ssl/pkg-plist
@@ -1,29 +1,61 @@
bin/lynx
etc/lynx.cfg
-lib/lynx_help/Lynx_users_guide.html
-lib/lynx_help/about_lynx.html
-lib/lynx_help/COPYHEADER
-lib/lynx_help/COPYING
-lib/lynx_help/keystrokes/alt_edit_help.html
-lib/lynx_help/keystrokes/bookmark_help.html
-lib/lynx_help/keystrokes/cookie_help.html
-lib/lynx_help/keystrokes/dired_help.html
-lib/lynx_help/keystrokes/edit_help.html
-lib/lynx_help/keystrokes/environments.html
-lib/lynx_help/keystrokes/follow_help.html
-lib/lynx_help/keystrokes/gopher_types_help.html
-lib/lynx_help/keystrokes/history_help.html
-lib/lynx_help/keystrokes/keystroke_help.html
-lib/lynx_help/keystrokes/movement_help.html
-lib/lynx_help/keystrokes/option_help.html
-lib/lynx_help/keystrokes/other_help.html
-lib/lynx_help/keystrokes/print_help.html
-lib/lynx_help/keystrokes/scrolling_help.html
-lib/lynx_help/keystrokes/test_display.html
-lib/lynx_help/keystrokes/visited_help.html
-lib/lynx_help/keystrokes/xterm_help.html
-lib/lynx_help/lynx-dev.html
-lib/lynx_help/lynx_help_main.html
-lib/lynx_help/lynx_url_support.html
-@dirrm lib/lynx_help/keystrokes
-@dirrm lib/lynx_help
+share/lynx_help/COPYHEADER
+share/lynx_help/COPYING
+share/lynx_help/Lynx_users_guide.html
+share/lynx_help/about_lynx.html
+share/lynx_help/keystrokes/alt_edit_help.html
+share/lynx_help/keystrokes/bashlike_edit_help.html
+share/lynx_help/keystrokes/bookmark_help.html
+share/lynx_help/keystrokes/cookie_help.html
+share/lynx_help/keystrokes/dired_help.html
+share/lynx_help/keystrokes/edit_help.html
+share/lynx_help/keystrokes/environments.html
+share/lynx_help/keystrokes/follow_help.html
+share/lynx_help/keystrokes/gopher_types_help.html
+share/lynx_help/keystrokes/history_help.html
+share/lynx_help/keystrokes/keystroke_help.html
+share/lynx_help/keystrokes/movement_help.html
+share/lynx_help/keystrokes/option_help.html
+share/lynx_help/keystrokes/other_help.html
+share/lynx_help/keystrokes/print_help.html
+share/lynx_help/keystrokes/scrolling_help.html
+share/lynx_help/keystrokes/test_display.html
+share/lynx_help/keystrokes/visited_help.html
+share/lynx_help/keystrokes/xterm_help.html
+share/lynx_help/lynx-dev.html
+share/lynx_help/lynx_help_main.html
+share/lynx_help/lynx_url_support.html
+share/doc/lynx/CHANGES
+share/doc/lynx/COPYHEADER
+share/doc/lynx/COPYING
+share/doc/lynx/PROBLEMS
+share/doc/lynx/README
+share/doc/lynx/samples/blue-background.lss
+share/doc/lynx/samples/cernrules.txt
+share/doc/lynx/samples/installdirs.html
+share/doc/lynx/samples/jumpsUnix.html
+share/doc/lynx/samples/jumpsVMS.html
+share/doc/lynx/samples/lynx-keymaps
+share/doc/lynx/samples/lynx.com
+share/doc/lynx/samples/lynx.lss
+share/doc/lynx/samples/mailcap
+share/doc/lynx/samples/mild-colors.lss
+share/doc/lynx/samples/mime.types
+share/doc/lynx/test/ALT88592.html
+share/doc/lynx/test/ISO_LATIN1_test.html
+share/doc/lynx/test/README.txt
+share/doc/lynx/test/TestComment.html
+share/doc/lynx/test/c1.html
+share/doc/lynx/test/iso8859-1.html
+share/doc/lynx/test/iso88592.html
+share/doc/lynx/test/raw8bit.html
+share/doc/lynx/test/sgml.html
+share/doc/lynx/test/spaces.html
+share/doc/lynx/test/tabtest.html
+share/doc/lynx/test/unicode.html
+@dirrm share/lynx_help/keystrokes
+@dirrm share/lynx_help
+@dirrm share/doc/lynx/samples
+@dirrm share/doc/lynx/test
+@dirrm share/doc/lynx