aboutsummaryrefslogtreecommitdiff
path: root/www/mahara
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:01:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:01:59 +0000
commit8a51784050c568375753e5dca2173d7f8f1b3eb6 (patch)
treea09a16b1600a6515e11db81862fcd0fe5c5afc97 /www/mahara
parent1049b2122eb03747cff97e5cd116cde947a1ffc7 (diff)
downloadports-8a51784050c568375753e5dca2173d7f8f1b3eb6.tar.gz
ports-8a51784050c568375753e5dca2173d7f8f1b3eb6.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=319846
Diffstat (limited to 'www/mahara')
-rw-r--r--www/mahara/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/www/mahara/Makefile b/www/mahara/Makefile
index 9aade7316848..d5f2f240fc6e 100644
--- a/www/mahara/Makefile
+++ b/www/mahara/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mahara
-# Date created: 21 Feb, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= mahara
PORTVERSION= 1.1.8
@@ -17,16 +13,16 @@ USE_BZIP2= yes
USE_PHP= session json curl xml xmlrpc openssl simplexml
FETCH_ARGS= -pRr
-OPTIONS= MYSQL "Add support for a MySQL database server" On \
- PGSQL "Add support for a PostgreSQL database server" Off
+OPTIONS_DEFINE= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
@@ -60,4 +56,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>