aboutsummaryrefslogtreecommitdiff
path: root/www/mathjax
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-07-18 15:47:48 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-07-18 15:47:48 +0000
commite3971c82ba13bf8620a11b754bf3fb9812041569 (patch)
tree010421981d05511f19a9b8c88171a9d8966202b1 /www/mathjax
parente4253f26ef7edbca0e19fa3f2e003485f999c555 (diff)
downloadports-e3971c82ba13bf8620a11b754bf3fb9812041569.tar.gz
ports-e3971c82ba13bf8620a11b754bf3fb9812041569.zip
MathJax is an open source JavaScript display engine for mathematics
that works in all modern browsers. WWW: http://www.mathjax.org Buildlog: http://goo.gl/Gnr3v PR: ports/153195 Submitted by: Lukasz Stelmach <lukasz.stelmach@iem.pw.edu.pl>
Notes
Notes: svn path=/head/; revision=301101
Diffstat (limited to 'www/mathjax')
-rw-r--r--www/mathjax/Makefile36
-rw-r--r--www/mathjax/distinfo2
-rw-r--r--www/mathjax/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/www/mathjax/Makefile b/www/mathjax/Makefile
new file mode 100644
index 000000000000..fb471a602930
--- /dev/null
+++ b/www/mathjax/Makefile
@@ -0,0 +1,36 @@
+# -*- mode: makefile-bsdmake -*-
+# New ports collection makefile for: www/mathjax
+# Date created: 7 December 2010
+# Whom: Lukasz Stelmach <lukasz.stelmach@iem.pw.edu.pl>
+#
+# $FreeBSD$
+
+PORTNAME= MathJax
+PORTVERSION= 2.0
+#PORTREVISION= 0
+CATEGORIES= www
+MASTER_SITES= https://nodeload.github.com/mathjax/MathJax/tarball/v${PORTVERSION}-latest?dummy=/
+
+MAINTAINER= lukasz.stelmach@iem.pw.edu.pl
+COMMENT= A cross-browser JavaScript display engine for mathematics
+
+FETCH_BEFORE_ARGS= -o ${DISTNAME}${EXTRACT_SUFX}
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/mathjax-MathJax-07669ac
+
+# Changing permissions of 30k files with find -exec (COPYTREE) is way
+# too slow.
+do-install:
+ ${MKDIR} ${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${FIND} -d . | ${CPIO} -dumpl ${WWWDIR} >/dev/null 2>&1)
+ ${FIND} -d ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ ${FIND} -d ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ ${CHOWN} -R ${BINOWN}:${BINGRP} ${WWWDIR}
+ @(cd ${PREFIX}; ${FIND} -s ${WWWDIR_REL} -not -type d) >> ${TMPPLIST}
+ @(cd ${PREFIX}; ${FIND} -s -d ${WWWDIR_REL} -type d) \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/mathjax/distinfo b/www/mathjax/distinfo
new file mode 100644
index 000000000000..172239a3d1f4
--- /dev/null
+++ b/www/mathjax/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MathJax-2.0.tar.gz) = 01ad97362b9bac25420cbffd9d733d9abd3a750ba82b68063d4b2608c43a70ae
+SIZE (MathJax-2.0.tar.gz) = 9457775
diff --git a/www/mathjax/pkg-descr b/www/mathjax/pkg-descr
new file mode 100644
index 000000000000..ff7665608314
--- /dev/null
+++ b/www/mathjax/pkg-descr
@@ -0,0 +1,4 @@
+MathJax is an open source JavaScript display engine for mathematics
+that works in all modern browsers.
+
+WWW: http://www.mathjax.org