aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-02-25 11:08:42 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-02-25 11:08:42 +0000
commita99be9477137b96380faced85bf4c4e9458309b0 (patch)
treeb0f958b1a8037c8f7c4d949f00906a668c3e45f9 /www/midori
parentf79e49566a3e8da781df381edd45b84d9b2cda16 (diff)
downloadports-a99be9477137b96380faced85bf4c4e9458309b0.tar.gz
ports-a99be9477137b96380faced85bf4c4e9458309b0.zip
Update to 3.2.
- Add new option, UNIQUE (enable single instance) "off" by default. - Fix a warning with rst2html PR: ports/154904 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Notes
Notes: svn path=/head/; revision=269682
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile19
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-wscript19
3 files changed, 31 insertions, 11 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index a78165994d0d..215e1ef30a50 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -7,16 +7,16 @@
#
PORTNAME= midori
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.2
CATEGORIES= www xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}/
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= kwm@FreeBSD.org
COMMENT= Lightweight web browser using WebKit browser engine
-LIB_DEPENDS= webkit-1.0:${PORTSDIR}/www/webkit-gtk2 \
+LIB_DEPENDS= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2 \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
notify.1:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= rsvg-convert:${PORTSDIR}/graphics/librsvg2 \
@@ -27,8 +27,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+=--disable-unique \
- --disable-libidn \
+CONFIGURE_ARGS+=--disable-libidn \
--enable-libnotify \
--enable-addons \
--jobs=${MAKE_JOBS_NUMBER}
@@ -49,7 +48,8 @@ PLIST_SUB= VERSION="${PORTVERSION:R}"
OPTIONS= NLS "Enable Native Language support" on \
USERDOCS "Build user documentation" off \
- APIDOCS "Build api documentation" off
+ APIDOCS "Build api documentation" off \
+ UNIQUE "Enable single instance support" off
.include <bsd.port.pre.mk>
@@ -81,6 +81,13 @@ CONFIGURE_ARGS+=--disable-apidocs
PLIST_SUB+= APIDOCS="@comment "
.endif
+.if defined(WITH_UNIQUE)
+LIB_DEPENDS+= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+CONFIGURE_ARGS+=--enable-unique
+.else
+CONFIGURE_ARGS+=--disable-unique
+.endif
+
post-install:
@-update-desktop-database
.if defined(WITH_APIDOCS)
diff --git a/www/midori/distinfo b/www/midori/distinfo
index eb8284779f14..8494241f31f1 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori-0.3.0.tar.bz2) = 56860b2eb2e5f223af0e64d103eef66c4b3574f4ed9a3cfd1ca20844563f0ae7
-SIZE (xfce4/midori-0.3.0.tar.bz2) = 819092
+SHA256 (xfce4/midori-0.3.2.tar.bz2) = 9316803fdd68842c43f06afe645ec4fa45206f142796f6131d2761ba3415e2bc
+SIZE (xfce4/midori-0.3.2.tar.bz2) = 826287
diff --git a/www/midori/files/patch-wscript b/www/midori/files/patch-wscript
index ccab30837188..232a99069ca4 100644
--- a/www/midori/files/patch-wscript
+++ b/www/midori/files/patch-wscript
@@ -1,6 +1,19 @@
---- wscript.orig 2010-05-26 12:34:09.000000000 +0200
-+++ wscript 2010-05-26 12:35:30.000000000 +0200
-@@ -267,8 +267,7 @@
+--- wscript.orig 2011-02-20 00:00:26.000000000 +0100
++++ wscript 2011-02-20 10:27:54.000000000 +0100
+@@ -99,10 +99,9 @@
+ conf.check_tool ('glib2')
+
+ if option_enabled ('userdocs'):
+- conf.find_program ('rst2html.py', var='RST2HTML')
+- # debian renames the executable, check that as well :(
++ conf.find_program ('rst2html', var='RST2HTML')
+ if not conf.env['RST2HTML']:
+- conf.find_program ('rst2html', var='RST2HTML')
++ conf.find_program ('rst2html.py', var='RST2HTML')
+ if conf.env['RST2HTML']:
+ user_docs = 'yes'
+ else:
+@@ -261,8 +260,7 @@
if not conf.env['HAVE_UNIQUE']:
if Options.platform == 'win32':
conf.check (lib='ws2_32')