aboutsummaryrefslogtreecommitdiff
path: root/www/mini_httpd
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2018-11-04 18:17:42 +0000
committerCraig Leres <leres@FreeBSD.org>2018-11-04 18:17:42 +0000
commit4eda384232cd09afee76f069d602bded8fa37598 (patch)
treef6f9ab99010ba4c8aee04f0f86394a4d2427d77c /www/mini_httpd
parent1f97ffe50bb6daeb14c8c42b0ddd6c7b33c37059 (diff)
downloadports-4eda384232cd09afee76f069d602bded8fa37598.tar.gz
ports-4eda384232cd09afee76f069d602bded8fa37598.zip
After consulting with upstream it turns out 500.mini_httpd-rotate
is supposed to be an example so add an EXAMPLES option and install (or not) appropriately. PR: 232926 Reported by: Oleg Strizhak Approved by: ler (mentor, implicit)
Notes
Notes: svn path=/head/; revision=484119
Diffstat (limited to 'www/mini_httpd')
-rw-r--r--www/mini_httpd/Makefile11
-rw-r--r--www/mini_httpd/pkg-plist4
2 files changed, 8 insertions, 7 deletions
diff --git a/www/mini_httpd/Makefile b/www/mini_httpd/Makefile
index 9327a3be4a0a..fe75b429fa1f 100644
--- a/www/mini_httpd/Makefile
+++ b/www/mini_httpd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mini_httpd
PORTVERSION= 1.30
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= https://www.acme.com/software/mini_httpd/
@@ -16,6 +16,8 @@ USES= cpe ssl
CPE_VENDOR= acme
+OPTIONS_DEFINE+= EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's/htpasswd/${PORTNAME}-htpasswd/' \
${WRKSRC}/htpasswd.1
@@ -23,13 +25,9 @@ post-patch:
${WRKSRC}/${PORTNAME}.8
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
- @${MKDIR} ${STAGEDIR}${PREFIX}/www/chroot/logs
${INSTALL_PROGRAM} ${WRKSRC}/mini_httpd ${STAGEDIR}${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/htpasswd \
${STAGEDIR}${PREFIX}/sbin/${PORTNAME}-htpasswd
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/500.mini_httpd-rotate \
- ${STAGEDIR}${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd_wrapper \
${STAGEDIR}${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd.sh \
@@ -40,5 +38,8 @@ do-install:
${STAGEDIR}${MANPREFIX}/man/man8
${INSTALL_DATA} ${WRKSRC}/mini_httpd.cnf \
${STAGEDIR}${PREFIX}/etc/mini_httpd.cnf.sample
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/500.mini_httpd-rotate \
+ ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/www/mini_httpd/pkg-plist b/www/mini_httpd/pkg-plist
index 969e8343b406..83b2248e2a79 100644
--- a/www/mini_httpd/pkg-plist
+++ b/www/mini_httpd/pkg-plist
@@ -1,9 +1,9 @@
@sample etc/mini_httpd.cnf.sample
-etc/periodic/daily/500.mini_httpd-rotate
etc/rc.d/mini_httpd
man/man1/mini_httpd-htpasswd.1.gz
man/man8/mini_httpd.8.gz
sbin/mini_httpd
sbin/mini_httpd-htpasswd
sbin/mini_httpd_wrapper
-@dir www/chroot/logs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/500.mini_httpd-rotate
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%