aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_kerb2
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-03-09 16:59:33 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-03-09 16:59:33 +0000
commit7d5e9e156ef6637a5ba35c87b031a4e1825bf23a (patch)
tree54d7273be9e9ca9389470de1f6611e204081a89a /www/mod_auth_kerb2
parent837771195f936bd35555bcd922868d99599fbc32 (diff)
downloadports-7d5e9e156ef6637a5ba35c87b031a4e1825bf23a.tar.gz
ports-7d5e9e156ef6637a5ba35c87b031a4e1825bf23a.zip
- add stage support
Notes
Notes: svn path=/head/; revision=347665
Diffstat (limited to 'www/mod_auth_kerb2')
-rw-r--r--www/mod_auth_kerb2/Makefile10
-rw-r--r--www/mod_auth_kerb2/files/patch-Makefile.in11
2 files changed, 14 insertions, 7 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index 747c5d05b79c..6ab9a8af8141 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -12,9 +12,8 @@ PKGNAMESUFFIX= 2
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for authenticating users with Kerberos v5
-NO_STAGE= yes
USE_APACHE= 22
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
PORTSCOUT= limit:^5.4
@@ -37,4 +36,11 @@ LIB_DEPENDS+= libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
+ ${WRKSRC}/Makefile.in
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
+
.include <bsd.port.mk>
diff --git a/www/mod_auth_kerb2/files/patch-Makefile.in b/www/mod_auth_kerb2/files/patch-Makefile.in
index f92ad41a3bc9..3aa4cb620e0b 100644
--- a/www/mod_auth_kerb2/files/patch-Makefile.in
+++ b/www/mod_auth_kerb2/files/patch-Makefile.in
@@ -1,19 +1,20 @@
---- ./Makefile.in.orig 2008-12-02 09:07:10.000000000 -0500
-+++ ./Makefile.in 2012-11-28 09:50:58.000000000 -0500
-@@ -1,6 +1,6 @@
+--- ./Makefile.in.orig 2008-12-02 15:07:10.000000000 +0100
++++ ./Makefile.in 2014-03-09 17:54:19.000000000 +0100
+@@ -1,6 +1,7 @@
APXS = @APXS@
++APXS_STAGE= @APXS_STAGE@
KRB5_CPPFLAGS = @KRB5_CPPFLAGS@
-KRB5_LDFLAGS = @KRB5_LDFLAGS@
+KRB5_LDFLAGS = @KRB5_LDFLAGS@ -lgssapi_krb5
KRB4_CPPFLAGS = @KRB4_CPPFLAGS@
KRB4_LDFLAGS = @KRB4_LDFLAGS@
LIB_resolv = @LIB_resolv@
-@@ -16,7 +16,7 @@
+@@ -16,7 +17,7 @@
./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c" "src/mod_auth_kerb.c"
install:
- ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c -i" "src/mod_auth_kerb.c"
-+ ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c -i -a" "src/mod_auth_kerb.c"
++ ${APXS} $(APXS_STAGE) -i -n auth_kerb src/mod_auth_kerb.la
clean:
for i in . src spnegokrb5; do \