aboutsummaryrefslogtreecommitdiff
path: root/www/mod_authn_otp
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-08-25 21:00:37 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-08-25 21:00:37 +0000
commitd3fdbf37361a478792f3a83fb5d754bbcd581586 (patch)
tree2fd81ec9c3afa554fc69e6ca9aacfc643e359f27 /www/mod_authn_otp
parent1f8c9e1df642f54fac93213c660757244c9c8616 (diff)
downloadports-d3fdbf37361a478792f3a83fb5d754bbcd581586.tar.gz
ports-d3fdbf37361a478792f3a83fb5d754bbcd581586.zip
mod_authn_otp - Apache module for one-time password authentication
mod_authn_otp is an Apache web server module for two-factor authentication using one-time passwords (OTP) generated via the HOTP/OATH algorithm defined in RFC 4226. This creates a simple way to protect a web site with one-time passwords, using any RFC 4226-compliant hardware or software token device. mod_authn_otp also supports the Mobile-OTP algorithm. mod_authn_otp supports both event and time based one-time passwords. It also supports "lingering" which allows the repeated re-use of a previously used one-time password up to a configurable maximum linger time. This allows one-time passwords to be used directly in HTTP authentication without forcing the user to enter a new one-time password for every page load. mod_authn_otp supports both basic and digest authentication, and will auto-synchronize with the user's token within a configurable maximum offset (auto-synchronization is not supported with digest authentication). WWW: http://mod-authn-otp.googlecode.com/ PR: ports/170826 Submitted by: Alexander Hausner <alex@hugo.bmg.gv.at>
Notes
Notes: svn path=/head/; revision=303156
Diffstat (limited to 'www/mod_authn_otp')
-rw-r--r--www/mod_authn_otp/Makefile31
-rw-r--r--www/mod_authn_otp/distinfo2
-rw-r--r--www/mod_authn_otp/pkg-descr20
3 files changed, 53 insertions, 0 deletions
diff --git a/www/mod_authn_otp/Makefile b/www/mod_authn_otp/Makefile
new file mode 100644
index 000000000000..9cc8c51583f3
--- /dev/null
+++ b/www/mod_authn_otp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ifdepd
+# Date created: 03 05 2012
+# Whom: Alexander Hausner <alex@hugo.bmg.gv.at>
+# $FreeBSD$
+
+PORTNAME= mod_authn_otp
+PORTVERSION= 1.1.4
+CATEGORIES= www
+MASTER_SITES= http://mod-authn-otp.googlecode.com/files/ \
+ http://alex.bmg.gv.at/programs/
+DIST_SUBDIR= apache2
+
+MAINTAINER= alex@hugo.bmg.gv.at
+COMMENT= Apache module for one-time password authentication
+
+MAKE_JOBS_SAFE= yes
+
+HAS_CONFIGURE= yes
+USE_APACHE= 22+
+
+PORTEXAMPLES= users.sample
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/users.sample ${EXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_authn_otp/distinfo b/www/mod_authn_otp/distinfo
new file mode 100644
index 000000000000..fb98ee82c38f
--- /dev/null
+++ b/www/mod_authn_otp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (apache2/mod_authn_otp-1.1.4.tar.gz) = f1dad6741ec2904637c251bee88f50156df611a9ebdbcf0abf64471c4a3987c0
+SIZE (apache2/mod_authn_otp-1.1.4.tar.gz) = 94911
diff --git a/www/mod_authn_otp/pkg-descr b/www/mod_authn_otp/pkg-descr
new file mode 100644
index 000000000000..cd3eee2aba11
--- /dev/null
+++ b/www/mod_authn_otp/pkg-descr
@@ -0,0 +1,20 @@
+mod_authn_otp - Apache module for one-time password authentication
+
+mod_authn_otp is an Apache web server module for two-factor authentication
+using one-time passwords (OTP) generated via the HOTP/OATH algorithm
+defined in RFC 4226. This creates a simple way to protect a web site with
+one-time passwords, using any RFC 4226-compliant hardware or software
+token device. mod_authn_otp also supports the Mobile-OTP algorithm.
+
+mod_authn_otp supports both event and time based one-time passwords. It
+also supports "lingering" which allows the repeated re-use of a previously
+used one-time password up to a configurable maximum linger time. This
+allows one-time passwords to be used directly in HTTP authentication
+without forcing the user to enter a new one-time password for every
+page load.
+
+mod_authn_otp supports both basic and digest authentication, and will
+auto-synchronize with the user's token within a configurable maximum
+offset (auto-synchronization is not supported with digest authentication).
+
+WWW: http://mod-authn-otp.googlecode.com/