aboutsummaryrefslogtreecommitdiff
path: root/www/mod_bf
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 23:18:57 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 23:18:57 +0000
commitc1b785c62b8a05524c9856e99b562447a33e5a2e (patch)
tree92bb3dde505153c9981486932b1c8cbbc32924c6 /www/mod_bf
parentca0808a56ec910f0dfbdc45466977ac518234367 (diff)
downloadports-c1b785c62b8a05524c9856e99b562447a33e5a2e.tar.gz
ports-c1b785c62b8a05524c9856e99b562447a33e5a2e.zip
Add mod_bf 0.1, a brainf*ck module for Apache.
Port #5,000 dedicated to: Bill Fumerola <billf>
Notes
Notes: svn path=/head/; revision=41254
Diffstat (limited to 'www/mod_bf')
-rw-r--r--www/mod_bf/Makefile27
-rw-r--r--www/mod_bf/distinfo1
-rw-r--r--www/mod_bf/pkg-comment1
-rw-r--r--www/mod_bf/pkg-descr3
-rw-r--r--www/mod_bf/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/www/mod_bf/Makefile b/www/mod_bf/Makefile
new file mode 100644
index 000000000000..f4b65e5f4f6c
--- /dev/null
+++ b/www/mod_bf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mod_bf
+# Date created: 10 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_bf
+PORTVERSION= 0.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= modbf
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_bf/distinfo b/www/mod_bf/distinfo
new file mode 100644
index 000000000000..3c61976ddceb
--- /dev/null
+++ b/www/mod_bf/distinfo
@@ -0,0 +1 @@
+MD5 (mod_bf-0.1.tar.gz) = 17894f5e68eeda47e8ebe7eeedc08851
diff --git a/www/mod_bf/pkg-comment b/www/mod_bf/pkg-comment
new file mode 100644
index 000000000000..c37afdbec35e
--- /dev/null
+++ b/www/mod_bf/pkg-comment
@@ -0,0 +1 @@
+A brainf*ck module for Apache
diff --git a/www/mod_bf/pkg-descr b/www/mod_bf/pkg-descr
new file mode 100644
index 000000000000..308c163ee403
--- /dev/null
+++ b/www/mod_bf/pkg-descr
@@ -0,0 +1,3 @@
+A brainf*ck module for the Apache Webserver.
+
+WWW: http://sourceforge.net/projects/modbf/
diff --git a/www/mod_bf/pkg-plist b/www/mod_bf/pkg-plist
new file mode 100644
index 000000000000..22a4bd8c4545
--- /dev/null
+++ b/www/mod_bf/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_bf.so
+@exec %D/sbin/apxs -e -A -n bf %D/%F
+@unexec %D/sbin/apxs -e -A -n bf %D/%F