aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dnssd
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-01-26 19:59:29 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-01-26 19:59:29 +0000
commit651c415d780aee3caab59a4d74bfb2c1ff3d883e (patch)
tree84d642122c95b1df9fdee139d63022470ef62808 /www/mod_dnssd
parent3ef524e5f8c1f9fd820b650159c7959350e642eb (diff)
downloadports-651c415d780aee3caab59a4d74bfb2c1ff3d883e.tar.gz
ports-651c415d780aee3caab59a4d74bfb2c1ff3d883e.zip
www/mod_dnssd: fix build with apache22
Requested by: Wolfgang Riegler <wolfgang.riegler@gmx.de> Submitted by: olli hauer <ohauer@gmx.de>
Notes
Notes: svn path=/head/; revision=407303
Diffstat (limited to 'www/mod_dnssd')
-rw-r--r--www/mod_dnssd/files/patch-src__Makefile.in4
-rw-r--r--www/mod_dnssd/files/patch-src__mod_dnssd.c11
2 files changed, 10 insertions, 5 deletions
diff --git a/www/mod_dnssd/files/patch-src__Makefile.in b/www/mod_dnssd/files/patch-src__Makefile.in
index e73d544e4def..4f42073af943 100644
--- a/www/mod_dnssd/files/patch-src__Makefile.in
+++ b/www/mod_dnssd/files/patch-src__Makefile.in
@@ -1,4 +1,4 @@
---- src/Makefile.in.orig
+--- src/Makefile.in.orig 2009-01-22 16:42:02 UTC
+++ src/Makefile.in
@@ -15,9 +15,10 @@
# permissions and limitations under the License.
@@ -13,7 +13,7 @@
all: mod_dnssd.la
-@@ -25,7 +26,7 @@
+@@ -25,7 +26,7 @@ mod_dnssd.la: @srcdir@/mod_dnssd.c
$(APXS) -c $(CFLAGS) $(LIBS) @srcdir@/mod_dnssd.c
install: all
diff --git a/www/mod_dnssd/files/patch-src__mod_dnssd.c b/www/mod_dnssd/files/patch-src__mod_dnssd.c
index 791d4a5082f4..c6b748f2967c 100644
--- a/www/mod_dnssd/files/patch-src__mod_dnssd.c
+++ b/www/mod_dnssd/files/patch-src__mod_dnssd.c
@@ -1,9 +1,14 @@
---- src/mod_dnssd.c.orig
+--- src/mod_dnssd.c.orig 2009-01-28 02:24:00 UTC
+++ src/mod_dnssd.c
-@@ -27,6 +27,11 @@
+@@ -24,9 +24,16 @@
+ #include <ap_config.h>
+ #include <apr_strings.h>
+ #include <unixd.h>
++#if MODULE_MAGIC_COOKIE >= 0x41503234UL /* "AP24" */
++#include <mod_unixd.h>
++#endif
#include <apr_signal.h>
#include <mpm_common.h>
-+#include <mod_unixd.h>
+#if MODULE_MAGIC_NUMBER_MAJOR >= 20090130
+#define unixd_setup_child ap_unixd_setup_child