aboutsummaryrefslogtreecommitdiff
path: root/www/mod_line_edit/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-07 05:28:48 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-07 05:28:48 +0000
commitec152850d3c4dded7e81b1cf72d922418b665738 (patch)
treea4278bf9be249da80429165ce94043169e6dbee3 /www/mod_line_edit/Makefile
parentefdb9d60be6a5da95835a8b97b49a0eef6e5c840 (diff)
downloadports-ec152850d3c4dded7e81b1cf72d922418b665738.tar.gz
ports-ec152850d3c4dded7e81b1cf72d922418b665738.zip
- Convert to AP_FAST_BUILD / AP_GENPLIST
- Pet Portlint
Notes
Notes: svn path=/head/; revision=255994
Diffstat (limited to 'www/mod_line_edit/Makefile')
-rw-r--r--www/mod_line_edit/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/www/mod_line_edit/Makefile b/www/mod_line_edit/Makefile
index acdfc546157d..29833a714841 100644
--- a/www/mod_line_edit/Makefile
+++ b/www/mod_line_edit/Makefile
@@ -12,28 +12,28 @@ PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://apache.webthing.com/mod_line_edit/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
-DISTFILES= mod_line_edit.c
+DISTNAME= ${PORTNAME}.c
+EXTRACT_SUFX=
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for simple text rewriting
MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}
+
USE_APACHE= 2.2+
-do-extract:
- @${DO_NADA}
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
pre-fetch:
- @${MKDIR} ${WRKDIR}
-
-post-fetch:
- @${CP} ${DISTDIR}/mod_line_edit.c ${WRKDIR}
+ @${MKDIR} ${WRKDIR}/
-do-build:
- @(cd ${WRKDIR} && ${APXS} -c mod_line_edit.c)
+do-extract:
+ @${DO_NADA}
-do-install:
- @(cd ${WRKDIR} && ${APXS} -A -i mod_line_edit.la)
+post-fetch:
+ @${CP} ${DISTDIR}/${PORTNAME}.c ${WRKDIR}/
.include <bsd.port.mk>