aboutsummaryrefslogtreecommitdiff
path: root/www/mod_macro22/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-01 19:51:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-01 19:51:51 +0000
commitf220d69d57a7edee501279fefa2e0300a09c7ddb (patch)
tree6a3d9b5a24809e7e65c4f1c8a0060dd10f61419b /www/mod_macro22/Makefile
parent87d9de78eb97c17ca22c5f9fb4373b7e7692b6bb (diff)
downloadports-f220d69d57a7edee501279fefa2e0300a09c7ddb.tar.gz
ports-f220d69d57a7edee501279fefa2e0300a09c7ddb.zip
mod_macro is a third-party module to the Apache Http Server, distributed with
a BSD-style license like Apache. It allows the definition and use of macros within apache runtime configuration files. The syntax is a natural extension to apache html-like configuration style. WWW: http://www.cri.ensmp.fr/~coelho/mod_macro/ PR: ports/124173 Submitted by: Lukasz Wasikowski <lukasz at wasikowski.net>
Notes
Notes: svn path=/head/; revision=214140
Diffstat (limited to 'www/mod_macro22/Makefile')
-rw-r--r--www/mod_macro22/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/mod_macro22/Makefile b/www/mod_macro22/Makefile
new file mode 100644
index 000000000000..8b3371af4942
--- /dev/null
+++ b/www/mod_macro22/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: mod_macro22
+# Date created: 31 May 2008
+# Whom: Lukasz Wasikowski <lukasz@wasikowski.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_macro
+PORTVERSION= 1.1.10
+CATEGORIES= www
+MASTER_SITES= http://www.cri.ensmp.fr/~coelho/mod_macro/
+
+MAINTAINER= lukasz@wasikowski.net
+COMMENT= Apache 2.2.x module for use macros in config files
+
+USE_APACHE= 22
+LATEST_LINK= mod_macro22
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+PORTDOCS= ${PORTNAME}.html
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>