aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-04-28 11:47:33 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-04-28 11:47:33 +0000
commit4ab3d201041e1b3973013f734c6f37c1b0fcaa8a (patch)
tree3ad2ea0a8ce2b227ae25a1168300bd7fcb5f124a /www/mod_musicindex
parent51eb98feb232a5367d402e385a5bb6fad5935605 (diff)
downloadports-4ab3d201041e1b3973013f734c6f37c1b0fcaa8a.tar.gz
ports-4ab3d201041e1b3973013f734c6f37c1b0fcaa8a.zip
- update to 1.4.1
- add stage support - use new OPTIONS syntax - update WWW
Notes
Notes: svn path=/head/; revision=352488
Diffstat (limited to 'www/mod_musicindex')
-rw-r--r--www/mod_musicindex/Makefile106
-rw-r--r--www/mod_musicindex/distinfo4
-rw-r--r--www/mod_musicindex/files/patch-src__Makefile.in13
-rw-r--r--www/mod_musicindex/pkg-descr2
-rw-r--r--www/mod_musicindex/pkg-plist15
5 files changed, 40 insertions, 100 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 901f7d1dad17..334b79d32d02 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= mod_musicindex
-PORTVERSION= 1.3.7
+PORTVERSION= 1.4.1
CATEGORIES= www audio
-MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/
+MASTER_SITES= http://hacks.slashdirt.org/musicindex/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
@@ -21,98 +21,50 @@ LIBARCHIVE_DESC= Archive downloading support
FILECACHE_DESC= Flat file caching support
MYSQLCACHE_DESC= MySQL caching support
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
+FILECACHE_CONFIGURE_ENABLE= filecache
+FLAC_CONFIGURE_ENABLE= flac
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
+LIBARCHIVE_CONFIGURE_ENABLE= archive
+MP3_CONFIGURE_ENABLE= mp3
+MP3_LIB_DEPENDS= libid3tag.so:${PORTSDIR}/audio/libid3tag \
+ libmad.so:${PORTSDIR}/audio/libmad
+MP4_CONFIGURE_ENABLE= mp4
+MP4_LIB_DEPENDS= libmp4v2.so:${PORTSDIR}/multimedia/mp4v2
+MYSQLCACHE_CONFIGURE_ENABLE= mysqlcache
+MYSQLCACHE_USE= MYSQL=yes
+NLS_CFLAGS= -lintl
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+VORBIS_CONFIGURE_ENABLE= vorbis
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+.include <bsd.port.options.mk>
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-apxs=${APXS} \
- --disable-libFLACtest --disable-vorbistest
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-apxs=${APXS} \
+ --disable-libFLACtest --disable-vorbistest
SUB_FILES= pkg-message
SUB_LIST= PORTNAME=${PORTNAME}
PORTDOCS= README
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CFLAGS+= -lintl
-PLIST_SUB+= NLS=""
-CONFIGURE_ARGS+=--enable-nls
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-CONFIGURE_ARGS+= --enable-flac
-.else
-CONFIGURE_ARGS+= --disable-flac
-.endif
-
-.if ${PORT_OPTIONS:MMP3}
-LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag \
- mad:${PORTSDIR}/audio/libmad
-CONFIGURE_ARGS+= --enable-mp3
-.else
-CONFIGURE_ARGS+= --disable-mp3
-.endif
-
-.if ${PORT_OPTIONS:MMP4}
-LIB_DEPENDS+= mp4v2:${PORTSDIR}/multimedia/mp4v2
-CONFIGURE_ARGS+= --enable-mp4
-.else
-CONFIGURE_ARGS+= --disable-mp4
-.endif
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+= --enable-vorbis
-.else
-CONFIGURE_ARGS+= --disable-vorbis
-.endif
-
-.if ${PORT_OPTIONS:MLIBARCHIVE}
-CONFIGURE_ARGS+= --enable-archive
-.else
-CONFIGURE_ARGS+= --disable-archive
-.endif
-
-.if ${PORT_OPTIONS:MFILECACHE}
-CONFIGURE_ARGS+= --enable-filecache
-.else
-CONFIGURE_ARGS+= --disable-filecache
-.endif
-
-.if ${PORT_OPTIONS:MMYSQLCACHE}
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --enable-mysqlcache
-.else
-CONFIGURE_ARGS+= --disable-mysqlcache
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e '/@BUILD_FOR_APACHE2/ s| -i -n musicindex| -a &|' \
- ${WRKSRC}/src/Makefile.in
.if ${PORT_OPTIONS:MNLS}
${RM} ${WRKSRC}/po/*.gmo
.endif
post-build:
.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC}/po && ${SETENV} ${MAKE_ENV} ${MAKE} update-gmo
+ @(${SETENV} ${MAKE_ENV} ${MAKE} -C ${WRKSRC}/po update-gmo)
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
-.endif
- @${ECHO_MSG} ""
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG} ""
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
.include <bsd.port.mk>
diff --git a/www/mod_musicindex/distinfo b/www/mod_musicindex/distinfo
index e22365f33891..39b5b7f10fc8 100644
--- a/www/mod_musicindex/distinfo
+++ b/www/mod_musicindex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mod_musicindex-1.3.7.tar.gz) = 7d5120d6d9ae96e84fe6acae3e80d517269a74bf86e3e6920e82c4169be00891
-SIZE (mod_musicindex-1.3.7.tar.gz) = 505798
+SHA256 (mod_musicindex-1.4.1.tar.gz) = 0fb052ebb8fa511467fd21696d798dee35b2e611955572cf746e9712e531a596
+SIZE (mod_musicindex-1.4.1.tar.gz) = 508795
diff --git a/www/mod_musicindex/files/patch-src__Makefile.in b/www/mod_musicindex/files/patch-src__Makefile.in
deleted file mode 100644
index 934dd58034ea..000000000000
--- a/www/mod_musicindex/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/Makefile.in.orig 2010-09-16 03:35:25.552884648 +0000
-+++ ./src/Makefile.in 2010-09-16 03:35:03.705416865 +0000
-@@ -727,8 +727,8 @@
-
- install: $(lib_LTLIBRARIES)
- $(mkinstalldirs) "$(DESTDIR)$(libdir)"
--@BUILD_FOR_APACHE2_TRUE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(libdir)" -i -n musicindex mod_musicindex.la
--@BUILD_FOR_APACHE2_FALSE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(libdir)" -i -n musicindex .libs/mod_musicindex.so
-+@BUILD_FOR_APACHE2_TRUE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(libdir)" -i -a -n musicindex mod_musicindex.la
-+@BUILD_FOR_APACHE2_FALSE@ $(APXS) -S LIBEXECDIR="$(DESTDIR)$(libdir)" -i -a -n musicindex .libs/mod_musicindex.so
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/www/mod_musicindex/pkg-descr b/www/mod_musicindex/pkg-descr
index 4e7040b8308d..7dfccf7cfc6b 100644
--- a/www/mod_musicindex/pkg-descr
+++ b/www/mod_musicindex/pkg-descr
@@ -3,4 +3,4 @@ the Perl module Apache::MP3. It allows nice displaying of directories
containing several kinds of audio files, including sorting them on various
fields, streaming/downloading them, constructing playlists, and searching.
-WWW: http://www.parisc-linux.org/~varenet/musicindex/
+WWW: http://hacks.slashdirt.org/musicindex/
diff --git a/www/mod_musicindex/pkg-plist b/www/mod_musicindex/pkg-plist
index 473af3337d19..144417049aaf 100644
--- a/www/mod_musicindex/pkg-plist
+++ b/www/mod_musicindex/pkg-plist
@@ -1,6 +1,12 @@
+@unexec /usr/bin/sed -i '' -E '/LoadModule[[:blank:]]+%%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
%%APACHEMODDIR%%/%%AP_MODULE%%
-@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
-@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@exec %D/sbin/apxs -e %%AP_MOD_EN%% -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_musicindex-related directives in your httpd.conf"
+%%NLS%%share/locale/de/LC_MESSAGES/mod_musicindex.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/mod_musicindex.mo
+%%NLS%%share/locale/it/LC_MESSAGES/mod_musicindex.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/mod_musicindex.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/mod_musicindex.mo
%%DATADIR%%/directory.png
%%DATADIR%%/fetch.png
%%DATADIR%%/fetchok.png
@@ -11,9 +17,4 @@
%%DATADIR%%/shuffle.png
%%DATADIR%%/sound.png
%%DATADIR%%/soundok.png
-%%NLS%%share/locale/de/LC_MESSAGES/mod_musicindex.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/mod_musicindex.mo
-%%NLS%%share/locale/it/LC_MESSAGES/mod_musicindex.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/mod_musicindex.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/mod_musicindex.mo
@dirrm %%DATADIR%%