aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-12 12:50:26 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-12 12:50:26 +0000
commitd122b73de24a4e8919b200626e7f1b4bb34fbc0c (patch)
treeb3e7e6c79e008f074e4799aad369499424aad704 /www/mod_musicindex
parent43b63893be8b4e9299ce9bf95aaef959a4f586e2 (diff)
downloadports-d122b73de24a4e8919b200626e7f1b4bb34fbc0c.tar.gz
ports-d122b73de24a4e8919b200626e7f1b4bb34fbc0c.zip
- Update to 1.2.0
PR: ports/115280 Submitted by: Tobias Roth <ports at fsck.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=197521
Diffstat (limited to 'www/mod_musicindex')
-rw-r--r--www/mod_musicindex/Makefile78
-rw-r--r--www/mod_musicindex/distinfo6
-rw-r--r--www/mod_musicindex/files/patch-Makefile50
-rw-r--r--www/mod_musicindex/files/pkg-message.in41
-rw-r--r--www/mod_musicindex/pkg-descr2
-rw-r--r--www/mod_musicindex/pkg-plist22
6 files changed, 73 insertions, 126 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index c790089bc67a..ad0747f88d9d 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -6,40 +6,72 @@
#
PORTNAME= mod_musicindex
-PORTVERSION= 0.99.7
-PORTREVISION= 4
+PORTVERSION= 1.2.0
CATEGORIES= www audio
-# Master site doesn't have a current version'd tarball...
-#MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/
-MASTER_SITES= http://depot.fsck.ch/mirror/distfiles/
-DISTNAME= libapache-mod-musicindex_${PORTVERSION}
+MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/ \
+ http://depot.fsck.ch/mirror/distfiles/
MAINTAINER= ports@fsck.ch
-COMMENT= Apache module in C that implements the perl module Apache::MP3
+COMMENT= Apache module that allows downloading and streaming of audio
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- id3tag.0:${PORTSDIR}/audio/libid3tag \
- mad.2:${PORTSDIR}/audio/libmad \
- FLAC.7:${PORTSDIR}/audio/flac
+OPTIONS= NLS "Native language support" on \
+ FLAC "FLAC support" off \
+ MP3 "MP3 support" on \
+ MP4 "MP4 support" off \
+ VORBIS "Ogg/Vorbis support" off \
+ LIBARCHIVE "Archive downloading support" on \
+ FILECACHE "Caching support" on
-CPPFLAGS= -DHAS_MP3 -DHAS_OGG -DHAS_FLAC
-CFLAGS+= -I${LOCALBASE}/include
-
-#WANT_APACHE= YES
-USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/libapache-mod-musicindex-${PORTVERSION}
+USE_APACHE= 1.3+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+PORTDOCS= README
SUB_FILES= pkg-message
+SUB_LIST= PORTNAME=${PORTNAME}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/apache20/Makefile.modules.3rd"
-MAKE_ENV+= APXS=${APXS} CPPFLAGS="${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+CFLAGS+= -lintl
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITHOUT_FLAC)
+CONFIGURE_ARGS+= --disable-flac
+.else
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+.endif
+
+.if defined(WITHOUT_MP3)
+CONFIGURE_ARGS+=--disable-mp3
+.else
+LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag \
+ mad:${PORTSDIR}/audio/libmad
+.endif
-.if "${AP_VER}"=="2"
-MAKE_ENV+= APACHE_VERSION=2 APRCONFIG=${LOCALBASE}/lib/apache2/apr-config
-.if "ARCH" = "amd64"
-CFLAGS+= -fPIC
+.if defined(WITHOUT_MP4)
+CONFIGURE_ARGS+= --disable-mp4
+.else
+LIB_DEPENDS+= mp4v2:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
.endif
+
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --disable-vorbis
+.else
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+.endif
+
+.if defined(WITHOUT_LIBARCHIVE)
+CONFIGURE_ARGS+= --disable-archive
+.endif
+
+.if defined(WITHOUT_FILECACHE)
+CONFIGURE_ARGS+= --disable-filecache
.endif
post-install:
diff --git a/www/mod_musicindex/distinfo b/www/mod_musicindex/distinfo
index f1d694b67a46..3c9c87f62d6a 100644
--- a/www/mod_musicindex/distinfo
+++ b/www/mod_musicindex/distinfo
@@ -1,3 +1,3 @@
-MD5 (libapache-mod-musicindex_0.99.7.tar.gz) = 98a146ee25786152ad756c41ff580e94
-SHA256 (libapache-mod-musicindex_0.99.7.tar.gz) = 64e23ec204da2125521b177ee412b784ffa8f7c73609da3bbe77ca83da85d041
-SIZE (libapache-mod-musicindex_0.99.7.tar.gz) = 81771
+MD5 (mod_musicindex-1.2.0.tar.gz) = a490703e50be29e271c5a28a4414fce5
+SHA256 (mod_musicindex-1.2.0.tar.gz) = 1b49abffe74a9a39bef57f0767cc2fad9b4e339565dd1ebc0de59f5bd68a531b
+SIZE (mod_musicindex-1.2.0.tar.gz) = 468706
diff --git a/www/mod_musicindex/files/patch-Makefile b/www/mod_musicindex/files/patch-Makefile
deleted file mode 100644
index 8b493b01a650..000000000000
--- a/www/mod_musicindex/files/patch-Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile.orig Wed Sep 15 18:34:27 2004
-+++ Makefile Sat Jan 22 14:58:01 2005
-@@ -8,21 +8,16 @@
- ## @todo autoconf/automake (i18n/apache2)
-
- # the tools
--CC = gcc
--INSTALL = install
-+CC ?= gcc
-+INSTALL ?= install
-
- ifeq ($(APACHE_VERSION),2)
--APXS = apxs2
--APACHECTL = apache2ctl
--APRCONFIG = apr-config
- APINCDIR = $(shell $(APRCONFIG) --includes)
- APCFLAGS = $(shell $(APRCONFIG) --cflags | sed -e "s/-g //" -e "s/-O.//" -e "s/-W[a-z]*//")
- APCPPFLAGS = $(shell $(APRCONFIG) --cppflags)
- #APLIBXDIR = $(shell $(APRCONFIG) --installbuilddir)
- APLIBXDIR = $(shell $(APXS) -q LIBEXECDIR)
- else
--APXS = apxs
--APACHECTL = apachectl
- APCFLAGS = $(shell $(APXS) -q CFLAGS_SHLIB | sed -e "s/-g //" -e "s/-O.//" -e "s/-W[a-z]*//")
- APLIBXDIR = $(shell $(APXS) -q LIBEXECDIR)
- endif
-@@ -31,11 +26,11 @@
- # debian doesn't have some libs (faad2 for instance...)
- DEBCPPFLAGS = -DHAS_MP3 -DHAS_OGG -DHAS_FLAC
- # in all cases:
--CPPFLAGS = -DHAS_MP3 -DHAS_OGG -DHAS_FLAC -DHAS_MP4
-+#CPPFLAGS = -DHAS_MP3 -DHAS_OGG -DHAS_FLAC -DHAS_MP4
- #INC =
- #LDFLAGS =
--CFLAGS = -O2 -Wall
--DOCROOT = /var/www
-+CFLAGS += -Wall
-+DOCROOT = ${LOCALBASE}/www
-
- # our own defines
- UNAME := $(shell uname)
-@@ -90,8 +85,6 @@
- $(INSTALL) -d $(DESTDIR)$(DOCROOT)/musicindex $(DESTDIR)$(LIBEXECDIR)
- $(INSTALL) -m 0644 musicindex/*.* $(DESTDIR)$(DOCROOT)/musicindex
- $(INSTALL) -m 0644 $(MOD_SO) $(DESTDIR)$(LIBEXECDIR)
-- @echo -e "\nDon't forget to edit your httpd.conf (see README for details):\n \
-- LoadModule musicindex_module $(DESTDIR)$(LIBEXECDIR)/$(MOD_SO)"
-
- # how to compile the objects
- %.o: %.c %.h mod_musicindex.h
diff --git a/www/mod_musicindex/files/pkg-message.in b/www/mod_musicindex/files/pkg-message.in
index 182f8f3b9c3b..5b9254de11d5 100644
--- a/www/mod_musicindex/files/pkg-message.in
+++ b/www/mod_musicindex/files/pkg-message.in
@@ -1,40 +1 @@
-************************************************************
-You've installed mod_musicindex
-
-To enable it, you need to take the following steps:
-
-1) Edit httpd.conf to make sure the module is loaded.
-2) Mod_musicindex looks for a directory called musicindex below
- the apache DocumentRoot. Make sure it finds it by either changing
- the DocumentRoot directive in httpd.conf to %%LOCALBASE%%/www or by
- copying or linking %%LOCALBASE%%/www/musicindex into your DocumentRoot
-3) Add a Directory configuration to your httpd.conf that should look
- something like this:
-
-<Directory "/path/to/you/mp3/files/">
- Options Indexes MultiViews FollowSymlinks
- AllowOverride None
- MusicLister On
- MusicSortOrder album disc track artist title length bitrate freq filetype filename uri
- MusicFields title artist length bitrate
- MusicAllowDownload On
- MusicAllowStream Off
- MusicAllowSearch On
- MusicPageTitle Myname
- MusicCssDefault musicindex.css
- MusicCachePath /tmp/musicindex
- MusicIceServer [ice.domain.my]:8000
- MusicCookieLife 300
-</Directory>
-
-4) Optionally consider setting an alias to your mp3 dir, so you can access
- the files by http://yourhost/music/ :
-
-Alias /music/ /path/to/you/mp3/files/
-
-5) To make your changes effective, restart apache:
-
-# apachectl configtest (see if there are any config errors)
-# apachectl restart
-
-************************************************************
+Read %%DOCSDIR%%/README to find out how to configure apache for %%PORTNAME%%.
diff --git a/www/mod_musicindex/pkg-descr b/www/mod_musicindex/pkg-descr
index 2a8f507362c6..4e7040b8308d 100644
--- a/www/mod_musicindex/pkg-descr
+++ b/www/mod_musicindex/pkg-descr
@@ -1,6 +1,6 @@
mod_musicindex is an Apache module aimed at being a C implementation of
the Perl module Apache::MP3. It allows nice displaying of directories
-containing MP3 or Ogg Vorbis files, including sorting them on various
+containing several kinds of audio files, including sorting them on various
fields, streaming/downloading them, constructing playlists, and searching.
WWW: http://www.parisc-linux.org/~varenet/musicindex/
diff --git a/www/mod_musicindex/pkg-plist b/www/mod_musicindex/pkg-plist
index 788c1125e8ea..5980b4e01af4 100644
--- a/www/mod_musicindex/pkg-plist
+++ b/www/mod_musicindex/pkg-plist
@@ -1,12 +1,16 @@
%%APACHEMODDIR%%/mod_musicindex.so
@exec %D/sbin/apxs -e -A -n musicindex %D/%F
@unexec %D/sbin/apxs -e -A -n musicindex %D/%F
-www/musicindex/directory.png
-www/musicindex/fetch.png
-www/musicindex/general.png
-www/musicindex/musicindex.css
-www/musicindex/right_arrow.gif
-www/musicindex/sound.png
-%%PORTDOCS%%%%DOCSDIR%%/README
-@dirrm www/musicindex
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%DATADIR%%/musicindex.css
+%%DATADIR%%/directory.png
+%%DATADIR%%/fetch.png
+%%DATADIR%%/general.png
+%%DATADIR%%/right_arrow.gif
+%%DATADIR%%/sound.png
+%%DATADIR%%/shuffle.png
+%%DATADIR%%/rss.png
+%%DATADIR%%/fetchok.png
+%%DATADIR%%/soundok.png
+%%NLS%%share/locale/fr/LC_MESSAGES/mod_musicindex.mo
+%%NLS%%share/locale/it/LC_MESSAGES/mod_musicindex.mo
+@dirrm %%DATADIR%%