aboutsummaryrefslogtreecommitdiff
path: root/www/mod_mya
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-06 01:26:57 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-06 01:26:57 +0000
commit5a663af66879a1054425ef0f2238eb91859a12bc (patch)
tree61d35ddf96718790ae8eec7af271bab152e9a4ab /www/mod_mya
parent99db7d149ed52a0d34676337808c58ae77e3726f (diff)
downloadports-5a663af66879a1054425ef0f2238eb91859a12bc.tar.gz
ports-5a663af66879a1054425ef0f2238eb91859a12bc.zip
Add mod_mya 3.0.1,
allows basic authentication data to be stored in a MySQL database. PR: 58252 Approved by: erwin (mentor) (implicitly)
Notes
Notes: svn path=/head/; revision=97421
Diffstat (limited to 'www/mod_mya')
-rw-r--r--www/mod_mya/Makefile41
-rw-r--r--www/mod_mya/distinfo1
-rw-r--r--www/mod_mya/files/patch-mod_mya.c10
-rw-r--r--www/mod_mya/pkg-descr4
-rw-r--r--www/mod_mya/pkg-plist4
5 files changed, 60 insertions, 0 deletions
diff --git a/www/mod_mya/Makefile b/www/mod_mya/Makefile
new file mode 100644
index 000000000000..3ccf5f8a5f4a
--- /dev/null
+++ b/www/mod_mya/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mod_mya
+# Date created: Sun Oct 19
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_mya
+PORTVERSION= 3.0.1
+CATEGORIES= www
+MASTER_SITES= http://www.synthemesc.com/downloads/mod_mya/
+DIST_SUBDIR= apache
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= Allows basic authentication data to be stored in a MySQL database
+
+USE_APACHE= YES
+WITH_APACHE2= YES
+
+USE_MYSQL= YES
+WANT_MYSQL_VER= 323
+
+MYSQL_INC?= ${LOCALBASE}/include/mysql
+MYSQL_LIB?= ${LOCALBASE}/lib/mysql -lmysqlclient
+
+PORTDOCS= AUTHORS README TODO
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -I ${MYSQL_INC} -L ${MYSQL_LIB} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -i -A -n ${PORTNAME:S/mod_//} ${PORTNAME}.la)
+
+.if !defined (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_mya/distinfo b/www/mod_mya/distinfo
new file mode 100644
index 000000000000..c6ce6574e0e5
--- /dev/null
+++ b/www/mod_mya/distinfo
@@ -0,0 +1 @@
+MD5 (apache/mod_mya-3.0.1.tar.gz) = 41885dfdaf5210eb33ed64e13fafc061
diff --git a/www/mod_mya/files/patch-mod_mya.c b/www/mod_mya/files/patch-mod_mya.c
new file mode 100644
index 000000000000..aae945656fc7
--- /dev/null
+++ b/www/mod_mya/files/patch-mod_mya.c
@@ -0,0 +1,10 @@
+--- mod_mya.c.orig Sun Oct 19 16:41:56 2003
++++ mod_mya.c Sun Oct 19 16:42:23 2003
+@@ -41,6 +41,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <stddef.h>
+
+ #include <mysql.h>
+
diff --git a/www/mod_mya/pkg-descr b/www/mod_mya/pkg-descr
new file mode 100644
index 000000000000..361089b24968
--- /dev/null
+++ b/www/mod_mya/pkg-descr
@@ -0,0 +1,4 @@
+mod_mya is an Apache Web Server module allowing basic authentication data to be
+stored in a MySQL database thus deprecating file based configuration.
+
+WWW: http://www.synthemesc.com/mod_mya/
diff --git a/www/mod_mya/pkg-plist b/www/mod_mya/pkg-plist
new file mode 100644
index 000000000000..a9d485c239e8
--- /dev/null
+++ b/www/mod_mya/pkg-plist
@@ -0,0 +1,4 @@
+libexec/apache2/mod_mya.so
+@exec %D/sbin/apxs -e -A -n mya %D/%f
+@unexec %D/sbin/apxs -e -A -n mya %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_mya, you must manually remove"; echo "===> references to it in httpd.conf."