aboutsummaryrefslogtreecommitdiff
path: root/www/mod_mylo
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2001-11-12 02:51:50 +0000
committerAnders Nordby <anders@FreeBSD.org>2001-11-12 02:51:50 +0000
commita87a019bc08e6161cbb2d4fac83da912824c69c1 (patch)
tree5c39f02163dbeee2ccd975e58b97c3d0670b9c32 /www/mod_mylo
parent4417a778f41170679f5eabb971094cd5c89b7c76 (diff)
downloadports-a87a019bc08e6161cbb2d4fac83da912824c69c1.tar.gz
ports-a87a019bc08e6161cbb2d4fac83da912824c69c1.zip
Add mod_mylo, a module for Apache that sends logs directly to a MySQL database
in addition to normal logging. PR: 31576 Approved by: will
Notes
Notes: svn path=/head/; revision=49954
Diffstat (limited to 'www/mod_mylo')
-rw-r--r--www/mod_mylo/Makefile39
-rw-r--r--www/mod_mylo/distinfo1
-rw-r--r--www/mod_mylo/pkg-comment1
-rw-r--r--www/mod_mylo/pkg-descr6
-rw-r--r--www/mod_mylo/pkg-message15
-rw-r--r--www/mod_mylo/pkg-plist6
6 files changed, 68 insertions, 0 deletions
diff --git a/www/mod_mylo/Makefile b/www/mod_mylo/Makefile
new file mode 100644
index 000000000000..7f4f3fc8d41e
--- /dev/null
+++ b/www/mod_mylo/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_mylo
+# Date created: 12 November 2001
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_mylo
+PORTVERSION= 0.2.1
+CATEGORIES= www
+MASTER_SITES= http://www.orakel.ntnu.no/~oyving/code/mod_mylo/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+APXS= ${LOCALBASE}/sbin/apxs
+DOCS= mod_mylo.sql README
+
+do-build:
+ (cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient mod_mylo.c)
+
+do-install:
+ (cd ${WRKSRC} && ${APXS} -i -A -n 'mylo' mod_mylo.so)
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_mylo/distinfo b/www/mod_mylo/distinfo
new file mode 100644
index 000000000000..933826e6dfe4
--- /dev/null
+++ b/www/mod_mylo/distinfo
@@ -0,0 +1 @@
+MD5 (mod_mylo-0.2.1.tgz) = 52e94e3c5af1c5cd7059af1132b69050
diff --git a/www/mod_mylo/pkg-comment b/www/mod_mylo/pkg-comment
new file mode 100644
index 000000000000..05b36f0d2457
--- /dev/null
+++ b/www/mod_mylo/pkg-comment
@@ -0,0 +1 @@
+An Apache module to make Apache log to MySQL
diff --git a/www/mod_mylo/pkg-descr b/www/mod_mylo/pkg-descr
new file mode 100644
index 000000000000..894c2d071781
--- /dev/null
+++ b/www/mod_mylo/pkg-descr
@@ -0,0 +1,6 @@
+This is a module for Apache that sends logs directly to a MySQL database in
+addition to normal logging.
+
+WWW: http://www.orakel.ntnu.no/~oyving/code/mod_mylo/
+
+- Anders Nordby <anders@FreeBSD.org>
diff --git a/www/mod_mylo/pkg-message b/www/mod_mylo/pkg-message
new file mode 100644
index 000000000000..3ee13300ae2d
--- /dev/null
+++ b/www/mod_mylo/pkg-message
@@ -0,0 +1,15 @@
+************************************************************
+You've installed mod_mylo, an Apache module to make Apache
+log to MySQL.
+
+Edit your apache.conf or httpd.conf to enable and setup this
+module. Have a look at the files in
+${PREFIX}/share/doc/mod_mylo for information on how to
+configure it etc.
+
+Then do this to make it work effective:
+
+# apachectl configtest (see if there are any config errors)
+# apachectl restart
+
+************************************************************
diff --git a/www/mod_mylo/pkg-plist b/www/mod_mylo/pkg-plist
new file mode 100644
index 000000000000..4d105b223d64
--- /dev/null
+++ b/www/mod_mylo/pkg-plist
@@ -0,0 +1,6 @@
+libexec/apache/mod_mylo.so
+@exec %D/sbin/apxs -e -A -n mylo %D/%F
+@unexec %D/sbin/apxs -e -A -n mylo %D/%F
+%%PORTDOCS%%share/doc/mod_mylo/mod_mylo.sql
+%%PORTDOCS%%share/doc/mod_mylo/README
+%%PORTDOCS%%@dirrm share/doc/mod_mylo