aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-06-02 10:50:25 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-06-02 10:50:25 +0000
commit98d1940e64f8d2d3dd081652376b3d6386f90b5b (patch)
tree13c871d6aae5a61170adee2a6eca8b1bbb81e51e /www/mod_perl2
parentd1b8e7fd9f30e8a3172242e4fa380c69488f1b0f (diff)
downloadports-98d1940e64f8d2d3dd081652376b3d6386f90b5b.tar.gz
ports-98d1940e64f8d2d3dd081652376b3d6386f90b5b.zip
Update to 1.99r14
PR: 67443 Submitted by: Lars Eggert <lars dot eggert at gmx dot net>
Notes
Notes: svn path=/head/; revision=110663
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile9
-rw-r--r--www/mod_perl2/distinfo4
-rw-r--r--www/mod_perl2/pkg-descr18
-rw-r--r--www/mod_perl2/pkg-plist8
4 files changed, 27 insertions, 12 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 01f132a43d04..c5eaef60f0a1 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_perl
-PORTVERSION= 1.99r13
+PORTVERSION= 1.99r14
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
http://perl.apache.org/dist/old/
@@ -25,9 +25,10 @@ CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs \
MAN3= Apache::Build.3 Apache::Test.3 Apache::TestConfig.3 \
Apache::TestMM.3 Apache::TestReport.3 Apache::TestRequest.3 \
- Apache::TestRun.3 Apache::TestSmoke.3 Apache::TestTrace.3 \
- Apache::TestUtil.3 Bundle::Apache2.3 Bundle::ApacheTest.3 \
- ModPerl::Code.3 ModPerl::Config.3 mod_perl.3
+ Apache::TestRun.3 Apache::TestRunPerl.3 Apache::TestSmoke.3 \
+ Apache::TestTrace.3 Apache::TestUtil.3 Bundle::Apache2.3 \
+ Bundle::ApacheTest.3 ModPerl::CScan.3 ModPerl::Code.3 \
+ ModPerl::Config.3 mod_perl.3
.include <bsd.port.pre.mk>
diff --git a/www/mod_perl2/distinfo b/www/mod_perl2/distinfo
index 6e5af098d48a..e1d34195674e 100644
--- a/www/mod_perl2/distinfo
+++ b/www/mod_perl2/distinfo
@@ -1,2 +1,2 @@
-MD5 (mod_perl-1.99_13.tar.gz) = e8945611cae2fe797ae4bb198c0285b6
-SIZE (mod_perl-1.99_13.tar.gz) = 1197628
+MD5 (mod_perl-1.99_14.tar.gz) = 116dce5c909701b3812ae4ad6d91c6bd
+SIZE (mod_perl-1.99_14.tar.gz) = 1264246
diff --git a/www/mod_perl2/pkg-descr b/www/mod_perl2/pkg-descr
index b88705f98b67..00112d4eef4b 100644
--- a/www/mod_perl2/pkg-descr
+++ b/www/mod_perl2/pkg-descr
@@ -1,7 +1,15 @@
-The Apache/Perl integration project brings together the full power of
-the Perl programming language and the Apache HTTP server. With mod_perl
-it is possible to write Apache modules entirely in Perl. In addition,
-the persistent interpreter embedded in the server avoids the overhead of
-starting an external interpreter and the penalty of Perl start-up time.
+mod_perl brings together the full power of the Perl programming language
+and the Apache HTTP server. You can use Perl to manage Apache, respond to
+requests for web pages and much more.
+
+mod_perl gives you a persistent Perl interpreter embedded in your web
+server. This lets you avoid the overhead of starting an external interpreter
+and avoids the penalty of Perl start-up time, giving you super-fast
+dynamic content.
+
+As you'd expect from the Perl community, there are hundreds of modules
+written for mod_perl, everything from persistent database connections, to
+templating sytems, to complete XML content delivery systems. Web sites like
+Slashdot and Wired Magazine use mod_perl.
WWW: http://perl.apache.org/
diff --git a/www/mod_perl2/pkg-plist b/www/mod_perl2/pkg-plist
index c43795718a76..3bcf1d2fbe1e 100644
--- a/www/mod_perl2/pkg-plist
+++ b/www/mod_perl2/pkg-plist
@@ -12,6 +12,7 @@ include/apache2/modules/perl/modperl_const.h
include/apache2/modules/perl/modperl_constants.h
include/apache2/modules/perl/modperl_directives.h
include/apache2/modules/perl/modperl_env.h
+include/apache2/modules/perl/modperl_error.h
include/apache2/modules/perl/modperl_filter.h
include/apache2/modules/perl/modperl_flags.h
include/apache2/modules/perl/modperl_global.h
@@ -72,6 +73,7 @@ include/apache2/modules/perl/modperl_util.h
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/Bucket.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/Const.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/Date.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/Error.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/Finfo.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/NetLib.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR/OS.pm
@@ -121,6 +123,7 @@ include/apache2/modules/perl/modperl_util.h
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/porting.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl/BuildMM.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl/BuildOptions.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl/CScan.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl/Code.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl/Config.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl/Const.pm
@@ -154,6 +157,8 @@ include/apache2/modules/perl/modperl_util.h
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Const/Const.so
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Date/Date.bs
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Date/Date.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Error/Error.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Error/Error.so
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Finfo/Finfo.bs
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Finfo/Finfo.so
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/NetLib/NetLib.bs
@@ -239,7 +244,7 @@ include/apache2/modules/perl/modperl_util.h
libexec/apache2/mod_perl.so
@unexec rmdir %D/libexec/apache2 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/mod_perl
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Bundle
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Bundle 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/ModPerl/Util
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/ModPerl/Global
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/ModPerl/Const
@@ -281,6 +286,7 @@ libexec/apache2/mod_perl.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/OS
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/NetLib
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Finfo
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Error
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Date
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Const
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Bucket